summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-05-02 20:11:32 +0200
committerMichel Zou2018-05-02 20:11:32 +0200
commit7f5572449b3ae3b92c9c55ab499f333f3f734646 (patch)
tree2ffd64b32ec086caae802faea6152d2eee3dbeb7
parent52c867935462c4f718e80b678f9e02a2685e68df (diff)
downloadaur-7f5572449b3ae3b92c9c55ab499f333f3f734646.tar.gz
jsoncpp fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--vtk-fix-jsoncpp-module.patch40
3 files changed, 50 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d12aed94b97d..dba6ad2231c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Apr 7 15:30:47 UTC 2018
+# Wed May 2 18:11:32 UTC 2018
pkgbase = mingw-w64-paraview
pkgdesc = Parallel Visualization Application using VTK (mingw-w64)
pkgver = 5.5.0
@@ -31,7 +31,9 @@ pkgbase = mingw-w64-paraview
options = !strip
options = staticlibs
source = http://paraview.org/files/v5.5/ParaView-v5.5.0.tar.gz
+ source = vtk-fix-jsoncpp-module.patch
sha256sums = 1b619e326ff574de808732ca9a7447e4cd14e94ae6568f55b6581896cd569dff
+ sha256sums = 86af85dddde9d02877d6eda60c440db3ae903e525238d4dc19be7a25a92597f7
pkgname = mingw-w64-paraview
diff --git a/PKGBUILD b/PKGBUILD
index 4db45a1d06ed..61c0a9be8d81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,10 @@ license=('custom')
depends=('mingw-w64-qt5-xmlpatterns' 'mingw-w64-qt5-tools' 'mingw-w64-boost' 'mingw-w64-glew' 'mingw-w64-expat' 'mingw-w64-freetype2' 'mingw-w64-libjpeg' 'mingw-w64-libxml2' 'mingw-w64-libtheora' 'mingw-w64-libpng' 'mingw-w64-libtiff' 'mingw-w64-zlib' 'mingw-w64-jsoncpp' 'mingw-w64-pugixml' 'mingw-w64-hdf5' 'mingw-w64-lz4' 'mingw-w64-cgns' 'mingw-w64-netcdf-cxx-legacy')
makedepends=('mingw-w64-cmake' 'mingw-w64-eigen')
options=('!buildflags' '!strip' 'staticlibs')
-source=("http://paraview.org/files/v${_majordotminor}/ParaView-v${_pkgver}.tar.gz")
-sha256sums=('1b619e326ff574de808732ca9a7447e4cd14e94ae6568f55b6581896cd569dff')
+source=("http://paraview.org/files/v${_majordotminor}/ParaView-v${_pkgver}.tar.gz"
+ "vtk-fix-jsoncpp-module.patch")
+sha256sums=('1b619e326ff574de808732ca9a7447e4cd14e94ae6568f55b6581896cd569dff'
+ '86af85dddde9d02877d6eda60c440db3ae903e525238d4dc19be7a25a92597f7')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -23,6 +25,9 @@ prepare() {
# https://gitlab.kitware.com/vtk/vtk/merge_requests/4017
sed -i "s|GetLibraryPathForSymbolWin32(\&function)|GetLibraryPathForSymbolWin32(reinterpret_cast<const void*>(\&function))|g" VTK/Common/Misc/vtkResourceFileLocator.h
+
+ # https://gitlab.kitware.com/vtk/vtk/merge_requests/4107
+ patch -p1 -i "${srcdir}/vtk-fix-jsoncpp-module.patch"
}
build() {
diff --git a/vtk-fix-jsoncpp-module.patch b/vtk-fix-jsoncpp-module.patch
new file mode 100644
index 000000000000..3624ed8d5e9f
--- /dev/null
+++ b/vtk-fix-jsoncpp-module.patch
@@ -0,0 +1,40 @@
+From aa336fc4f87fd98a4afb560e7a0f972102c6ace5 Mon Sep 17 00:00:00 2001
+From: Kyle Edwards <kyle.edwards@kitware.com>
+Date: Thu, 22 Mar 2018 10:03:43 -0400
+Subject: [PATCH] Move vtk_module_third_party() call back to the top
+
+The rest of the file depends on VTK_USE_SYSTEM_JSONCPP, which is set
+by the vtk_module_third_party() call. When the call happens at the
+end, and VTK_USE_SYSTEM_JSONCPP is set to true, the rest of the file
+doesn't take this into account because the cache value hasn't been
+created yet. (You only see this on the first run of CMake; if you
+run it again the problem solves itself because the value is already
+in the cache.) This moves the call back to the beginning so that the
+rest of the file uses the correct value.
+---
+ ThirdParty/jsoncpp/CMakeLists.txt | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/ThirdParty/jsoncpp/CMakeLists.txt b/ThirdParty/jsoncpp/CMakeLists.txt
+index 7c3e51705b..6168d911c0 100644
+--- a/VTK/ThirdParty/jsoncpp/CMakeLists.txt
++++ b/VTK/ThirdParty/jsoncpp/CMakeLists.txt
+@@ -1,4 +1,8 @@
+ include(CMakeDependentOption)
++
++vtk_module_third_party(JsonCpp
++ VERSION 0.7.0)
++
+ cmake_dependent_option(VTK_SYSTEM_JSONCPP_SHARED "Whether the system jsoncpp is shared or not" ON VTK_USE_SYSTEM_JSONCPP "${BUILD_SHARED_LIBS}")
+
+ if (VTK_USE_SYSTEM_JSONCPP)
+@@ -18,6 +22,3 @@ if (NOT VTK_INSTALL_NO_DEVELOPMENT)
+ DESTINATION "${VTK_INSTALL_INCLUDE_DIR}"
+ COMPONENT Development)
+ endif ()
+-
+-vtk_module_third_party(JsonCpp
+- VERSION 0.7.0)
+--
+2.14.3
+