summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2021-05-14 08:42:52 +0200
committerMichel Zou2021-05-14 08:42:52 +0200
commit2050a21a7f3eb3e78a41d089a96327414a2100c4 (patch)
tree3f38194ed59c39c33e059488a14301e35a7a1fab
parent468a52a8a5ccfa034fd91338e8fffb18f5f643ee (diff)
downloadaur-2050a21a7f3eb3e78a41d089a96327414a2100c4.tar.gz
ioss
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--ioss.patch40
3 files changed, 5 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7c81c7dafb0..ba864bdcd4c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-paraview-git
pkgdesc = Parallel Visualization Application using VTK (mingw-w64)
- pkgver = r75656.e324073287
+ pkgver = r76017.efd28bec18
pkgrel = 1
url = https://www.paraview.org
arch = any
@@ -42,8 +42,6 @@ pkgbase = mingw-w64-paraview-git
source = git+https://gitlab.kitware.com/paraview/visitbridge.git
source = git+https://gitlab.kitware.com/paraview/icet.git
source = git+https://gitlab.kitware.com/paraview/qttesting.git
- source = ioss.patch
- sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e7f7d805c004..1ec36ca9fc84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-paraview-git
-pkgver=r75656.e324073287
+pkgver=r76017.efd28bec18
pkgrel=1
pkgdesc='Parallel Visualization Application using VTK (mingw-w64)'
arch=('any')
@@ -14,10 +14,10 @@ source=("git+https://gitlab.kitware.com/paraview/paraview.git"
"git+https://gitlab.kitware.com/vtk/vtk.git"
"git+https://gitlab.kitware.com/paraview/visitbridge.git"
"git+https://gitlab.kitware.com/paraview/icet.git"
- "git+https://gitlab.kitware.com/paraview/qttesting.git" ioss.patch)
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+ "git+https://gitlab.kitware.com/paraview/qttesting.git")
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_architectures="x86_64-w64-mingw32 i686-w64-mingw32 x86_64-w64-mingw32"
pkgver () {
cd "${srcdir}/paraview"
@@ -33,7 +33,6 @@ prepare() {
git config submodule.ThirdParty/QtTesting/vtkqttesting.git "$srcdir"/qttesting
git submodule update -f --init
cd VTK
- patch -p1 -i "${srcdir}"/ioss.patch
cd ../ThirdParty/catalyst/vtkcatalyst/catalyst
curl -L https://gitlab.kitware.com/paraview/catalyst/-/merge_requests/7.patch | patch -p1
}
diff --git a/ioss.patch b/ioss.patch
deleted file mode 100644
index f25eaea0dbb8..000000000000
--- a/ioss.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/ThirdParty/ioss/vtkioss/Ioss_FileInfo.C b/ThirdParty/ioss/vtkioss/Ioss_FileInfo.C
-index c4ae4a43c1..f01db288ce 100644
---- a/ThirdParty/ioss/vtkioss/Ioss_FileInfo.C
-+++ b/ThirdParty/ioss/vtkioss/Ioss_FileInfo.C
-@@ -39,7 +39,7 @@
- #include <string>
- #include <tokenize.h>
-
--#ifndef _MSC_VER
-+#ifndef _WIN32
- #include <sys/unistd.h>
- #else
- #include <direct.h>
-@@ -184,7 +184,7 @@ namespace Ioss {
- //: Returns TRUE if we are pointing to a symbolic link
- bool FileInfo::is_symlink() const
- {
--#ifndef _MSC_VER
-+#ifndef _WIN32
- struct stat s
- {
- };
-@@ -317,7 +317,7 @@ namespace Ioss {
-
- std::string FileInfo::realpath() const
- {
--#ifdef _MSC_VER
-+#ifdef _WIN32
- char *path = _fullpath(nullptr, filename_.c_str(), _MAX_PATH);
- #else
- char *path = ::realpath(filename_.c_str(), nullptr);
-@@ -354,7 +354,7 @@ namespace Ioss {
- struct stat st;
- if (stat(path_root.c_str(), &st) != 0) {
- const int mode = 0777; // Users umask will be applied to this.
--#ifdef _MSC_VER
-+#ifdef _WIN32
- if (mkdir(path_root.c_str()) != 0 && errno != EEXIST) {
- #else
- if (mkdir(path_root.c_str(), mode) != 0 && errno != EEXIST) {