summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2016-08-19 15:27:02 -0700
committerSchala2016-08-19 15:27:02 -0700
commit62eeb525738bba84f85da0d48582acfdb7aa1286 (patch)
tree7b3c2cc20269ad2b59471768a64a3fa151f6344d
parentf0a454fc71104a3f0f26f8f0f9ac916263398811 (diff)
downloadaur-62eeb525738bba84f85da0d48582acfdb7aa1286.tar.gz
keep EXEs
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d62f9360db90..bc840ff6af8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Jun 24 01:54:53 UTC 2016
+# Fri Aug 19 22:26:30 UTC 2016
pkgbase = mingw-w64-pcre
pkgdesc = A library that implements Perl 5-style regular expressions (mingw-w64)
pkgver = 8.39
@@ -8,7 +8,13 @@ pkgbase = mingw-w64-pcre
arch = any
license = BSD
makedepends = mingw-w64-configure
+ makedepends = mingw-w64-readline
+ makedepends = mingw-w64-bzip2
+ makedepends = mingw-w64-zlib
depends = mingw-w64-crt
+ optdepends = mingw-w64-readline
+ optdepends = mingw-w64-bzip2
+ optdepends = mingw-w64-zlib
options = staticlibs
options = !strip
options = !buildflags
diff --git a/PKGBUILD b/PKGBUILD
index fc12018e4b13..efaae9b92df2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,10 @@ pkgdesc="A library that implements Perl 5-style regular expressions (mingw-w64)"
arch=(any)
url="http://www.pcre.org/"
license=("BSD")
-makedepends=(mingw-w64-configure)
+makedepends=(mingw-w64-configure mingw-w64-readline mingw-w64-bzip2 mingw-w64-zlib)
depends=(mingw-w64-crt)
options=(staticlibs !strip !buildflags)
+optdepends=(mingw-w64-readline mingw-w64-bzip2 mingw-w64-zlib)
source=("ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-$pkgver.tar.bz2"{,.sig})
validpgpkeys=('45F68D54BBE23FB3039B46E59766E084FB0F43D8') # Philip Hazel
md5sums=('e3fca7650a0556a2647821679d81f585'
@@ -24,7 +25,10 @@ build() {
--enable-unicode-properties \
--enable-jit \
--enable-pcre16 \
- --enable-pcre32
+ --enable-pcre32 \
+ --enable-pcregrep-libz \
+ --enable-pcregrep-libbz2 \
+ --enable-pcretest-libreadline
make
popd
done
@@ -34,9 +38,8 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/pcre-$pkgver/build-${_arch}"
make DESTDIR="$pkgdir" install
- find "$pkgdir/usr/${_arch}" -name '*.exe' -exec rm {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
- rm -r "$pkgdir/usr/${_arch}/share"
done
}