summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2016-06-23 18:55:15 -0700
committerSchala2016-06-23 18:55:15 -0700
commitf0a454fc71104a3f0f26f8f0f9ac916263398811 (patch)
treeb0e39109a27fd0bc97ec60699e9283a7969ae517
parent330bad919e31fd5b1ce8b4aa8486916b70622cd2 (diff)
downloadaur-f0a454fc71104a3f0f26f8f0f9ac916263398811.tar.gz
8.39
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--01-CVE-2016-1283.patch18
-rw-r--r--PKGBUILD24
4 files changed, 12 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d254d3f6830..d62f9360db90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Mar 18 11:35:17 UTC 2016
+# Fri Jun 24 01:54:53 UTC 2016
pkgbase = mingw-w64-pcre
pkgdesc = A library that implements Perl 5-style regular expressions (mingw-w64)
- pkgver = 8.38
- pkgrel = 2
+ pkgver = 8.39
+ pkgrel = 1
url = http://www.pcre.org/
arch = any
license = BSD
@@ -12,12 +12,10 @@ pkgbase = mingw-w64-pcre
options = staticlibs
options = !strip
options = !buildflags
- source = ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-8.38.tar.bz2
- source = ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-8.38.tar.bz2.sig
- source = 01-CVE-2016-1283.patch
- md5sums = 00aabbfe56d5a48b270f999b508c5ad2
+ source = ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-8.39.tar.bz2
+ source = ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-8.39.tar.bz2.sig
+ md5sums = e3fca7650a0556a2647821679d81f585
md5sums = SKIP
- md5sums = 722aba6455a3f0240eaa22289f0176a0
pkgname = mingw-w64-pcre
diff --git a/.gitignore b/.gitignore
index 5012a3480bf6..d6a576c6d1bb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,5 @@ pkg/
src/
*.bz2
*.sig
+*.tar
*.xz
diff --git a/01-CVE-2016-1283.patch b/01-CVE-2016-1283.patch
deleted file mode 100644
index 2c2dad29e929..000000000000
--- a/01-CVE-2016-1283.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Index: pcre_compile.c
-===================================================================
---- a/pcre_compile.c (revision 1635)
-+++ b/pcre_compile.c (revision 1636)
-@@ -7311,7 +7311,12 @@
- so far in order to get the number. If the name is not found, leave
- the value of recno as 0 for a forward reference. */
-
-- else
-+ /* This patch (removing "else") fixes a problem when a reference is
-+ to multiple identically named nested groups from within the nest.
-+ Once again, it is not the "proper" fix, and it results in an
-+ over-allocation of memory. */
-+
-+ /* else */
- {
- ng = cd->named_groups;
- for (i = 0; i < cd->names_found; i++, ng++)
diff --git a/PKGBUILD b/PKGBUILD
index 8e73a1114a85..fc12018e4b13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-pcre
-pkgver=8.38
-pkgrel=2
+pkgver=8.39
+pkgrel=1
pkgdesc="A library that implements Perl 5-style regular expressions (mingw-w64)"
arch=(any)
url="http://www.pcre.org/"
@@ -8,27 +8,13 @@ license=("BSD")
makedepends=(mingw-w64-configure)
depends=(mingw-w64-crt)
options=(staticlibs !strip !buildflags)
-source=("ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-$pkgver.tar.bz2"{,.sig}
-"01-CVE-2016-1283.patch")
+source=("ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-$pkgver.tar.bz2"{,.sig})
validpgpkeys=('45F68D54BBE23FB3039B46E59766E084FB0F43D8') # Philip Hazel
-md5sums=('00aabbfe56d5a48b270f999b508c5ad2'
- 'SKIP'
- '722aba6455a3f0240eaa22289f0176a0')
+md5sums=('e3fca7650a0556a2647821679d81f585'
+ 'SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare() {
- cd "$srcdir/pcre-$pkgver"
- # apply patch from the source array (should be a pacman feature)
- local filename
- for filename in "${source[@]}"; do
- if [[ "$filename" =~ \.patch$ ]]; then
- patch -p1 -N -i "$srcdir/$filename"
- fi
- done
- :
-}
-
build() {
cd "$srcdir/pcre-$pkgver"
for _arch in ${_architectures}; do