summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2022-09-01 20:40:16 +0200
committerMichel Zou2022-09-01 20:40:16 +0200
commit1d37b40739b3c752975eed1d70e889f438189920 (patch)
treec7f2d1b8178b8450e9d6d2d04eda8ffa55007bbc
parent5553580a6d4cd89f1da21b66fd787d0611d599ff (diff)
downloadaur-1d37b40739b3c752975eed1d70e889f438189920.tar.gz
1.7.3272
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD40
2 files changed, 27 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b2d130d809a..b6edda106d55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = mingw-w64-pcsx2
pkgdesc = A Sony PlayStation 2 emulator (mingw-w64)
- pkgver = 1.7.2184
+ pkgver = 1.7.3272
pkgrel = 1
url = https://www.pcsx2.net
arch = any
license = GPL3
makedepends = mingw-w64-cmake
depends = mingw-w64-rapidyaml
- depends = mingw-w64-wxmsw3.1
depends = mingw-w64-xz
depends = mingw-w64-libpng
depends = mingw-w64-soundtouch
+ depends = mingw-w64-qt6-tools
+ depends = mingw-w64-libzip
options = !buildflags
options = !strip
options = staticlibs
- source = git+https://github.com/PCSX2/pcsx2.git#tag=v1.7.2184
+ source = git+https://github.com/PCSX2/pcsx2.git#tag=v1.7.3272
sha256sums = SKIP
pkgname = mingw-w64-pcsx2
diff --git a/PKGBUILD b/PKGBUILD
index 85ad191b56ad..b25ed9022390 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
pkgname=mingw-w64-pcsx2
-pkgver=1.7.2184
+pkgver=1.7.3272
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator (mingw-w64)'
-depends=('mingw-w64-rapidyaml' 'mingw-w64-wxmsw3.1' 'mingw-w64-xz' 'mingw-w64-libpng' 'mingw-w64-soundtouch')
+depends=('mingw-w64-rapidyaml' 'mingw-w64-xz' 'mingw-w64-libpng' 'mingw-w64-soundtouch' 'mingw-w64-qt6-tools' 'mingw-w64-libzip')
makedepends=('mingw-w64-cmake')
options=('!buildflags' '!strip' 'staticlibs')
arch=('any')
@@ -11,34 +11,38 @@ license=('GPL3')
source=("git+https://github.com/PCSX2/pcsx2.git#tag=v${pkgver}")
sha256sums=('SKIP')
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_architectures="x86_64-w64-mingw32"
prepare () {
cd "$srcdir"/pcsx2
git submodule update --force --init --recursive
curl -L https://github.com/PCSX2/pcsx2/pull/5243.patch | patch -p1
- sed -i "/#define _inline /d" common/Pcsx2Defs.h
- sed -i "/#define __forceinline /d" common/Pcsx2Defs.h
- sed -i "/#define CALLBACK /d" common/Pcsx2Defs.h
- sed -i "s|target_sources(common PRIVATE FastJmp.asm)||g" common/CMakeLists.txt
- sed -i "s|FastJmp.asm||g" common/CMakeLists.txt
- sed -i "/__fastcall _aligned_malloc/d" common/AlignedMalloc.h
+ #sed -i "/#define _inline /d" common/Pcsx2Defs.h
+ #sed -i "/#define __forceinline /d" common/Pcsx2Defs.h
+ #sed -i "/#define CALLBACK /d" common/Pcsx2Defs.h
+ #sed -i "s|target_sources(common PRIVATE FastJmp.asm)||g" common/CMakeLists.txt
+ #sed -i "s|FastJmp.asm||g" common/CMakeLists.txt
+ #sed -i "/__fastcall _aligned_malloc/d" common/AlignedMalloc.h
# patched in mingw
- sed -i "s|#include <timeapi.h>||g" common/RedtapeWindows.h
- sed -i "s|ERROR_COMMITMENT_MINIMUM|635|g" common/Windows/WinHostSys.cpp
+ #sed -i "s|#include <timeapi.h>||g" common/RedtapeWindows.h
+ #sed -i "s|ERROR_COMMITMENT_MINIMUM|635|g" common/Windows/WinHostSys.cpp
+
+ #sed -i "s|D3D12MemAlloc|d3d12memalloc|g" cmake/SearchForStuff.cmake
+ #sed -i "s|Win32Update.cpp|Windows/WindowsUpdater.cpp|g" updater/CMakeLists.txt
sed -i "/baseclasses/d" cmake/SearchForStuff.cmake
- cp 3rdparty/baseclasses/schedule.h 3rdparty/baseclasses/Schedule.h
- # unbundle dependencies
- sed -i "/pthreads4w/d" cmake/SearchForStuff.cmake
- sed -i "s|pthreads4w||g" common/CMakeLists.txt
+ #cp 3rdparty/baseclasses/schedule.h 3rdparty/baseclasses/Schedule.h
+ ## unbundle dependencies
+ #sed -i "/pthreads4w/d" cmake/SearchForStuff.cmake
+ #sed -i "s|pthreads4w||g" common/CMakeLists.txt
sed -i "s|add_subdirectory(3rdparty/soundtouch EXCLUDE_FROM_ALL)|include(CheckLib)\ncheck_lib(SOUNDTOUCH SoundTouch SoundTouch.h PATH_SUFFIXES soundtouch)|g" cmake/SearchForStuff.cmake
sed -i "s|add_subdirectory(3rdparty/xz EXCLUDE_FROM_ALL)|find_package(LibLZMA REQUIRED)|g" cmake/SearchForStuff.cmake
sed -i "s|add_subdirectory(3rdparty/zlib EXCLUDE_FROM_ALL)|find_package(ZLIB REQUIRED)|g" cmake/SearchForStuff.cmake
sed -i "s|add_subdirectory(3rdparty/libpng EXCLUDE_FROM_ALL)|find_package(PNG REQUIRED)|g" cmake/SearchForStuff.cmake
sed -i "s|add_subdirectory(3rdparty/libjpeg EXCLUDE_FROM_ALL)|find_package(JPEG REQUIRED)|g" cmake/SearchForStuff.cmake
- sed -i "s|add_subdirectory(3rdparty/wxwidgets3.0 EXCLUDE_FROM_ALL)|find_package(wxWidgets REQUIRED base core adv)\ninclude(\${wxWidgets_USE_FILE})\nmake_imported_target_if_missing(wxWidgets::all wxWidgets)|g" cmake/SearchForStuff.cmake
+ sed -i "s|add_subdirectory(3rdparty/lzma EXCLUDE_FROM_ALL)|find_package(LibLZMA REQUIRED)|g" cmake/SearchForStuff.cmake
+ #sed -i "s|add_subdirectory(3rdparty/wxwidgets3.0 EXCLUDE_FROM_ALL)|find_package(wxWidgets REQUIRED base core adv)\ninclude(\${wxWidgets_USE_FILE})\nmake_imported_target_if_missing(wxWidgets::all wxWidgets)|g" cmake/SearchForStuff.cmake
}
build() {
@@ -52,7 +56,9 @@ build() {
-DDISABLE_SETCAP=ON \
-DENABLE_TESTS=OFF \
-DLTO_PCSX2_CORE=ON \
- -DPACKAGE_MODE=ON \
+ -DPACKAGE_MODE=OFF \
+ -DQT_BUILD=ON \
+ -DUSE_SYSTEM_LIBS=ON \
-DSDL2_API=ON \
-DUSE_SYSTEM_YAML=ON \
-DUSE_VTUNE=OFF \