summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2022-01-01 13:42:02 +0100
committerMichel Zou2022-01-01 13:42:02 +0100
commit5553580a6d4cd89f1da21b66fd787d0611d599ff (patch)
tree9d234703edb35e937b2f02cc1013407385538ce0
parent08919c558c7278117534203c4473e00a69b24d02 (diff)
downloadaur-5553580a6d4cd89f1da21b66fd787d0611d599ff.tar.gz
5243
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6da9f72af67b..2b2d130d809a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = mingw-w64-pcsx2
pkgdesc = A Sony PlayStation 2 emulator (mingw-w64)
- pkgver = 1.7.2183
+ pkgver = 1.7.2184
pkgrel = 1
url = https://www.pcsx2.net
arch = any
license = GPL3
makedepends = mingw-w64-cmake
depends = mingw-w64-rapidyaml
- depends = mingw-w64-wxmsw
+ depends = mingw-w64-wxmsw3.1
depends = mingw-w64-xz
depends = mingw-w64-libpng
depends = mingw-w64-soundtouch
options = !buildflags
options = !strip
options = staticlibs
- source = git+https://github.com/PCSX2/pcsx2.git#tag=v1.7.2183
+ source = git+https://github.com/PCSX2/pcsx2.git#tag=v1.7.2184
sha256sums = SKIP
pkgname = mingw-w64-pcsx2
diff --git a/PKGBUILD b/PKGBUILD
index db1f49845ca7..85ad191b56ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
pkgname=mingw-w64-pcsx2
-pkgver=1.7.2183
+pkgver=1.7.2184
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator (mingw-w64)'
-depends=('mingw-w64-rapidyaml' 'mingw-w64-wxmsw' 'mingw-w64-xz' 'mingw-w64-libpng' 'mingw-w64-soundtouch')
+depends=('mingw-w64-rapidyaml' 'mingw-w64-wxmsw3.1' 'mingw-w64-xz' 'mingw-w64-libpng' 'mingw-w64-soundtouch')
makedepends=('mingw-w64-cmake')
options=('!buildflags' '!strip' 'staticlibs')
arch=('any')
@@ -16,28 +16,23 @@ _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare () {
cd "$srcdir"/pcsx2
git submodule update --force --init --recursive
- sed -i "s|_wstati64|_wstat64|g" common/FileSystem.cpp
- sed -i "s|_fstati64|_fstat64|g" common/FileSystem.cpp
+ curl -L https://github.com/PCSX2/pcsx2/pull/5243.patch | patch -p1
sed -i "/#define _inline /d" common/Pcsx2Defs.h
sed -i "/#define __forceinline /d" common/Pcsx2Defs.h
sed -i "/#define CALLBACK /d" common/Pcsx2Defs.h
- sed -i "s|#if defined(_WIN32)|#if 0|g" common/emitter/cpudetect.cpp
- sed -i "s|#if defined(_WIN32)|#if 0|g" common/x86/MemcpyFast.cpp
- sed -i "s|#if defined(_WIN32)|#if 0|g" common/Windows/WinHostSys.cpp
sed -i "s|target_sources(common PRIVATE FastJmp.asm)||g" common/CMakeLists.txt
sed -i "s|FastJmp.asm||g" common/CMakeLists.txt
- sed -i "s|addr = wglGetProcAddress|addr = (void*)wglGetProcAddress|g" common/GL/ContextWGL.cpp
- sed -i "s|return wglGetProcAddress|return (void*)wglGetProcAddress|g" common/GL/ContextWGL.cpp
- sed -i "s|return ::GetProcAddress|return (void*)::GetProcAddress|g" common/GL/ContextWGL.cpp
sed -i "/__fastcall _aligned_malloc/d" common/AlignedMalloc.h
- sed -i "s|#include <VersionHelpers.h>|#include <versionhelpers.h>|g" common/RedtapeWindows.h
- sed -i "s|#include <ShTypes.h>|#include <shtypes.h>|g" common/RedtapeWindows.h
+
+ # patched in mingw
sed -i "s|#include <timeapi.h>||g" common/RedtapeWindows.h
- cp pcsx2/SPU2/Windows/ConfigSoundtouch.cpp pcsx2/SPU2/Windows/ConfigSoundTouch.cpp
- sed -i "/pthreads4w/d" cmake/SearchForStuff.cmake
+ sed -i "s|ERROR_COMMITMENT_MINIMUM|635|g" common/Windows/WinHostSys.cpp
+
sed -i "/baseclasses/d" cmake/SearchForStuff.cmake
cp 3rdparty/baseclasses/schedule.h 3rdparty/baseclasses/Schedule.h
# unbundle dependencies
+ sed -i "/pthreads4w/d" cmake/SearchForStuff.cmake
+ sed -i "s|pthreads4w||g" common/CMakeLists.txt
sed -i "s|add_subdirectory(3rdparty/soundtouch EXCLUDE_FROM_ALL)|include(CheckLib)\ncheck_lib(SOUNDTOUCH SoundTouch SoundTouch.h PATH_SUFFIXES soundtouch)|g" cmake/SearchForStuff.cmake
sed -i "s|add_subdirectory(3rdparty/xz EXCLUDE_FROM_ALL)|find_package(LibLZMA REQUIRED)|g" cmake/SearchForStuff.cmake
sed -i "s|add_subdirectory(3rdparty/zlib EXCLUDE_FROM_ALL)|find_package(ZLIB REQUIRED)|g" cmake/SearchForStuff.cmake
@@ -61,6 +56,8 @@ build() {
-DSDL2_API=ON \
-DUSE_SYSTEM_YAML=ON \
-DUSE_VTUNE=OFF \
+ -DwxWidgets_INCLUDE_DIR="/usr/${_arch}/include/wx-3.1" \
+ -DwxWidgets_LIBRARIES="/usr/${_arch}/lib/libwx_mswu_adv-3.1-${_arch}.a;/usr/${_arch}/lib/libwx_mswu_core-3.1-${_arch}.a;/usr/${_arch}/lib/libwx_mswu_gl-3.1-${_arch}.a" \
-DWIL_BUILD_TESTS=OFF ..
make
popd