summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2018-07-19 15:49:43 -0400
committerAndrew Sun2018-07-19 15:49:43 -0400
commitaa8210254e200b19d2c1acb90d671c09760e695e (patch)
tree8772ffc49520d5ffb308c68ac562dd1860c02135
parentb5bbee6080d6978e390f2de8edf24ac742e1fdf2 (diff)
downloadaur-aa8210254e200b19d2c1acb90d671c09760e695e.tar.gz
mingw-w64-pdcurses: update to 3.6
-rw-r--r--.SRCINFO16
-rw-r--r--001-mingw-pdcurses-3.6-build.patch42
-rw-r--r--PKGBUILD54
-rw-r--r--mingw-pdcurses-3.4-build.patch63
4 files changed, 82 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 495d280f31b4..d205b10c087b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = mingw-w64-pdcurses
- pkgdesc = Curses library for MinGW-w64
- pkgver = 3.4
- pkgrel = 4
- url = http://pdcurses.sourceforge.net
+ pkgdesc = Public Domain Curses wincon port (mingw-w64)
+ pkgver = 3.6
+ pkgrel = 1
+ url = https://github.com/wmcbrine/PDCurses
arch = any
license = public domain
makedepends = mingw-w64-gcc
@@ -10,10 +10,10 @@ pkgbase = mingw-w64-pdcurses
options = staticlibs
options = !buildflags
options = !strip
- source = http://downloads.sourceforge.net/pdcurses/PDCurses-3.4.tar.gz
- source = mingw-pdcurses-3.4-build.patch
- md5sums = 4e04e4412d1b1392a7f9a489b95b331a
- md5sums = d1a36327155f51a1073b930e3647e4aa
+ source = https://github.com/wmcbrine/PDCurses/archive/3.6.tar.gz
+ source = 001-mingw-pdcurses-3.6-build.patch
+ sha256sums = 1760cbf3c3f254798e3614efa40206f95fe5bb2ca68eb2be434265d995f078eb
+ sha256sums = 98867a357e172cf18f9bd59fc8208f44ebba6e887f6b87522e32cda333cf416d
pkgname = mingw-w64-pdcurses
diff --git a/001-mingw-pdcurses-3.6-build.patch b/001-mingw-pdcurses-3.6-build.patch
new file mode 100644
index 000000000000..cfc8d3220dbe
--- /dev/null
+++ b/001-mingw-pdcurses-3.6-build.patch
@@ -0,0 +1,42 @@
+diff -Naur wincon/Makefile.orig wincon/Makefile
+--- wincon/Makefile.orig 2018-02-13 14:46:44.000000000 +0100
++++ wincon/Makefile 2018-04-05 18:21:09.162821700 +0200
+@@ -26,6 +26,9 @@
+ PDCURSES_WIN_H = $(osdir)/pdcwin.h
+
+ CC = gcc
++AR = ar
++STRIP = strip
++LINK = gcc
+
+ ifeq ($(DEBUG),Y)
+ CFLAGS = -g -Wall -DPDCDEBUG
+@@ -45,17 +48,15 @@
+ CFLAGS += -DPDC_FORCE_UTF8
+ endif
+
+-LINK = gcc
+-
+ ifeq ($(DLL),Y)
+ CFLAGS += -DPDC_DLL_BUILD
+- LIBEXE = gcc
++ LIBEXE = $(CC)
+ LIBFLAGS = -Wl,--out-implib,pdcurses.a -shared -o
+ LIBCURSES = pdcurses.dll
+ LIBDEPS = $(LIBOBJS) $(PDCOBJS)
+ CLEAN = $(LIBCURSES) *.a
+ else
+- LIBEXE = ar
++ LIBEXE = $(AR)
+ LIBFLAGS = rcv
+ LIBCURSES = pdcurses.a
+ LIBDEPS = $(LIBOBJS) $(PDCOBJS)
+@@ -75,7 +76,7 @@
+
+ demos: $(DEMOS)
+ ifneq ($(DEBUG),Y)
+- strip *.exe
++ $(STRIP) *.exe
+ endif
+
+ $(LIBCURSES) : $(LIBDEPS)
diff --git a/PKGBUILD b/PKGBUILD
index 2d41cb8ecbe0..9d18f50237d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,41 @@
+# Maintainer: Andrew Sun <adsun701@gmail.com>
# Contributor: Filip Brcic <brcha@gna.org>
+
pkgname=mingw-w64-pdcurses
-pkgver=3.4
-pkgrel=4
-pkgdesc="Curses library for MinGW-w64"
-arch=(any)
-depends=(mingw-w64-crt)
-makedepends=(mingw-w64-gcc)
+pkgver=3.6
+pkgrel=1
+pkgdesc="Public Domain Curses wincon port (mingw-w64)"
+arch=('any')
+url="https://github.com/wmcbrine/PDCurses"
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-gcc')
options=(staticlibs !buildflags !strip)
license=("public domain")
-url="http://pdcurses.sourceforge.net"
-source=("http://downloads.sourceforge.net/pdcurses/PDCurses-${pkgver}.tar.gz"
- "mingw-pdcurses-3.4-build.patch")
-md5sums=('4e04e4412d1b1392a7f9a489b95b331a'
- 'd1a36327155f51a1073b930e3647e4aa')
+source=("https://github.com/wmcbrine/PDCurses/archive/${pkgver}.tar.gz"
+ "001-mingw-pdcurses-3.6-build.patch")
+sha256sums=('1760cbf3c3f254798e3614efa40206f95fe5bb2ca68eb2be434265d995f078eb'
+ '98867a357e172cf18f9bd59fc8208f44ebba6e887f6b87522e32cda333cf416d')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd "${srcdir}/PDCurses-${pkgver}"
- patch -Np1 -i ${srcdir}/mingw-pdcurses-3.4-build.patch
- sed -i "s|CFLAGS = \-O2 \-Wall|CFLAGS = \-O2 \-g -pipe \-Wall \-Wp,\-D_FORTIFY_SOURCE=2 \-fexceptions \-\-param=ssp\-buffer\-size=4|g" win32/mingwin32.mak
+ cd "${srcdir}/PDCurses-${pkgver}/wincon"
+ patch -Np1 -i ${srcdir}/001-mingw-pdcurses-3.6-build.patch
}
build() {
cd "${srcdir}/PDCurses-${pkgver}"
export CFLAGS="-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
for _arch in ${_architectures}; do
- cp -a win32 build-${_arch} && pushd build-${_arch}
- make -f mingwin32.mak \
+ cp -a wincon build-${_arch} && pushd build-${_arch}
+ make \
CC=${_arch}-gcc \
LINK=${_arch}-gcc \
STRIP=${_arch}-strip \
- WIDE=Y UTF8=Y DLL=Y
+ AR=${_arch}-ar \
+ WIDE=Y \
+ UTF8=Y \
+ DLL=Y
popd
done
}
@@ -39,11 +43,17 @@ build() {
package() {
cd "${srcdir}/PDCurses-${pkgver}"
for _arch in ${_architectures} ; do
- install -d "${pkgdir}"/usr/${_arch}/{bin,lib,include}
- install build-${_arch}/pdcurses.dll "${pkgdir}"/usr/${_arch}/bin/
- install build-${_arch}/pdcurses.a "${pkgdir}"/usr/${_arch}/lib/libpdcurses.dll.a
- install -m 0644 curses.h panel.h term.h "${pkgdir}"/usr/${_arch}/include/
- find "$pkgdir/usr/${_arch}" -name '*.exe' -exec rm {} \;
+ mkdir -p ${pkgdir}/usr/${_arch}/{bin,include,lib}
+ mkdir ${pkgdir}/usr/${_arch}/include/pdcurses
+
+ install build-${_arch}/*.exe ${pkgdir}/usr/${_arch}/bin/
+ install build-${_arch}/pdcurses.dll ${pkgdir}/usr/${_arch}/bin/
+ install build-${_arch}/pdcurses.a ${pkgdir}/usr/${_arch}/lib/libpdcurses.dll.a
+
+ echo '#include "pdcurses/curses.h"' > pdcurses.h
+ install -m 0644 pdcurses.h ${pkgdir}/usr/${_arch}/include/pdcurses.h
+ install -m 0644 curses.h panel.h term.h ${pkgdir}/usr/${_arch}/include/pdcurses/
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
done
diff --git a/mingw-pdcurses-3.4-build.patch b/mingw-pdcurses-3.4-build.patch
deleted file mode 100644
index dc34fe0c1729..000000000000
--- a/mingw-pdcurses-3.4-build.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-diff -Naur PDCurses-3.4.orig/win32/mingwin32.mak PDCurses-3.4/win32/mingwin32.mak
---- PDCurses-3.4.orig/win32/mingwin32.mak 2008-07-21 14:31:36.000000000 +0200
-+++ PDCurses-3.4/win32/mingwin32.mak 2012-04-20 15:28:55.071506378 +0200
-@@ -19,6 +19,7 @@
- PDCURSES_WIN_H = $(osdir)/pdcwin.h
-
- CC = gcc
-+STRIP = strip
-
- ifeq ($(DEBUG),Y)
- CFLAGS = -g -Wall -DPDCDEBUG
-@@ -30,8 +31,8 @@
-
- CFLAGS += -I$(PDCURSES_SRCDIR)
-
--BASEDEF = $(PDCURSES_SRCDIR)\exp-base.def
--WIDEDEF = $(PDCURSES_SRCDIR)\exp-wide.def
-+BASEDEF = $(PDCURSES_SRCDIR)/exp-base.def
-+WIDEDEF = $(PDCURSES_SRCDIR)/exp-wide.def
-
- DEFDEPS = $(BASEDEF)
-
-@@ -50,7 +51,7 @@
-
- ifeq ($(DLL),Y)
- CFLAGS += -DPDC_DLL_BUILD
-- LIBEXE = gcc $(DEFFILE)
-+ LIBEXE = $(CC) $(DEFFILE)
- LIBFLAGS = -Wl,--out-implib,pdcurses.a -shared -o
- LIBCURSES = pdcurses.dll
- LIBDEPS = $(LIBOBJS) $(PDCOBJS) $(DEFFILE)
-@@ -70,24 +71,24 @@
- libs: $(LIBCURSES)
-
- clean:
-- -del *.o
-- -del *.exe
-- -del $(CLEAN)
-+ -rm *.o
-+ -rm *.exe
-+ -rm $(CLEAN)
-
- demos: $(DEMOS)
-- strip *.exe
-+ $(STRIP) *.exe
-
- $(DEFFILE): $(DEFDEPS)
- echo LIBRARY pdcurses > $@
- echo EXPORTS >> $@
-- type $(BASEDEF) >> $@
-+ cat $(BASEDEF) >> $@
- ifeq ($(WIDE),Y)
-- type $(WIDEDEF) >> $@
-+ cat $(WIDEDEF) >> $@
- endif
-
- $(LIBCURSES) : $(LIBDEPS)
- $(LIBEXE) $(LIBFLAGS) $@ $?
-- -copy pdcurses.a panel.a
-+ -cp pdcurses.a panel.a
-
- $(LIBOBJS) $(PDCOBJS) : $(PDCURSES_HEADERS)
- $(PDCOBJS) : $(PDCURSES_WIN_H)