summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Bart2018-06-07 10:51:08 -0300
committerEduardo Bart2018-06-07 10:51:08 -0300
commite3fd8b7b29b4a92c1899813ce669c4c324e82c4e (patch)
treeeed40053481026e9a05e54ba1df9b9035b4e3811
downloadaur-e3fd8b7b29b4a92c1899813ce669c4c324e82c4e.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a1e4b05c61f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mingw-w64-physfs
+ pkgdesc = A library to provide abstract access to various archives (mingw-w64)
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = http://icculus.org/physfs/
+ arch = any
+ license = ZLIB
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-gcc-crt
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-zlib
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ options = !makeflags
+ source = http://icculus.org/physfs/downloads/physfs-3.0.1.tar.bz2
+ sha1sums = 9959a7acad0aa30d1a86d3a418e61155b0ac533c
+
+pkgname = mingw-w64-physfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a6bebc36f50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: edub4rt <edub4rt@gmail.com>
+pkgname=mingw-w64-physfs
+_basename=physfs
+pkgver=3.0.1
+pkgrel=1
+pkgdesc="A library to provide abstract access to various archives (mingw-w64)"
+arch=('any')
+url="http://icculus.org/physfs/"
+license=('ZLIB')
+makedepends=('mingw-w64-gcc' 'mingw-gcc-crt' 'mingw-w64-cmake')
+depends=('mingw-w64-zlib')
+options=(staticlibs '!strip' '!buildflags' '!makeflags')
+source=(http://icculus.org/physfs/downloads/${_basename}-${pkgver}.tar.bz2)
+sha1sums=('9959a7acad0aa30d1a86d3a418e61155b0ac533c')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd $_basename-$pkgver
+ unset LDFLAGS
+ export CFLAGS="$CFLAGS -fno-strict-aliasing"
+ export CXXFLAGS="$CXXFLAGS -fno-strict-aliasing"
+ sed -i 's/-Werror//g' CMakeLists.txt
+ for _arch in ${_architectures}; do
+ rm -rf build-${_arch}
+ mkdir build-${_arch}
+ cd build-${_arch}
+ ${_arch}-cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr/${_arch} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DPHYSFS_BUILD_TEST=OFF \
+ -DPHYSFS_BUILD_WX_TEST=OFF ..
+ make all
+ cd ..
+ done
+}
+
+package() {
+ cd $_basename-$pkgver
+ for _arch in ${_architectures}; do
+ cd build-${_arch}
+ make DESTDIR=${pkgdir} install
+ cd ..
+ done
+}