summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Bart2016-08-03 15:50:43 -0300
committerEduardo Bart2016-08-03 15:50:43 -0300
commite7821d80f0d521cee4ec8cfb92cc661a541339ca (patch)
tree0978a2b9d290008076028c190af30f5d50a03cc8
downloadaur-e7821d80f0d521cee4ec8cfb92cc661a541339ca.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD56
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a74ea637c0fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mingw-w64-physfs-hg
+ pkgdesc = A library to provide abstract access to various archives (mingw-w64)
+ pkgver = 1301
+ pkgrel = 1
+ url = http://icculus.org/physfs/
+ arch = any
+ license = ZLIB
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-cmake
+ makedepends = mercurial
+ depends = mingw-w64-zlib
+ provides = mingw-w64-physfs
+ conflicts = mingw-w64-physfs
+ replaces = mingw-w64-physfs
+ options = !strip
+ options = !buildflags
+ options = !makeflags
+
+pkgname = mingw-w64-physfs-hg \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b67307c270f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: edub4rt <edub4rt@gmail.com>
+pkgname=mingw-w64-physfs-hg
+pkgver=1301
+pkgrel=1
+pkgdesc="A library to provide abstract access to various archives (mingw-w64)"
+arch=('any')
+url="http://icculus.org/physfs/"
+license=('ZLIB')
+makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mercurial')
+depends=('mingw-w64-zlib')
+options=('!strip' '!buildflags' '!makeflags')
+source=()
+sha1sums=()
+provides=(mingw-w64-physfs)
+replaces=(mingw-w64-physfs)
+conflicts=(mingw-w64-physfs)
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_hgroot="http://hg.icculus.org/icculus/physfs"
+_hgrepo="physfs"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to Mercurial server...."
+ if [ -d $_hgrepo ]; then
+ cd $_hgrepo
+ hg pull -u || true
+ msg "The local files are updated."
+ else
+ hg clone $_hgroot $_hgrepo || true
+ fi
+
+ msg "Mercurial checkout done or server timeout"
+ msg "Starting make..."
+
+ unset LDFLAGS
+ export CFLAGS="$CFLAGS -fno-strict-aliasing"
+ export CXXFLAGS="$CXXFLAGS -fno-strict-aliasing"
+ for _arch in ${_architectures}; do
+ rm -rf "$srcdir/$_hgrepo-build-${_arch}"
+ cp -r "$srcdir/$_hgrepo" "$srcdir/$_hgrepo-build-${_arch}"
+ cd "$srcdir/$_hgrepo-build-${_arch}"
+ sed -i 's/-Werror//g' CMakeLists.txt
+ ${_arch}-cmake -DCMAKE_BUILD_TYPE=Release \
+ -DPHYSFS_BUILD_TEST=OFF \
+ -DPHYSFS_BUILD_WX_TEST=OFF .
+ make all
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd ${srcdir}/$_hgrepo-build-${_arch}
+ make DESTDIR=${pkgdir} install
+ done
+} \ No newline at end of file