summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-10-31 13:29:49 +0100
committerMichel Zou2020-10-31 13:29:49 +0100
commit1be87deec30f04abeb4926c80f4e40767de879dc (patch)
treeb08a2d28f35798c28a364cf0d1b71d3cdff7b078
downloadaur-1be87deec30f04abeb4926c80f4e40767de879dc.tar.gz
init
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD43
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf47c0499d53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mingw-w64-piglit-git
+ pkgdesc = OpenGL implementation testing suite. Provides a simple means to perform regression tests. (mingw-w64)
+ pkgver = r11172.59e695c16
+ pkgrel = 1
+ url = http://piglit.freedesktop.org/
+ arch = any
+ license = GPL2
+ license = GPL3
+ license = LGPL2.1
+ makedepends = git
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-freeglut
+ depends = python-mako
+ depends = python-numpy
+ provides = mingw-w64-piglit
+ conflicts = mingw-w64-piglit
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = git+https://gitlab.freedesktop.org/mesa/piglit.git
+ sha256sums = SKIP
+
+pkgname = mingw-w64-piglit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3aebe2a002b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+pkgname=mingw-w64-piglit-git
+pkgver=r11172.59e695c16
+pkgrel=1
+pkgdesc="OpenGL implementation testing suite. Provides a simple means to perform regression tests. (mingw-w64)"
+arch=('any')
+url="http://piglit.freedesktop.org/"
+license=('GPL2' 'GPL3' 'LGPL2.1')
+depends=('mingw-w64-freeglut' 'python-mako' 'python-numpy')
+makedepends=('git' 'mingw-w64-cmake')
+provides=('mingw-w64-piglit')
+conflicts=('mingw-w64-piglit')
+options=('!strip' '!buildflags' 'staticlibs')
+source=("git+https://gitlab.freedesktop.org/mesa/piglit.git")
+sha256sums=('SKIP')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+pkgver() {
+ cd "${srcdir}/piglit"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/piglit"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake -DCMAKE_BUILD_TYPE=Release \
+ -DGLUT_glut_LIBRARY_RELEASE=/usr/${_arch}/lib/libfreeglut.dll.a \
+ -DGLUT_glut_LIBRARY=/usr/${_arch}/lib/libfreeglut.dll.a \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/piglit/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ rm -r "$pkgdir"/usr/${_arch}/share
+ ${_arch}-strip "$pkgdir"/usr/${_arch}/lib/piglit/bin/*.exe
+ done
+}