summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2019-09-10 07:15:36 +0200
committerNicola Murino2019-09-10 07:15:36 +0200
commit064307f197ccb45fc5dc0ab2ae10a33cd69da363 (patch)
tree9cc694784617c1bf84db41541e36a15307c93312
parent1feb89d9e3257bece0fd939515d2dd551a7ba128 (diff)
downloadaur-064307f197ccb45fc5dc0ab2ae10a33cd69da363.tar.gz
enable meson build again and fix static lib
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD43
2 files changed, 43 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f5afa19ce9f..0da1c9bd4538 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-pixman
pkgdesc = The pixel-manipulation library for X and cairo (mingw-w64)
pkgver = 0.38.4
- pkgrel = 5
+ pkgrel = 6
url = http://xorg.freedesktop.org
arch = any
license = custom
@@ -12,7 +12,15 @@ pkgbase = mingw-w64-pixman
options = !strip
options = !buildflags
source = http://xorg.freedesktop.org/releases/individual/lib/pixman-0.38.4.tar.bz2
+ source = https://gitlab.freedesktop.org/pixman/pixman/commit/4851d4e20f66f540cd61fb69851df17671fc90d2.patch
+ source = https://gitlab.freedesktop.org/pixman/pixman/commit/be0d3e699401f8230fa88c28c52d73c57f13f327.patch
+ source = https://gitlab.freedesktop.org/pixman/pixman/commit/fd5c0da57985a430912907d4a898ed1ddb854ead.patch
+ source = https://gitlab.freedesktop.org/pixman/pixman/merge_requests/13.diff
sha256sums = 84abb7fa2541af24d9c3b34bf75d6ac60cc94ac4410061bbb295b66a29221550
+ sha256sums = 381443063e9c55624dc943fde12860a08d5823fc5ce9ae3ae4d9975715f53869
+ sha256sums = 357b1e82b0ea7b4b533625e14759457997eccad9e094a6acf9af94f81f6e0f35
+ sha256sums = 4168be919db45f53666e816ca42c8a99ff210d398b4c6cf26ca7f57de438d8c7
+ sha256sums = 0d7c3b9da2e8f6973aaeae9aedae91e51f383cfd58ca5b6b0d3bcc6162fd3cbd
pkgname = mingw-w64-pixman
diff --git a/PKGBUILD b/PKGBUILD
index 69f47e2786cf..af77ffa71587 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-pixman
pkgver=0.38.4
-pkgrel=5
+pkgrel=6
pkgdesc="The pixel-manipulation library for X and cairo (mingw-w64)"
arch=(any)
url="http://xorg.freedesktop.org"
@@ -9,26 +9,51 @@ license=("custom")
makedepends=(mingw-w64-meson mingw-w64-libpng)
depends=(mingw-w64-gcc)
options=(staticlibs !strip !buildflags)
-source=("http://xorg.freedesktop.org/releases/individual/lib/pixman-${pkgver}.tar.bz2")
-sha256sums=('84abb7fa2541af24d9c3b34bf75d6ac60cc94ac4410061bbb295b66a29221550')
+source=("http://xorg.freedesktop.org/releases/individual/lib/pixman-${pkgver}.tar.bz2"
+ "https://gitlab.freedesktop.org/pixman/pixman/commit/4851d4e20f66f540cd61fb69851df17671fc90d2.patch"
+ "https://gitlab.freedesktop.org/pixman/pixman/commit/be0d3e699401f8230fa88c28c52d73c57f13f327.patch"
+ "https://gitlab.freedesktop.org/pixman/pixman/commit/fd5c0da57985a430912907d4a898ed1ddb854ead.patch"
+ "https://gitlab.freedesktop.org/pixman/pixman/merge_requests/13.diff")
+sha256sums=('84abb7fa2541af24d9c3b34bf75d6ac60cc94ac4410061bbb295b66a29221550'
+ '381443063e9c55624dc943fde12860a08d5823fc5ce9ae3ae4d9975715f53869'
+ '357b1e82b0ea7b4b533625e14759457997eccad9e094a6acf9af94f81f6e0f35'
+ '4168be919db45f53666e816ca42c8a99ff210d398b4c6cf26ca7f57de438d8c7'
+ '0d7c3b9da2e8f6973aaeae9aedae91e51f383cfd58ca5b6b0d3bcc6162fd3cbd')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd ${srcdir}/pixman-${pkgver}
+ patch -Np1 -i ../4851d4e20f66f540cd61fb69851df17671fc90d2.patch
+ patch -Np1 -i ../be0d3e699401f8230fa88c28c52d73c57f13f327.patch
+ patch -Np1 -i ../fd5c0da57985a430912907d4a898ed1ddb854ead.patch
+ patch -Np1 -i ../13.diff
+}
+
build() {
-
for _arch in ${_architectures}; do
mkdir -p "${srcdir}/pixman-${pkgver}/build-${_arch}"
cd "${srcdir}/pixman-${pkgver}/build-${_arch}"
- ${_arch}-configure \
- --disable-gtk ..
- make
+ ${_arch}-meson \
+ -D loongson-mmi=disabled \
+ -D vmx=disabled \
+ -D arm-simd=disabled \
+ -D neon=disabled \
+ -D iwmmxt=disabled \
+ -D mips-dspr2=disabled \
+ -D b_lto=false \
+ -D gtk=disabled \
+ -D strip=false \
+ --default-library both ..
+ ninja
done
}
package() {
for _arch in ${_architectures}; do
- cd "${srcdir}/pixman-${pkgver}/build-${_arch}"
- make DESTDIR="$pkgdir" install
+ # fix static libs inside pc file
+ sed -i "s/-lpixman-mmx -lpixman-sse2 -lpixman-ssse3//g" ${srcdir}/pixman-${pkgver}/build-${_arch}/meson-private/pixman-1.pc
+ DESTDIR="${pkgdir}" ninja -C "${srcdir}/pixman-${pkgver}/build-${_arch}" install
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
done