summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2019-09-09 00:44:42 +0200
committerNicola Murino2019-09-09 00:44:42 +0200
commit1feb89d9e3257bece0fd939515d2dd551a7ba128 (patch)
tree8b967b05ce17bdd78eb7fc2e2e7fa433aedc4eb8
parentff60e0e47c1f2db5fcc0a6ff1820c699f3921bf1 (diff)
downloadaur-1feb89d9e3257bece0fd939515d2dd551a7ba128.tar.gz
switch back to configure until static libs are broken with meson
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD34
2 files changed, 10 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e132b636cfb..2f5afa19ce9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-pixman
pkgdesc = The pixel-manipulation library for X and cairo (mingw-w64)
pkgver = 0.38.4
- pkgrel = 4
+ pkgrel = 5
url = http://xorg.freedesktop.org
arch = any
license = custom
@@ -12,9 +12,7 @@ pkgbase = mingw-w64-pixman
options = !strip
options = !buildflags
source = http://xorg.freedesktop.org/releases/individual/lib/pixman-0.38.4.tar.bz2
- source = https://gitlab.freedesktop.org/creiter/pixman/commit/303c80d69eb72a78d0bb7908d2038cbc3493f3af.patch
sha256sums = 84abb7fa2541af24d9c3b34bf75d6ac60cc94ac4410061bbb295b66a29221550
- sha256sums = d950e6600fc504a7d134829df639439031a07c3da39ff4eaaea2243f299927bc
pkgname = mingw-w64-pixman
diff --git a/PKGBUILD b/PKGBUILD
index 8413183bb627..69f47e2786cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-pixman
pkgver=0.38.4
-pkgrel=4
+pkgrel=5
pkgdesc="The pixel-manipulation library for X and cairo (mingw-w64)"
arch=(any)
url="http://xorg.freedesktop.org"
@@ -9,42 +9,26 @@ license=("custom")
makedepends=(mingw-w64-meson mingw-w64-libpng)
depends=(mingw-w64-gcc)
options=(staticlibs !strip !buildflags)
-source=("http://xorg.freedesktop.org/releases/individual/lib/pixman-${pkgver}.tar.bz2"
- "https://gitlab.freedesktop.org/creiter/pixman/commit/303c80d69eb72a78d0bb7908d2038cbc3493f3af.patch")
-sha256sums=('84abb7fa2541af24d9c3b34bf75d6ac60cc94ac4410061bbb295b66a29221550'
- 'd950e6600fc504a7d134829df639439031a07c3da39ff4eaaea2243f299927bc')
+source=("http://xorg.freedesktop.org/releases/individual/lib/pixman-${pkgver}.tar.bz2")
+sha256sums=('84abb7fa2541af24d9c3b34bf75d6ac60cc94ac4410061bbb295b66a29221550')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare() {
- cd ${srcdir}/pixman-${pkgver}
- patch -Np1 -i ../303c80d69eb72a78d0bb7908d2038cbc3493f3af.patch
-}
-
build() {
+
for _arch in ${_architectures}; do
mkdir -p "${srcdir}/pixman-${pkgver}/build-${_arch}"
cd "${srcdir}/pixman-${pkgver}/build-${_arch}"
- ${_arch}-meson \
- -D loongson-mmi=disabled \
- -D vmx=disabled \
- -D arm-simd=disabled \
- -D neon=disabled \
- -D iwmmxt=disabled \
- -D mips-dspr2=disabled \
- -D b_lto=false \
- -D gtk=disabled \
- -D strip=false \
- --default-library both ..
- ninja
+ ${_arch}-configure \
+ --disable-gtk ..
+ make
done
}
package() {
for _arch in ${_architectures}; do
- # fix static libs inside pc file
- sed -i "s/-lpixman-mmx -lpixman-sse2 -lpixman-ssse3//g" ${srcdir}/pixman-${pkgver}/build-${_arch}/meson-private/pixman-1.pc
- DESTDIR="${pkgdir}" ninja -C "${srcdir}/pixman-${pkgver}/build-${_arch}" install
+ cd "${srcdir}/pixman-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
done