summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2019-09-07 21:15:39 +0200
committerNicola Murino2019-09-07 21:15:39 +0200
commite3a404f299ca3d77acae322cc151420c5380f884 (patch)
tree9e87f02aa3c6135e33ef6c6acc69ccd29661a486
parent86011e3e7a8f527b6275426f22d09aa012e805a9 (diff)
downloadaur-e3a404f299ca3d77acae322cc151420c5380f884.tar.gz
build static libs
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22841e5e4958..d2b3db4c8706 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-pixman
pkgdesc = The pixel-manipulation library for X and cairo (mingw-w64)
pkgver = 0.38.4
- pkgrel = 2
+ pkgrel = 3
url = http://xorg.freedesktop.org
arch = any
license = custom
@@ -12,7 +12,9 @@ pkgbase = mingw-w64-pixman
options = !strip
options = !buildflags
source = http://xorg.freedesktop.org/releases/individual/lib/pixman-0.38.4.tar.bz2
- sha1sums = 87e1abc91ac4e5dfcc275f744f1d0ec3277ee7cd
+ source = https://gitlab.freedesktop.org/creiter/pixman/commit/303c80d69eb72a78d0bb7908d2038cbc3493f3af.patch
+ sha256sums = 84abb7fa2541af24d9c3b34bf75d6ac60cc94ac4410061bbb295b66a29221550
+ sha256sums = d950e6600fc504a7d134829df639439031a07c3da39ff4eaaea2243f299927bc
pkgname = mingw-w64-pixman
diff --git a/PKGBUILD b/PKGBUILD
index be940a8d2e3e..d59e88eeaaee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-pixman
pkgver=0.38.4
-pkgrel=2
+pkgrel=3
pkgdesc="The pixel-manipulation library for X and cairo (mingw-w64)"
arch=(any)
url="http://xorg.freedesktop.org"
@@ -9,11 +9,18 @@ license=("custom")
makedepends=(mingw-w64-meson mingw-w64-libpng)
depends=(mingw-w64-gcc)
options=(staticlibs !strip !buildflags)
-source=("http://xorg.freedesktop.org/releases/individual/lib/pixman-${pkgver}.tar.bz2")
-sha1sums=('87e1abc91ac4e5dfcc275f744f1d0ec3277ee7cd')
+source=("http://xorg.freedesktop.org/releases/individual/lib/pixman-${pkgver}.tar.bz2"
+ "https://gitlab.freedesktop.org/creiter/pixman/commit/303c80d69eb72a78d0bb7908d2038cbc3493f3af.patch")
+sha256sums=('84abb7fa2541af24d9c3b34bf75d6ac60cc94ac4410061bbb295b66a29221550'
+ 'd950e6600fc504a7d134829df639439031a07c3da39ff4eaaea2243f299927bc')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd ${srcdir}/pixman-${pkgver}
+ patch -Np1 -i ../303c80d69eb72a78d0bb7908d2038cbc3493f3af.patch
+}
+
build() {
for _arch in ${_architectures}; do
mkdir -p "${srcdir}/pixman-${pkgver}/build-${_arch}"
@@ -26,13 +33,16 @@ build() {
-D iwmmxt=disabled \
-D mips-dspr2=disabled \
-D b_lto=false \
- -D gtk=disabled ..
+ -D gtk=disabled \
+ --default-library both ..
ninja
done
}
package() {
for _arch in ${_architectures}; do
+ # fix static libs inside pc file
+ sed -i "s/-lpixman-mmx -lpixman-sse2 -lpixman-ssse3//g" ${srcdir}/pixman-${pkgver}/build-${_arch}/meson-private/pixman-1.pc
DESTDIR="${pkgdir}" ninja -C "${srcdir}/pixman-${pkgver}/build-${_arch}" install
# see https://github.com/mesonbuild/meson/issues/4138