summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2019-09-08 05:16:07 +0200
committerNicola Murino2019-09-08 05:16:07 +0200
commitff60e0e47c1f2db5fcc0a6ff1820c699f3921bf1 (patch)
tree70b0a01284508cac55d38e0e0bde4aaa35b72a65
parente3a404f299ca3d77acae322cc151420c5380f884 (diff)
downloadaur-ff60e0e47c1f2db5fcc0a6ff1820c699f3921bf1.tar.gz
disable meson strip option ...
... and strip the library manually. Fixes static libs. A ranlib is not enough here, see: https://github.com/mesonbuild/meson/issues/4138
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2b3db4c8706..7e132b636cfb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-pixman
pkgdesc = The pixel-manipulation library for X and cairo (mingw-w64)
pkgver = 0.38.4
- pkgrel = 3
+ pkgrel = 4
url = http://xorg.freedesktop.org
arch = any
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index d59e88eeaaee..8413183bb627 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-pixman
pkgver=0.38.4
-pkgrel=3
+pkgrel=4
pkgdesc="The pixel-manipulation library for X and cairo (mingw-w64)"
arch=(any)
url="http://xorg.freedesktop.org"
@@ -34,6 +34,7 @@ build() {
-D mips-dspr2=disabled \
-D b_lto=false \
-D gtk=disabled \
+ -D strip=false \
--default-library both ..
ninja
done
@@ -44,9 +45,8 @@ package() {
# fix static libs inside pc file
sed -i "s/-lpixman-mmx -lpixman-sse2 -lpixman-ssse3//g" ${srcdir}/pixman-${pkgver}/build-${_arch}/meson-private/pixman-1.pc
DESTDIR="${pkgdir}" ninja -C "${srcdir}/pixman-${pkgver}/build-${_arch}" install
-
- # see https://github.com/mesonbuild/meson/issues/4138
- ${_arch}-gcc-ranlib ${pkgdir}/usr/${_arch}/lib/*.a
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
done
}