summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-07-20 20:11:16 +0200
committerxantares2015-07-20 20:11:16 +0200
commite3298b7b1838ab2f2111cb6d7d44bfa93fbf6fe8 (patch)
treec04abf37753837da2ad35a8b2a8773294f64f74e
downloadaur-e3298b7b1838ab2f2111cb6d7d44bfa93fbf6fe8.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
-rw-r--r--i686-w64-mingw32-pkg-config21
-rw-r--r--mingw-w64-pkg-config.install5
-rw-r--r--x86_64-w64-mingw32-pkg-config21
5 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..137e29676ab6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-pkg-config
+ pkgdesc = Support pkg-config script (does not depend on any particular version of pkg-config). Useful for pkg-config powered cross-compiling with mingw-w64, see http://tinyurl.com/pkg-config-cross for more info
+ pkgver = 2
+ pkgrel = 3
+ url = http://pkg-config.freedesktop.org/
+ install = mingw-w64-pkg-config.install
+ arch = any
+ license = zlib
+ depends = pkg-config
+ depends = mingw-w64-crt
+ source = x86_64-w64-mingw32-pkg-config
+ source = i686-w64-mingw32-pkg-config
+ md5sums = 7a828d6aa57390613679edb208610045
+ md5sums = 18530650bb2ef89bf91176cedd4ce20b
+
+pkgname = mingw-w64-pkg-config
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e21e0dc9f7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=mingw-w64-pkg-config
+pkgver=2
+pkgrel=3
+pkgdesc='Support pkg-config script (does not depend on any particular version of pkg-config). Useful for pkg-config powered cross-compiling with mingw-w64, see http://tinyurl.com/pkg-config-cross for more info'
+arch=('any')
+url=('http://pkg-config.freedesktop.org/')
+license=('zlib')
+depends=('pkg-config' 'mingw-w64-crt')
+source=('x86_64-w64-mingw32-pkg-config' 'i686-w64-mingw32-pkg-config')
+install='mingw-w64-pkg-config.install'
+md5sums=('7a828d6aa57390613679edb208610045'
+ '18530650bb2ef89bf91176cedd4ce20b')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+package() {
+ # This indeed has to go to the "normal" directory tree
+ install -d -m755 ${pkgdir}/usr/bin
+ for _arch in ${_architectures}; do
+ install -m755 ${_arch}-pkg-config ${pkgdir}/usr/bin
+ done
+}
diff --git a/i686-w64-mingw32-pkg-config b/i686-w64-mingw32-pkg-config
new file mode 100644
index 000000000000..72bde110f24b
--- /dev/null
+++ b/i686-w64-mingw32-pkg-config
@@ -0,0 +1,21 @@
+#!/bin/bash
+
+# Taken from
+# http://www.mega-nerd.com/erikd/Blog/CodeHacking/MinGWCross/pkg-config.html
+# Thanks, Erik
+
+# This file has no copyright assigned and is placed in the Public Domain.
+# No warranty is given.
+
+# When using the mingw32msvc cross compiler tools, the native Linux
+# pkg-config executable works fine as long as the default PKG_CONFIG_LIBDIR
+# is overridden.
+export PKG_CONFIG_LIBDIR=/usr/i686-w64-mingw32/lib/pkgconfig
+
+# Also want to override the standard user defined PKG_CONFIG_PATH with
+# a mingw32msvc specific one.
+# You can use PKG_CONFIG_PATH_CUSTOM to tweak pkg-config behavior further
+export PKG_CONFIG_PATH=$PKG_CONFIG_LIBDIR:$PKG_CONFIG_PATH_CUSTOM
+
+# Now just execute pkg-config with the given command line args.
+pkg-config $@
diff --git a/mingw-w64-pkg-config.install b/mingw-w64-pkg-config.install
new file mode 100644
index 000000000000..9cf1b9fe45a1
--- /dev/null
+++ b/mingw-w64-pkg-config.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo "Note that you can use PKG_CONFIG_PATH_CUSTOM to tweak pkg-config path further"
+ echo "See the x86_64-w64-mingw32-config (or i686-w64-mingw32-config) file itself"
+ echo "for more information"
+}
diff --git a/x86_64-w64-mingw32-pkg-config b/x86_64-w64-mingw32-pkg-config
new file mode 100644
index 000000000000..4101da30e9b7
--- /dev/null
+++ b/x86_64-w64-mingw32-pkg-config
@@ -0,0 +1,21 @@
+#!/bin/bash
+
+# Taken from
+# http://www.mega-nerd.com/erikd/Blog/CodeHacking/MinGWCross/pkg-config.html
+# Thanks, Erik
+
+# This file has no copyright assigned and is placed in the Public Domain.
+# No warranty is given.
+
+# When using the mingw32msvc cross compiler tools, the native Linux
+# pkg-config executable works fine as long as the default PKG_CONFIG_LIBDIR
+# is overridden.
+export PKG_CONFIG_LIBDIR=/usr/x86_64-w64-mingw32/lib/pkgconfig
+
+# Also want to override the standard user defined PKG_CONFIG_PATH with
+# a mingw32msvc specific one.
+# You can use PKG_CONFIG_PATH_CUSTOM to tweak pkg-config behavior further
+export PKG_CONFIG_PATH=$PKG_CONFIG_LIBDIR:$PKG_CONFIG_PATH_CUSTOM
+
+# Now just execute pkg-config with the given command line args.
+pkg-config $@