summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-03-07 19:57:47 +0100
committerMartchus2021-03-07 19:57:47 +0100
commitd2c3d59ec271fe5f0ca9e90978e15548a58307b3 (patch)
treef51823d05a9288a9838e967c60257398c65fdbcf
parentc2d5e43911d907f6912381ac8b2c37e51d9133ae (diff)
downloadaur-d2c3d59ec271fe5f0ca9e90978e15548a58307b3.tar.gz
Update to 13.2
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Use-.dll.a-as-extension-for-import-libraries.patch29
-rw-r--r--0002-Use-pthread-library-from-MinGW.patch25
-rw-r--r--0002-use-mingw-pthread.patch10
-rw-r--r--PKGBUILD12
5 files changed, 58 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1701a83735c..5528f7be7410 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-postgresql
pkgdesc = Sophisticated object-relational DBMS (mingw-w64)
- pkgver = 12.1
+ pkgver = 13.2
pkgrel = 1
url = https://www.postgresql.org
arch = any
@@ -17,12 +17,12 @@ pkgbase = mingw-w64-postgresql
options = staticlibs
options = !strip
options = !buildflags
- source = http://ftp.postgresql.org/pub/source/v12.1/postgresql-12.1.tar.bz2
+ source = http://ftp.postgresql.org/pub/source/v13.2/postgresql-13.2.tar.bz2
source = 0001-Use-.dll.a-as-extension-for-import-libraries.patch
- source = 0002-use-mingw-pthread.patch
- sha256sums = a09bf3abbaf6763980d0f8acbb943b7629a8b20073de18d867aecdb7988483ed
- sha256sums = 1012ccd145b3191d7b3f3362961decc31f42c0dd349e9150e435ed464417d460
- sha256sums = fadddea99386132cc81f5c38b51c36621ede4d3ccb66f4cc26a540c0c9b62bd6
+ source = 0002-Use-pthread-library-from-MinGW.patch
+ sha256sums = 5fd7fcd08db86f5b2aed28fcfaf9ae0aca8e9428561ac547764c2a2b0f41adfc
+ sha256sums = 6119ad2418ce9995acf13b0f095ffa521250bae18cd387083c04e92b6ff22814
+ sha256sums = 55c636400087482f896530e80f07706fff6c5c5b5654955d71944f035940e6a5
pkgname = mingw-w64-postgresql
diff --git a/0001-Use-.dll.a-as-extension-for-import-libraries.patch b/0001-Use-.dll.a-as-extension-for-import-libraries.patch
index a5fd01fb07d5..5e5457873a4c 100644
--- a/0001-Use-.dll.a-as-extension-for-import-libraries.patch
+++ b/0001-Use-.dll.a-as-extension-for-import-libraries.patch
@@ -1,8 +1,18 @@
+From ffc33301366f141f16519fc4999944c93d1e4a61 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sun, 7 Mar 2021 18:22:06 +0100
+Subject: [PATCH 1/2] Use .dll.a as extension for import libraries
+
+---
+ src/Makefile.shlib | 2 +-
+ src/backend/Makefile | 24 ++++++++++++------------
+ 2 files changed, 13 insertions(+), 13 deletions(-)
+
diff --git a/src/Makefile.shlib b/src/Makefile.shlib
-index 373d73c..f1941d4 100644
+index 29a7f6d38c..106139e929 100644
--- a/src/Makefile.shlib
+++ b/src/Makefile.shlib
-@@ -86,7 +86,7 @@ else
+@@ -85,7 +85,7 @@ else
# Naming convention for dynamically loadable modules
shlib = $(NAME)$(DLSUFFIX)
endif
@@ -12,10 +22,10 @@ index 373d73c..f1941d4 100644
ifndef soname
# additional flags for backend modules
diff --git a/src/backend/Makefile b/src/backend/Makefile
-index b03d5e5..e1b8755 100644
+index 9706a95848..21d43c072b 100644
--- a/src/backend/Makefile
+++ b/src/backend/Makefile
-@@ -69,11 +69,11 @@ endif
+@@ -72,11 +72,11 @@ endif
ifeq ($(PORTNAME), cygwin)
postgres: $(OBJS)
@@ -30,7 +40,7 @@ index b03d5e5..e1b8755 100644
touch $@
endif # cygwin
-@@ -82,11 +82,11 @@ ifeq ($(PORTNAME), win32)
+@@ -85,11 +85,11 @@ ifeq ($(PORTNAME), win32)
LIBS += -lsecur32
postgres: $(OBJS) $(WIN32RES)
@@ -45,7 +55,7 @@ index b03d5e5..e1b8755 100644
touch $@
endif # win32
-@@ -195,12 +195,12 @@ distprep:
+@@ -198,12 +198,12 @@ distprep:
install: all installdirs install-bin
ifeq ($(PORTNAME), cygwin)
ifeq ($(MAKE_DLL), true)
@@ -60,7 +70,7 @@ index b03d5e5..e1b8755 100644
endif
endif
$(MAKE) -C catalog install-data
-@@ -260,12 +260,12 @@ ifeq ($(MAKE_EXPORTS), true)
+@@ -263,12 +263,12 @@ ifeq ($(MAKE_EXPORTS), true)
endif
ifeq ($(PORTNAME), cygwin)
ifeq ($(MAKE_DLL), true)
@@ -75,7 +85,7 @@ index b03d5e5..e1b8755 100644
endif
endif
$(MAKE) -C catalog uninstall-data
-@@ -284,10 +284,10 @@ endif
+@@ -287,10 +287,10 @@ endif
clean:
rm -f $(LOCALOBJS) postgres$(X) $(POSTGRES_IMP)
ifeq ($(PORTNAME), cygwin)
@@ -88,3 +98,6 @@ index b03d5e5..e1b8755 100644
endif
distclean: clean
+--
+2.30.1
+
diff --git a/0002-Use-pthread-library-from-MinGW.patch b/0002-Use-pthread-library-from-MinGW.patch
new file mode 100644
index 000000000000..da1c8475c6f1
--- /dev/null
+++ b/0002-Use-pthread-library-from-MinGW.patch
@@ -0,0 +1,25 @@
+From 90d0aca155c9f3fd89afbab6442c91a513bfcd94 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sun, 7 Mar 2021 18:24:32 +0100
+Subject: [PATCH 2/2] Use pthread library from MinGW
+
+---
+ src/interfaces/libpq/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/interfaces/libpq/Makefile b/src/interfaces/libpq/Makefile
+index d4919970f8..ec30bfeb9e 100644
+--- a/src/interfaces/libpq/Makefile
++++ b/src/interfaces/libpq/Makefile
+@@ -66,7 +66,7 @@ OBJS += \
+ win32.o
+
+ ifeq ($(enable_thread_safety), yes)
+-OBJS += pthread-win32.o
++# OBJS += pthread-win32.o
+ endif
+ endif
+
+--
+2.30.1
+
diff --git a/0002-use-mingw-pthread.patch b/0002-use-mingw-pthread.patch
deleted file mode 100644
index ec182f0c7f1f..000000000000
--- a/0002-use-mingw-pthread.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/interfaces/libpq/Makefile 2020-01-07 12:50:48.446033775 +0100
-+++ b/src/interfaces/libpq/Makefile 2020-01-07 12:51:15.381102946 +0100
-@@ -69,7 +69,7 @@
- $(WINDRES) -i $< -o $@
-
- ifeq ($(enable_thread_safety), yes)
--OBJS += pthread-win32.o
-+# OBJS += pthread-win32.o
- endif
- endif
diff --git a/PKGBUILD b/PKGBUILD
index c81e666b8eec..3b8b0a702950 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: ant32 <antreimer@gmail.com>
pkgname=mingw-w64-postgresql
-pkgver=12.1
+pkgver=13.2
pkgrel=1
pkgdesc='Sophisticated object-relational DBMS (mingw-w64)'
arch=('any')
@@ -16,17 +16,17 @@ conflicts=('mingw-w64-postgresql-libs')
replaces=('mingw-w64-postgresql-libs')
source=("http://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2"
'0001-Use-.dll.a-as-extension-for-import-libraries.patch'
- '0002-use-mingw-pthread.patch')
-sha256sums=('a09bf3abbaf6763980d0f8acbb943b7629a8b20073de18d867aecdb7988483ed'
- '1012ccd145b3191d7b3f3362961decc31f42c0dd349e9150e435ed464417d460'
- 'fadddea99386132cc81f5c38b51c36621ede4d3ccb66f4cc26a540c0c9b62bd6')
+ '0002-Use-pthread-library-from-MinGW.patch')
+sha256sums=('5fd7fcd08db86f5b2aed28fcfaf9ae0aca8e9428561ac547764c2a2b0f41adfc'
+ '6119ad2418ce9995acf13b0f095ffa521250bae18cd387083c04e92b6ff22814'
+ '55c636400087482f896530e80f07706fff6c5c5b5654955d71944f035940e6a5')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd postgresql-$pkgver
patch -p1 -i ${srcdir}/0001-Use-.dll.a-as-extension-for-import-libraries.patch
- patch -p1 -i ${srcdir}/0002-use-mingw-pthread.patch
+ patch -p1 -i ${srcdir}/0002-Use-pthread-library-from-MinGW.patch
}
build() {