summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2016-02-21 03:32:36 -0800
committerBuildTools2016-02-21 03:32:36 -0800
commit351ac771a07bf99d56f23b7d544ecd9f529c95d5 (patch)
treed0ca5b30704bfba91c2cec8986a45e6561e642c1
parent761cf3f9344ae46b1181425f730f0d6799a9bbe8 (diff)
downloadaur-351ac771a07bf99d56f23b7d544ecd9f529c95d5.tar.gz
9.5.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
-rw-r--r--postgresql-9.4.1-pl-perl.patch40
-rw-r--r--postgresql-9.4.1-pl-python.patch48
-rw-r--r--postgresql-9.4.1-pl-tcl.patch48
5 files changed, 9 insertions, 158 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39627952a6c9..b8a88a689bfc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Feb 21 11:32:15 UTC 2016
pkgbase = mingw-w64-postgresql-libs
pkgdesc = Libraries for use with PostgreSQL (mingw-w64)
- pkgver = 9.4.5
+ pkgver = 9.5.1
pkgrel = 1
url = http://www.postgresql.org
arch = any
@@ -13,16 +15,10 @@ pkgbase = mingw-w64-postgresql-libs
options = staticlibs
options = !strip
options = !buildflags
- source = http://ftp.postgresql.org/pub/source/v9.4.5/postgresql-9.4.5.tar.bz2
+ source = http://ftp.postgresql.org/pub/source/v9.5.1/postgresql-9.5.1.tar.bz2
source = postgresql-9.4.1-mingw-link.patch
- source = postgresql-9.4.1-pl-perl.patch
- source = postgresql-9.4.1-pl-python.patch
- source = postgresql-9.4.1-pl-tcl.patch
- sha256sums = b87c50c66b6ea42a9712b5f6284794fabad0616e6ae420cf0f10523be6d94a39
+ sha256sums = 6b309d8506a39773a752ff074f47656e5424576ea090b04a24fe1725958c5bd2
sha256sums = 0f2b5c7edb48dd106900854c9323ca2d483054595c4cf8a5b796a1d536d22aad
- sha256sums = 86a12775cdf66cb174def103d6c7add095b473fd7f9038858e09564046d2b091
- sha256sums = 0aa6c34fa7a34c99ef9135dcee8d3f6de45ee14dd29b6a09106834e32dc6c883
- sha256sums = a57b6e7500d2d3daa89162ef98f5e5cb9a082a2123b53f31b4060e774fd1a0c0
pkgname = mingw-w64-postgresql-libs
diff --git a/PKGBUILD b/PKGBUILD
index 7622dee451c9..9568ac48661e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Contributor: ant32 <antreimer@gmail.com>
pkgname=mingw-w64-postgresql-libs
-pkgver=9.4.5
+pkgver=9.5.1
pkgrel=1
pkgdesc="Libraries for use with PostgreSQL (mingw-w64)"
arch=(any)
@@ -10,24 +10,15 @@ makedepends=(mingw-w64-configure libxml2)
depends=(mingw-w64-gettext "mingw-w64-openssl>=1.0.0" mingw-w64-libxml2)
options=(staticlibs !strip !buildflags)
source=("http://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2"
-"postgresql-9.4.1-mingw-link.patch"
-"postgresql-9.4.1-pl-perl.patch"
-"postgresql-9.4.1-pl-python.patch"
-"postgresql-9.4.1-pl-tcl.patch")
-sha256sums=('b87c50c66b6ea42a9712b5f6284794fabad0616e6ae420cf0f10523be6d94a39'
- '0f2b5c7edb48dd106900854c9323ca2d483054595c4cf8a5b796a1d536d22aad'
- '86a12775cdf66cb174def103d6c7add095b473fd7f9038858e09564046d2b091'
- '0aa6c34fa7a34c99ef9135dcee8d3f6de45ee14dd29b6a09106834e32dc6c883'
- 'a57b6e7500d2d3daa89162ef98f5e5cb9a082a2123b53f31b4060e774fd1a0c0')
+"postgresql-9.4.1-mingw-link.patch")
+sha256sums=('6b309d8506a39773a752ff074f47656e5424576ea090b04a24fe1725958c5bd2'
+ '0f2b5c7edb48dd106900854c9323ca2d483054595c4cf8a5b796a1d536d22aad')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd postgresql-$pkgver
patch -p1 -i ${srcdir}/postgresql-9.4.1-mingw-link.patch
- patch -p1 -i ${srcdir}/postgresql-9.4.1-pl-perl.patch
- patch -p1 -i ${srcdir}/postgresql-9.4.1-pl-python.patch
- patch -p1 -i ${srcdir}/postgresql-9.4.1-pl-tcl.patch
}
build() {
diff --git a/postgresql-9.4.1-pl-perl.patch b/postgresql-9.4.1-pl-perl.patch
deleted file mode 100644
index dd8c2314f4a6..000000000000
--- a/postgresql-9.4.1-pl-perl.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- postgresql-9.4.1/src/pl/plperl/GNUmakefile.orig 2015-02-10 21:34:31.287600000 +0300
-+++ postgresql-9.4.1/src/pl/plperl/GNUmakefile 2015-02-10 21:35:06.732800000 +0300
-@@ -36,27 +36,6 @@
-
- PERLCHUNKS = plc_perlboot.pl plc_trusted.pl
-
--# Perl on win32 ships with import libraries only for Microsoft Visual C++,
--# which are not compatible with mingw gcc. Therefore we need to build a
--# new import library to link with.
--ifeq ($(PORTNAME), win32)
--
--perlwithver := $(subst -l,,$(filter -l%, $(perl_embed_ldflags)))
--PERLDLL := $(dir $(subst ',,$(PERL)))$(perlwithver).dll
--# we no longer want to include the original -l spec in SHLIB_LINK
--override perl_embed_ldflags :=
--
--OBJS += lib$(perlwithver).a
--
--lib$(perlwithver).a: $(perlwithver).def
-- dlltool --dllname $(perlwithver).dll --def $(perlwithver).def --output-lib lib$(perlwithver).a
--
--$(perlwithver).def: $(PERLDLL)
-- pexports $^ > $@
--
--endif # win32
--
--
- SHLIB_LINK = $(perl_embed_ldflags)
-
- REGRESS_OPTS = --dbname=$(PL_TESTDB) --load-extension=plperl --load-extension=plperlu
-@@ -126,9 +105,6 @@
- clean distclean maintainer-clean: clean-lib
- rm -f SPI.c Util.c $(OBJS) perlchunks.h plperl_opmask.h
- rm -rf $(pg_regress_clean_files)
--ifeq ($(PORTNAME), win32)
-- rm -f $(perlwithver).def
--endif
-
- else # can't build
-
diff --git a/postgresql-9.4.1-pl-python.patch b/postgresql-9.4.1-pl-python.patch
deleted file mode 100644
index aa2aabda399b..000000000000
--- a/postgresql-9.4.1-pl-python.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- postgresql-9.4.1/src/pl/plpython/Makefile.orig 2015-02-02 23:42:55.000000000 +0300
-+++ postgresql-9.4.1/src/pl/plpython/Makefile 2015-02-10 21:33:26.353400000 +0300
-@@ -27,8 +27,6 @@
- # and we have to remove -lpython from the link since we are building our own
- ifeq ($(PORTNAME), win32)
- shared_libpython = yes
--python_includespec := $(subst \,/,$(python_includespec))
--override python_libspec =
- endif
-
- # If we don't have a shared library, we have to skip it.
-@@ -59,26 +57,6 @@
- DATA += plpythonu.control plpythonu--1.0.sql plpythonu--unpackaged--1.0.sql
- endif
-
--
--# Python on win32 ships with import libraries only for Microsoft Visual C++,
--# which are not compatible with mingw gcc. Therefore we need to build a
--# new import library to link with.
--ifeq ($(PORTNAME), win32)
--
--pytverstr=$(subst .,,${python_version})
--PYTHONDLL=$(subst \,/,$(WINDIR))/system32/python${pytverstr}.dll
--
--OBJS += libpython${pytverstr}.a
--
--libpython${pytverstr}.a: python${pytverstr}.def
-- dlltool --dllname python${pytverstr}.dll --def python${pytverstr}.def --output-lib libpython${pytverstr}.a
--
--python${pytverstr}.def:
-- pexports $(PYTHONDLL) > $@
--
--endif # win32
--
--
- SHLIB_LINK = $(python_libspec) $(python_additional_libs) $(filter -lintl,$(LIBS))
-
- REGRESS_OPTS = --dbname=$(PL_TESTDB)
-@@ -187,9 +165,6 @@
- clean distclean: clean-lib
- rm -f $(OBJS)
- rm -rf $(pg_regress_clean_files)
--ifeq ($(PORTNAME), win32)
-- rm -f python${pytverstr}.def
--endif
-
- else # can't build
-
diff --git a/postgresql-9.4.1-pl-tcl.patch b/postgresql-9.4.1-pl-tcl.patch
deleted file mode 100644
index 99e62633a9bf..000000000000
--- a/postgresql-9.4.1-pl-tcl.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- postgresql-9.4.1/src/pl/tcl/Makefile.orig 2015-02-10 21:23:07.259800000 +0300
-+++ postgresql-9.4.1/src/pl/tcl/Makefile 2015-02-10 21:24:31.189800000 +0300
-@@ -29,9 +29,10 @@
- endif
-
-
-+SHLIB_LINK = $(TCL_LIB_SPEC) $(TCL_LIBS)
- # On Windows, we don't link directly with the Tcl library; see below
- ifneq ($(PORTNAME), win32)
--SHLIB_LINK = $(TCL_LIB_SPEC) $(TCL_LIBS) -lc
-+SHLIB_LINK += -lc
- endif
-
-
-@@ -47,25 +48,6 @@
- # where to find psql for running the tests
- PSQLDIR = $(bindir)
-
--# Tcl on win32 ships with import libraries only for Microsoft Visual C++,
--# which are not compatible with mingw gcc. Therefore we need to build a
--# new import library to link with.
--ifeq ($(PORTNAME), win32)
--
--tclwithver = $(subst -l,,$(filter -l%, $(TCL_LIB_SPEC)))
--TCLDLL = $(dir $(TCLSH))/$(tclwithver).dll
--
--OBJS += lib$(tclwithver).a
--
--lib$(tclwithver).a: $(tclwithver).def
-- dlltool --dllname $(tclwithver).dll --def $(tclwithver).def --output-lib lib$(tclwithver).a
--
--$(tclwithver).def: $(TCLDLL)
-- pexports $^ > $@
--
--endif # win32
--
--
- include $(top_srcdir)/src/Makefile.shlib
-
- ifeq ($(TCL_SHARED_BUILD), 1)
-@@ -116,7 +98,4 @@
- clean distclean maintainer-clean: clean-lib
- rm -f $(OBJS)
- rm -rf $(pg_regress_clean_files)
--ifeq ($(PORTNAME), win32)
-- rm -f $(tclwithver).def
--endif
- $(MAKE) -C modules $@