summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2021-09-24 17:55:26 +0200
committerMichel Zou2021-09-24 17:55:26 +0200
commitcbacaa7313087e6238729aee330e8f56cf8ef331 (patch)
tree4942faead77dc8a4e0a5532ce502e8d1809c5c02
downloadaur-cbacaa7313087e6238729aee330e8f56cf8ef331.tar.gz
7.6
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ada1a274b5e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mingw-w64-primesieve
+ pkgdesc = Fast prime number generator (mingw-w64)
+ pkgver = 7.6
+ pkgrel = 1
+ url = https://github.com/kimwalisch/primesieve
+ arch = any
+ license = BSD
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-crt
+ options = !buildflags
+ options = !strip
+ options = staticlibs
+ source = https://github.com/kimwalisch/primesieve/archive/v7.6.tar.gz
+ sha256sums = 485669e8f9a6c74e528947d274df705f13caaf276d460d0f037b8dbc0c9c0a99
+
+pkgname = mingw-w64-primesieve
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b8c8e011ece
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=mingw-w64-primesieve
+pkgver=7.6
+pkgrel=1
+pkgdesc="Fast prime number generator (mingw-w64)"
+url="https://github.com/kimwalisch/primesieve"
+license=(BSD)
+arch=('any')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-cmake')
+options=('!buildflags' '!strip' 'staticlibs')
+source=("https://github.com/kimwalisch/primesieve/archive/v$pkgver.tar.gz")
+sha256sums=('485669e8f9a6c74e528947d274df705f13caaf276d460d0f037b8dbc0c9c0a99')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "$srcdir/primesieve-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir/primesieve-${pkgver}/build-${_arch}"
+ make install DESTDIR="$pkgdir"
+ rm -r "$pkgdir"/usr/${_arch}/share
+ rm "$pkgdir"/usr/${_arch}/bin/*.exe
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}