summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenoit Favre2015-06-26 07:57:37 +0200
committerBenoit Favre2015-06-26 07:57:37 +0200
commit63ef106a47a2d6f6bfe961c2509431f21cc0fc4d (patch)
tree9506586ab8a4ec949757fd2cce35ebcfa87c5899
downloadaur-63ef106a47a2d6f6bfe961c2509431f21cc0fc4d.tar.gz
Initial import
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
3 files changed, 79 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..18ca947da5bd
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-protobuf
+ pkgdesc = Protocol Buffers - Google's data interchange format
+ pkgver = 2.6.1
+ pkgrel = 1
+ url = https://developers.google.com/protocol-buffers/
+ arch = any
+ license = BSD
+ makedepends = mingw-w64-gcc
+ makedepends = protobuf
+ depends = mingw-w64-crt
+ depends = mingw-w64-zlib
+ source = https://github.com/google/protobuf/releases/download/v2.6.1/protobuf-2.6.1.tar.bz2
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+
+pkgname = mingw-w64-protobuf
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6bbb85f9758c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mingw-w64-protobuf
+ pkgdesc = Protocol Buffers - Google's data interchange format
+ pkgver = 2.6.1
+ pkgrel = 1
+ url = https://developers.google.com/protocol-buffers/
+ arch = any
+ license = BSD
+ makedepends = mingw-w64-gcc
+ makedepends = protobuf
+ depends = mingw-w64-crt
+ depends = mingw-w64-zlib
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://github.com/google/protobuf/releases/download/v2.6.1/protobuf-2.6.1.tar.bz2
+ md5sums = 11aaac2d704eef8efd1867a807865d85
+
+pkgname = mingw-w64-protobuf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c212f19163a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Benoit Favre <benoit.favre@gmail.com>
+
+pkgname=('mingw-w64-protobuf')
+_pkgname=protobuf
+pkgver=2.6.1
+pkgrel=1
+pkgdesc="Protocol Buffers - Google's data interchange format"
+arch=('any')
+url='https://developers.google.com/protocol-buffers/'
+license=('BSD')
+depends=('mingw-w64-crt' 'mingw-w64-zlib')
+makedepends=('mingw-w64-gcc' 'protobuf')
+options=(!strip !buildflags staticlibs)
+source=(https://github.com/google/protobuf/releases/download/v$pkgver/protobuf-$pkgver.tar.bz2)
+md5sums=('11aaac2d704eef8efd1867a807865d85')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch}
+ pushd build-${_arch}
+ ${_arch}-configure --with-protoc=/usr/bin/protoc
+ make
+ popd
+ done
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ find ${pkgdir}/usr/${_arch} -name \*.a | xargs ${_arch}-strip -g
+ find ${pkgdir}/usr/${_arch} -name \*.dll | xargs ${_arch}-strip --strip-unneeded
+ rm -f ${pkgdir}/usr/${_arch}/bin/*.exe
+ popd
+ done
+}
+