summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-01-28 11:53:11 +0100
committerMichel Zou2018-01-28 11:53:11 +0100
commit0506c30fc1c82c2aaf1972d3080bd54fdc7af1d6 (patch)
treea7181ad17e14a08d5819a012aacabc2e49b31b54
parent72431330647991fe2fae0997057dee5d1e0253df (diff)
downloadaur-0506c30fc1c82c2aaf1972d3080bd54fdc7af1d6.tar.gz
1.8
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3edd32b73b9f..4cb868033c7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Jan 28 10:53:11 UTC 2018
pkgbase = mingw-w64-pugixml
pkgdesc = Light-weight, simple and fast XML parser for C++ with XPath support (mingw-w64)
- pkgver = 1.7
+ pkgver = 1.8
pkgrel = 1
url = http://pugixml.org/
arch = any
@@ -10,8 +12,8 @@ pkgbase = mingw-w64-pugixml
options = !buildflags
options = staticlibs
options = !strip
- source = http://github.com/zeux/pugixml/releases/download/v1.7/pugixml-1.7.tar.gz
- md5sums = 17e6a3996de2942629dce65db1a701c5
+ source = http://github.com/zeux/pugixml/releases/download/v1.8/pugixml-1.8.tar.gz
+ sha256sums = 8ef26a51c670fbe79a71e9af94df4884d5a4b00a2db38a0608a87c14113b2904
pkgname = mingw-w64-pugixml
diff --git a/PKGBUILD b/PKGBUILD
index 5340a8658838..9595291b7d51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Jesse Juhani Jaara <gmail.com: jesse.jaara>
+# Contributor: Jesse Juhani Jaara <gmail.com: jesse.jaara>
pkgname=mingw-w64-pugixml
-pkgver=1.7
+pkgver=1.8
pkgrel=1
pkgdesc="Light-weight, simple and fast XML parser for C++ with XPath support (mingw-w64)"
arch=('any')
@@ -11,27 +11,26 @@ depends=('mingw-w64-crt')
makedepends=('mingw-w64-cmake')
options=('!buildflags' 'staticlibs' '!strip')
source=("http://github.com/zeux/pugixml/releases/download/v${pkgver}/pugixml-${pkgver}.tar.gz")
-md5sums=('17e6a3996de2942629dce65db1a701c5')
+sha256sums=('8ef26a51c670fbe79a71e9af94df4884d5a4b00a2db38a0608a87c14113b2904')
+
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/pugixml-${pkgver}"
for _arch in ${_architectures}; do
- unset LDFLAGS
mkdir -p build-${_arch}-static && pushd build-${_arch}-static
- ${_arch}-cmake -DCMAKE_BUILD_TYPE=Release \
- -DLIB_INSTALL_DIR=lib \
- -DBUILD_SHARED_LIBS=OFF \
- ../scripts
+ ${_arch}-cmake \
+ -DLIB_INSTALL_DIR=lib \
+ -DBUILD_SHARED_LIBS=OFF \
+ ..
make
popd
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake -DCMAKE_BUILD_TYPE=Release \
- -DLIB_INSTALL_DIR=lib \
- -DDBUILD_SHARED_LIBS=ON \
- ../scripts
+ ${_arch}-cmake \
+ -DLIB_INSTALL_DIR=lib \
+ ..
make
popd
done