summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse Jaara2015-06-20 18:06:03 +0300
committerJesse Jaara2015-06-20 18:06:03 +0300
commit63f1c1f375f50f76c0fe3b8f27cdde9ddea16226 (patch)
tree291541e46ec841f1479647543e42c5434131270e
downloadaur-63f1c1f375f50f76c0fe3b8f27cdde9ddea16226.tar.gz
Create ming-w64-pugixml package.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc4c05b63a2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-pugixml
+ pkgdesc = Light-weight, simple and fast XML parser for C++ with XPath support (mingw-w64)
+ pkgver = 1.6
+ pkgrel = 1
+ url = http://pugixml.org/
+ arch = any
+ license = MIT
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-crt
+ options = !buildflags
+ options = staticlibs
+ options = !strip
+ source = http://github.com/zeux/pugixml/releases/download/v1.6/pugixml-1.6.tar.gz
+ md5sums = 7fe3667bb6bf123f65cdf2f5cfe4732f
+
+pkgname = mingw-w64-pugixml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..768f03820d43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Jesse Juhani Jaara <gmail.com: jesse.jaara>
+
+pkgname=mingw-w64-pugixml
+pkgver=1.6
+pkgrel=1
+pkgdesc="Light-weight, simple and fast XML parser for C++ with XPath support (mingw-w64)"
+arch=('any')
+url="http://pugixml.org/"
+license=('MIT')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-cmake')
+options=('!buildflags' 'staticlibs' '!strip')
+source=("http://github.com/zeux/pugixml/releases/download/v${pkgver}/pugixml-${pkgver}.tar.gz")
+md5sums=('7fe3667bb6bf123f65cdf2f5cfe4732f')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/pugixml-${pkgver}"
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+
+ mkdir -p build-${_arch}-static && pushd build-${_arch}-static
+ ${_arch}-cmake -DCMAKE_BUILD_TYPE=Release \
+ -DLIB_INSTALL_DIR=lib \
+ -DBUILD_SHARED_LIBS=OFF \
+ ../scripts
+ make
+ popd
+
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake -DCMAKE_BUILD_TYPE=Release \
+ -DLIB_INSTALL_DIR=lib \
+ -DDBUILD_SHARED_LIBS=ON \
+ ../scripts
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/pugixml-${pkgver}/build-${_arch}-static"
+ make install DESTDIR="$pkgdir"
+
+ cd "${srcdir}/pugixml-${pkgver}/build-${_arch}"
+ make install DESTDIR="$pkgdir"
+
+ ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
+ done
+}