summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-03-04 10:22:20 +0100
committerMichel Zou2018-03-04 10:22:20 +0100
commit9d766d8d948a1e3bfc56c6f48bd9b8aa98b82c20 (patch)
tree78076933c97f1d2e6ac66107b23f769802686ddd
parent0506c30fc1c82c2aaf1972d3080bd54fdc7af1d6 (diff)
downloadaur-9d766d8d948a1e3bfc56c6f48bd9b8aa98b82c20.tar.gz
1.8.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cb868033c7f..4c3ad51133bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Jan 28 10:53:11 UTC 2018
+# Sun Mar 4 09:22:20 UTC 2018
pkgbase = mingw-w64-pugixml
pkgdesc = Light-weight, simple and fast XML parser for C++ with XPath support (mingw-w64)
- pkgver = 1.8
+ pkgver = 1.8.1
pkgrel = 1
url = http://pugixml.org/
arch = any
@@ -12,8 +12,8 @@ pkgbase = mingw-w64-pugixml
options = !buildflags
options = staticlibs
options = !strip
- source = http://github.com/zeux/pugixml/releases/download/v1.8/pugixml-1.8.tar.gz
- sha256sums = 8ef26a51c670fbe79a71e9af94df4884d5a4b00a2db38a0608a87c14113b2904
+ source = http://github.com/zeux/pugixml/releases/download/v1.8.1/pugixml-1.8.1.tar.gz
+ sha256sums = 00d974a1308e85ca0677a981adc1b2855cb060923181053fb0abf4e2f37b8f39
pkgname = mingw-w64-pugixml
diff --git a/PKGBUILD b/PKGBUILD
index 9595291b7d51..c3310f81cef8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Contributor: Jesse Juhani Jaara <gmail.com: jesse.jaara>
pkgname=mingw-w64-pugixml
-pkgver=1.8
+_majordotminor=1.8
+pkgver=${_majordotminor}.1
pkgrel=1
pkgdesc="Light-weight, simple and fast XML parser for C++ with XPath support (mingw-w64)"
arch=('any')
@@ -12,11 +13,11 @@ makedepends=('mingw-w64-cmake')
options=('!buildflags' 'staticlibs' '!strip')
source=("http://github.com/zeux/pugixml/releases/download/v${pkgver}/pugixml-${pkgver}.tar.gz")
sha256sums=('8ef26a51c670fbe79a71e9af94df4884d5a4b00a2db38a0608a87c14113b2904')
-
+sha256sums=('00d974a1308e85ca0677a981adc1b2855cb060923181053fb0abf4e2f37b8f39')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- cd "${srcdir}/pugixml-${pkgver}"
+ cd "${srcdir}/pugixml-${_majordotminor}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch}-static && pushd build-${_arch}-static
@@ -38,10 +39,10 @@ build() {
package() {
for _arch in ${_architectures}; do
- cd "${srcdir}/pugixml-${pkgver}/build-${_arch}-static"
+ cd "${srcdir}/pugixml-${_majordotminor}/build-${_arch}-static"
make install DESTDIR="$pkgdir"
- cd "${srcdir}/pugixml-${pkgver}/build-${_arch}"
+ cd "${srcdir}/pugixml-${_majordotminor}/build-${_arch}"
make install DESTDIR="$pkgdir"
${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll