summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-10-06 18:15:15 +0200
committerMichel Zou2020-10-06 18:15:15 +0200
commit165958874e212d0ce723d39313eaa7677fc12f56 (patch)
tree3e61b086f783204cff9c2099f2ca981e4d099196
downloadaur-165958874e212d0ce723d39313eaa7677fc12f56.tar.gz
2.6.0b1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f84c1503350
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mingw-w64-pybind11
+ pkgdesc = A lightweight header-only library that exposes C++ types in Python and vice versa (mingw-w64)
+ pkgver = 2.6.0b1
+ pkgrel = 1
+ url = https://pybind11.readthedocs.org/
+ arch = any
+ license = BSD
+ makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-boost
+ makedepends = mingw-w64-eigen
+ depends = mingw-w64-crt
+ options = !buildflags
+ options = !strip
+ options = staticlibs
+ source = https://github.com/pybind/pybind11/archive/v2.6.0b1.tar.gz
+ sha256sums = SKIP
+
+pkgname = mingw-w64-pybind11
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66be967cbfd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=mingw-w64-pybind11
+pkgver=2.6.0b1
+pkgrel=1
+pkgdesc='A lightweight header-only library that exposes C++ types in Python and vice versa (mingw-w64)'
+arch=('any')
+url='https://pybind11.readthedocs.org/'
+license=('BSD')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-cmake' 'mingw-w64-boost' 'mingw-w64-eigen')
+options=('!buildflags' '!strip' 'staticlibs')
+source=("https://github.com/pybind/pybind11/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/pybind11-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake -DPYBIND11_NOPYTHON=ON -DBUILD_TESTING=OFF ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in $_architectures; do
+ cd "$srcdir"/pybind11-${pkgver}/build-${_arch}
+ make install DESTDIR="$pkgdir"
+ done
+}