summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorluigoalma2020-05-10 19:22:51 +0100
committerluigoalma2020-05-10 19:22:51 +0100
commita6a3be68bdc2d4d8817bc6ef655b66a9b4e84ec0 (patch)
tree5ad7fae350c5f0ba353f6b4c50810ca23413cee5
parentbd3578de0542f8b5ae24df1df9897f87607837ee (diff)
downloadaur-mingw-w64-python2.tar.gz
Python 2.7.18
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD36
-rw-r--r--descr_ref.patch58
-rw-r--r--patches.tar.xzbin48564 -> 49772 bytes
5 files changed, 37 insertions, 85 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88984b420229..600d0506e962 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = mingw-w64-python2
pkgdesc = A high-level scripting language (mingw-w64)
- pkgver = 2.7.15
- pkgrel = 3
+ pkgver = 2.7.18
+ pkgrel = 1
url = https://www.python.org/
arch = any
license = PSF
makedepends = mingw-w64-pkg-config
makedepends = mingw-w64-configure
- makedepends = python2>=2.7.15
+ makedepends = python2>=2.7.18
makedepends = mingw-w64-wine
depends = mingw-w64-crt
depends = mingw-w64-expat
@@ -15,6 +15,7 @@ pkgbase = mingw-w64-python2
depends = mingw-w64-ncurses
depends = mingw-w64-openssl
depends = mingw-w64-libffi
+ depends = mingw-w64-sqlite
depends = mingw-w64-tcl
depends = mingw-w64-tk
depends = mingw-w64-zlib
@@ -22,17 +23,14 @@ pkgbase = mingw-w64-python2
options = staticlibs
options = !buildflags
options = !strip
- source = Python-2.7.15.tar.xz::https://www.python.org/ftp/python/2.7.15/Python-2.7.15.tar.xz
+ source = Python-2.7.18.tar.xz::https://www.python.org/ftp/python/2.7.18/Python-2.7.18.tar.xz
source = patches.tar.xz
- source = descr_ref.patch
source = wine-python.sh
- sha1sums = f99348a095ec4a6411c84c0d15343d11920c9724
- sha1sums = 54891e03b3ce179055f6c5da046848d7b130bf8e
- sha1sums = 8cc6ac63e909063eb16bbdabc0f0eac7d24ff0c1
+ sha1sums = 678d4cf483a1c92efd347ee8e1e79326dc82810b
+ sha1sums = 02fe742643efd511ac1af51132587571d7e4050c
sha1sums = a024e7fd7eea7984a0d050164a4a015dea762da7
- sha512sums = 27ea43eb45fc68f3d2469d5f07636e10801dee11635a430ec8ec922ed790bb426b072da94df885e4dfa1ea8b7a24f2f56dd92f9b0f51e162330f161216bd6de6
- sha512sums = 028a40fecc940ebd895b7bcfe50717cc836c24d35323f5e1c8994dca66382bb2163002c923ca59977e0f531bffaa515903e488700eece3243573f03f80091f16
- sha512sums = 2e16eb23eb402dbe921c09bce99b400c10939114b4a1ded0e94a744d8cb66427947bc8d07c4fb054f9fe0906d10d1da509fc2273fd136225c0f019cc43dd045d
+ sha512sums = a7bb62b51f48ff0b6df0b18f5b0312a523e3110f49c3237936bfe56ed0e26838c0274ff5401bda6fc21bf24337477ccac49e8026c5d651e4b4cafb5eb5086f6c
+ sha512sums = 01249c95858ceb909e9e88ea79e25d0165ce229cacec7829779473657fe42c2cd643cc314d8136a6e661b807cc8d02fa7ffac6d1eed56905cf2332590330e252
sha512sums = d0fb7f0e1a3d98a170ebea301226ad8caa7ffab9fc0bee224abc31c22875c892b43d3468dffbdd15eb71ca1b5260e039d0fceb21ecc92341b9bb6949d7e9be6a
pkgname = mingw-w64-python2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a9b78817c4ec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*
+*/
+
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!patches.tar.xz
+!wine-python.sh
diff --git a/PKGBUILD b/PKGBUILD
index cf6217f4bffe..aeb0f9cf2e6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Ray Donnelly <mingw.android@gmail.com>
pkgname=mingw-w64-python2
-pkgver=2.7.15
+pkgver=2.7.18
_pybasever=2.7
-pkgrel=3
+pkgrel=1
pkgdesc="A high-level scripting language (mingw-w64)"
arch=('any')
license=('PSF')
@@ -16,6 +16,7 @@ depends=('mingw-w64-crt'
'mingw-w64-ncurses'
'mingw-w64-openssl'
'mingw-w64-libffi'
+ 'mingw-w64-sqlite'
'mingw-w64-tcl'
'mingw-w64-tk'
'mingw-w64-zlib')
@@ -25,15 +26,12 @@ optdepends=('mingw-w64-wine: runtime support')
options=('staticlibs' '!buildflags' '!strip')
source=("Python-${pkgver}.tar.xz::https://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tar.xz"
'patches.tar.xz'
- 'descr_ref.patch'
"wine-python.sh")
-sha1sums=('f99348a095ec4a6411c84c0d15343d11920c9724'
- '54891e03b3ce179055f6c5da046848d7b130bf8e'
- '8cc6ac63e909063eb16bbdabc0f0eac7d24ff0c1'
+sha1sums=('678d4cf483a1c92efd347ee8e1e79326dc82810b'
+ '02fe742643efd511ac1af51132587571d7e4050c'
'a024e7fd7eea7984a0d050164a4a015dea762da7')
-sha512sums=('27ea43eb45fc68f3d2469d5f07636e10801dee11635a430ec8ec922ed790bb426b072da94df885e4dfa1ea8b7a24f2f56dd92f9b0f51e162330f161216bd6de6'
- '028a40fecc940ebd895b7bcfe50717cc836c24d35323f5e1c8994dca66382bb2163002c923ca59977e0f531bffaa515903e488700eece3243573f03f80091f16'
- '2e16eb23eb402dbe921c09bce99b400c10939114b4a1ded0e94a744d8cb66427947bc8d07c4fb054f9fe0906d10d1da509fc2273fd136225c0f019cc43dd045d'
+sha512sums=('a7bb62b51f48ff0b6df0b18f5b0312a523e3110f49c3237936bfe56ed0e26838c0274ff5401bda6fc21bf24337477ccac49e8026c5d651e4b4cafb5eb5086f6c'
+ '01249c95858ceb909e9e88ea79e25d0165ce229cacec7829779473657fe42c2cd643cc314d8136a6e661b807cc8d02fa7ffac6d1eed56905cf2332590330e252'
'd0fb7f0e1a3d98a170ebea301226ad8caa7ffab9fc0bee224abc31c22875c892b43d3468dffbdd15eb71ca1b5260e039d0fceb21ecc92341b9bb6949d7e9be6a')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -144,11 +142,11 @@ prepare() {
0720-mingw-pdcurses_ISPAD.patch \
0740-grammar-fixes.patch \
0750-Add-interp-Python-DESTSHARED-to-PYTHONPATH-b4-pybuilddir-txt-dir.patch \
- 0760-msys-monkeypatch-os-system-via-sh-exe.patch \
0770-msys-replace-slashes-used-in-io-redirection.patch \
0790-mingw-add-_exec_prefix-for-tcltk-dlls.patch \
0800-mingw-install-layout-as-posix.patch \
0820-mingw-reorder-bininstall-ln-symlink-creation.patch \
+ 0821-make-python2-non-default-python.patch \
0830-add-build-sysroot-config-option.patch \
0840-add-builddir-to-library_dirs.patch \
0845-Remove-compiler-lib-dirs-from-extension-lib-dirs.patch \
@@ -168,6 +166,9 @@ prepare() {
1030-use-gnu_printf-in-format.patch \
1040-install-msilib.patch \
1050-skip-add-db-includes-for-win.patch \
+ 1060-dont-include-system-ncurses-path.patch \
+ 1850-disable-readline.patch \
+ 1900-ctypes-dont-depend-on-internal-libffi.patch
plain "Apply Renato Silva's patch to distutils"
apply_patch_with_msg \
@@ -187,10 +188,17 @@ prepare() {
apply_patch_with_msg \
2701-disable-broken-gdbm-module.patch
+ # https://github.com/msys2/MINGW-packages/issues/5155
+ apply_patch_with_msg 2030-fix-msvc9-import.patch
+
# Fix winsock2 include in timemodule.c and readline.c
apply_patch_with_msg \
python-2.7.15-add-missing-winsock2-include.patch
+ # Some extra fixups
+ apply_patch_with_msg \
+ extra_fixups.patch
+
# run PGEN through wine
sed -i "s|\\\$(PGEN) \\\$(GRAMMAR_INPUT)|wine \\\$(PGEN) \\\$(GRAMMAR_INPUT)|g" Makefile.pre.in
@@ -230,10 +238,6 @@ prepare() {
# Workaround asdl_c.py/makeopcodetargets.py errors after we touched the shebangs
touch Include/Python-ast.h Python/Python-ast.c Python/opcode_targets.h
-
- # FS#48761
- # http://bugs.python.org/issue25750
- patch -Np1 -i ../descr_ref.patch
}
build() {
@@ -245,7 +249,7 @@ build() {
CFLAGS+=" -fwrapv -D__USE_MINGW_ANSI_STDIO=1 "
CXXFLAGS+=" -fwrapv -D__USE_MINGW_ANSI_STDIO=1 "
- CPPFLAGS+=" -I/usr/${_arch}/include/ncursesw "
+ CPPFLAGS+=" -I/usr/${_arch}/include/ncurses "
if check_option "strip" "y"; then
LDFLAGS+=" -s "
@@ -302,7 +306,7 @@ package() {
[[ -d "${pkgdir}/usr/${_arch}"/share/gdb/python2/ ]] || mkdir -p "${pkgdir}/usr/${_arch}"/share/gdb/python2/
cp -f python.exe-gdb.py "${pkgdir}/usr/${_arch}"/share/gdb/python2/python_gdb.py
- for file in 2to3 python{.exe,-config{'',{'',-u}.sh}}; do
+ for file in 2to3; do
rm "${pkgdir}/usr/${_arch}"/bin/$file
done
rm "${pkgdir}/usr/${_arch}"/lib/pkgconfig/python.pc
diff --git a/descr_ref.patch b/descr_ref.patch
deleted file mode 100644
index b55cf58a2d25..000000000000
--- a/descr_ref.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-When calling tp_descr_get(self, obj, type), make sure that we own a reference to "self"
-
-diff -ru Python-2.7.9/Objects/typeobject.c Python-2.7.9-fixed//Objects/typeobject.c
---- Python-2.7.9/Objects/typeobject.c 2014-12-10 16:59:57.000000000 +0100
-+++ Python-2.7.9-fixed//Objects/typeobject.c 2015-11-27 20:39:58.276156800 +0100
-@@ -2542,6 +2542,7 @@
- PyTypeObject *metatype = Py_TYPE(type);
- PyObject *meta_attribute, *attribute;
- descrgetfunc meta_get;
-+ PyObject* res;
-
- if (!PyString_Check(name)) {
- PyErr_Format(PyExc_TypeError,
-@@ -2563,6 +2564,7 @@
- meta_attribute = _PyType_Lookup(metatype, name);
-
- if (meta_attribute != NULL) {
-+ Py_INCREF(meta_attribute);
- meta_get = Py_TYPE(meta_attribute)->tp_descr_get;
-
- if (meta_get != NULL && PyDescr_IsData(meta_attribute)) {
-@@ -2570,10 +2572,11 @@
- * writes. Assume the attribute is not overridden in
- * type's tp_dict (and bases): call the descriptor now.
- */
-- return meta_get(meta_attribute, (PyObject *)type,
-+ res = meta_get(meta_attribute, (PyObject *)type,
- (PyObject *)metatype);
-+ Py_DECREF(meta_attribute);
-+ return res;
- }
-- Py_INCREF(meta_attribute);
- }
-
- /* No data descriptor found on metatype. Look in tp_dict of this
-@@ -2581,6 +2584,7 @@
- attribute = _PyType_Lookup(type, name);
- if (attribute != NULL) {
- /* Implement descriptor functionality, if any */
-+ Py_INCREF(attribute);
- descrgetfunc local_get = Py_TYPE(attribute)->tp_descr_get;
-
- Py_XDECREF(meta_attribute);
-@@ -2588,11 +2592,12 @@
- if (local_get != NULL) {
- /* NULL 2nd argument indicates the descriptor was
- * found on the target object itself (or a base) */
-- return local_get(attribute, (PyObject *)NULL,
-+ res = local_get(attribute, (PyObject *)NULL,
- (PyObject *)type);
-+ Py_DECREF(attribute);
-+ return res;
- }
-
-- Py_INCREF(attribute);
- return attribute;
- }
-
diff --git a/patches.tar.xz b/patches.tar.xz
index b03f44ee5c11..590fb7f05a63 100644
--- a/patches.tar.xz
+++ b/patches.tar.xz
Binary files differ