summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-10-31 19:07:33 +0100
committerMichel Zou2018-10-31 19:07:33 +0100
commit370b330fb282a49385f1a242a808c097f7756b04 (patch)
treef79eb95915c8d89324bbcc8a1cd64df6c2d46ec9
parentfaa348b94e43b95943b3362efe71d875cd50b670 (diff)
downloadaur-370b330fb282a49385f1a242a808c097f7756b04.tar.gz
bpo-issue11722
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5cf68297bdb..e267656d1b63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,8 +29,13 @@ build() {
fi
mkdir -p "build-${_arch}" && pushd "build-${_arch}"
msiexec /i "${srcdir}"/python-${pkgver}${target}.msi /qb TARGETDIR=$PWD
+
# https://bugs.python.org/issue11566
sed -i "s|#define hypot _hypot|/*#define hypot _hypot*/|g" include/pyconfig.h
+
+ # https://bugs.python.org/issue11722
+ sed -i "s|#if defined(MS_WIN64)|#if defined(MS_WIN64) \|\| defined(__MINGW64__)|g" include/pyconfig.h
+
gendef python${_pybasever}.dll
${_arch}-dlltool --dllname python${_pybasever}.dll --def python${_pybasever}.def --output-lib libs/libpython${_pybasever}.dll.a
sed "s|@TRIPLE@|${_arch}|g;s|@PYVER@|${_pybasever}|g" "${srcdir}"/wine-python.sh > ${_arch}-python${_pybasever}-bin