summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-10-31 18:33:38 +0100
committerMichel Zou2018-10-31 18:33:38 +0100
commitfaa348b94e43b95943b3362efe71d875cd50b670 (patch)
treeb4ca62ac8774f3c1ca7691602f73f8aa80dc235e
parente79ede5601e43489a971f9a8e337cb9670399f19 (diff)
downloadaur-faa348b94e43b95943b3362efe71d875cd50b670.tar.gz
comment
-rw-r--r--PKGBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 574be550ff96..d5cf68297bdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,6 +29,7 @@ build() {
fi
mkdir -p "build-${_arch}" && pushd "build-${_arch}"
msiexec /i "${srcdir}"/python-${pkgver}${target}.msi /qb TARGETDIR=$PWD
+ # https://bugs.python.org/issue11566
sed -i "s|#define hypot _hypot|/*#define hypot _hypot*/|g" include/pyconfig.h
gendef python${_pybasever}.dll
${_arch}-dlltool --dllname python${_pybasever}.dll --def python${_pybasever}.def --output-lib libs/libpython${_pybasever}.dll.a