summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2022-07-07 20:27:34 +0200
committerMichel Zou2022-07-07 20:27:34 +0200
commite2a321049cbfa732505280b06f521c29f923e2f1 (patch)
tree517112858e766d003063937748890c37c7e89c61
downloadaur-e2a321049cbfa732505280b06f521c29f923e2f1.tar.gz
1.23.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c30710edc8d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mingw-w64-python310-numpy-bin
+ pkgdesc = Scientific tools for Python (mingw-w64)
+ pkgver = 1.23.0
+ pkgrel = 1
+ url = https://www.numpy.org/
+ arch = any
+ license = custom
+ depends = mingw-w64-python310-bin
+ options = staticlibs
+ options = !buildflags
+ options = !strip
+ source = https://files.pythonhosted.org/packages/34/1c/1c9ec57f522822e7507fb5cf69b153f857405518d8f50fa4ff94f43385be/numpy-1.23.0-cp310-cp310-win_amd64.whl
+ sha256sums = SKIP
+
+pkgname = mingw-w64-python310-numpy-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b64d69a50fb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname=mingw-w64-python310-numpy-bin
+pkgver=1.23.0
+pkgrel=1
+pkgdesc="Scientific tools for Python (mingw-w64)"
+arch=('any')
+license=('custom')
+url="https://www.numpy.org/"
+depends=('mingw-w64-python310-bin')
+options=('staticlibs' '!buildflags' '!strip')
+source=("https://files.pythonhosted.org/packages/34/1c/1c9ec57f522822e7507fb5cf69b153f857405518d8f50fa4ff94f43385be/numpy-1.23.0-cp310-cp310-win_amd64.whl")
+sha256sums=('SKIP')
+
+package() {
+ install -d "$pkgdir"/usr/x86_64-w64-mingw32/lib/python310/
+ cp -r $srcdir/numpy* "$pkgdir"/usr/x86_64-w64-mingw32/lib/python310/
+}
+