summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-06-28 18:35:03 +0200
committerMichel Zou2018-06-28 18:35:03 +0200
commit2f4800656ff9a33c3276cd9ea0e43849bd0a62b5 (patch)
tree162ded8f75ed30b68d798222ed1765362215d404
downloadaur-2f4800656ff9a33c3276cd9ea0e43849bd0a62b5.tar.gz
init
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD57
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8af6f8b56ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Thu Jun 28 16:35:03 UTC 2018
+pkgbase = mingw-w64-python36-bin
+ pkgdesc = Next generation of the python high-level scripting language (native MSVC version) (mingw-w64)
+ pkgver = 3.6.4
+ pkgrel = 1
+ url = http://www.python.org/
+ arch = any
+ license = PSF
+ makedepends = mingw-w64-tools
+ makedepends = mingw-w64-binutils
+ depends = mingw-w64-crt
+ provides = mingw-w64-python
+ conflicts = mingw-w64-python
+ noextract = python-3.6.4-embed-win32.zip
+ noextract = python-3.6.4-embed-amd64.zip
+ options = staticlibs
+ options = !buildflags
+ options = !strip
+ source = https://www.python.org/ftp/python/3.6.4/python-3.6.4-embed-win32.zip
+ source = https://www.python.org/ftp/python/3.6.4/python-3.6.4-embed-amd64.zip
+ source = https://www.python.org/ftp/python/3.6.4/Python-3.6.4.tgz
+ sha256sums = 749eed1e2d7b5fe1db540c3c3b716c65bdddb44da28a8783148746d7f69ee402
+ sha256sums = f6ca955d6885a2ac01595dc7857c5c06ee0a5b1f7b3774f89ec52692c7cb691c
+ sha256sums = 7dc453e1a93c083388eb1a23a256862407f8234a96dc4fae0fc7682020227486
+
+pkgname = mingw-w64-python36-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac3968f8d87d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+pkgname=mingw-w64-python36-bin
+pkgver=3.6.4
+_pybasever=36
+pkgrel=1
+pkgdesc="Next generation of the python high-level scripting language (native MSVC version) (mingw-w64)"
+arch=('any')
+license=('PSF')
+url="http://www.python.org/"
+provides=('mingw-w64-python')
+conflicts=('mingw-w64-python')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-tools' 'mingw-w64-binutils')
+options=('staticlibs' '!buildflags' '!strip')
+source=("https://www.python.org/ftp/python/${pkgver}/python-${pkgver}-embed-win32.zip"
+ "https://www.python.org/ftp/python/${pkgver}/python-${pkgver}-embed-amd64.zip"
+ "https://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tgz")
+noextract=("python-${pkgver}-embed-win32.zip"
+ "python-${pkgver}-embed-amd64.zip")
+sha256sums=('749eed1e2d7b5fe1db540c3c3b716c65bdddb44da28a8783148746d7f69ee402'
+ 'f6ca955d6885a2ac01595dc7857c5c06ee0a5b1f7b3774f89ec52692c7cb691c'
+ '7dc453e1a93c083388eb1a23a256862407f8234a96dc4fae0fc7682020227486')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/Python-${pkgver}"
+ for _arch in ${_architectures}; do
+ target="win32"
+ if test "${_arch}" = x86_64-w64-mingw32
+ then
+ target="amd64"
+ fi
+ mkdir -p "build-${_arch}" && pushd "build-${_arch}"
+ bsdtar -xf "${srcdir}"/python-${pkgver}-embed-${target}.zip
+ gendef python${_pybasever}.dll
+ ${_arch}-dlltool --dllname python${_pybasever}.dll --def python${_pybasever}.def --output-lib libpython${_pybasever}.dll.a
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/Python-${pkgver}/build-${_arch}"
+ install -d "$pkgdir"/usr/${_arch}/lib
+ install -m644 libpython${_pybasever}*.a "$pkgdir"/usr/${_arch}/lib
+ install -d "$pkgdir"/usr/${_arch}/bin
+ install -d "$pkgdir"/usr/${_arch}/include/python${_pybasever}
+ install -m644 ../Include/*.h "$pkgdir"/usr/${_arch}/include/python${_pybasever}
+ install -m644 ../PC/pyconfig.h "$pkgdir"/usr/${_arch}/include/python${_pybasever}
+ install -m755 python${_pybasever}.dll "$pkgdir"/usr/${_arch}/bin
+ install -d "$pkgdir"/usr/${_arch}/lib/python${_pybasever}
+ install -m644 *.pyd "$pkgdir"/usr/${_arch}/lib/python${_pybasever}
+ install -m755 python.exe "$pkgdir"/usr/${_arch}/bin/python${_pybasever}.exe
+ install -m644 python${_pybasever}.zip "$pkgdir"/usr/${_arch}/bin/
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ done
+}