summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-10-31 18:18:49 +0100
committerMichel Zou2018-10-31 18:18:49 +0100
commit5935e4a8e20d2226cc00859c84dc808b40cf8903 (patch)
tree107513f4a30b4f8f76c00790a28929b0ce361890
parentf311ff549f3911a9f1d42b6185ce550589d1a5c2 (diff)
downloadaur-5935e4a8e20d2226cc00859c84dc808b40cf8903.tar.gz
bpo-11566
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--bpo-11566.patch10
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7693226132a..6689c3dacdda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-python36-bin
pkgdesc = Next generation of the python high-level scripting language (native MSVC version) (mingw-w64)
pkgver = 3.6.5
- pkgrel = 2
+ pkgrel = 3
url = http://www.python.org/
arch = any
license = PSF
@@ -18,10 +18,12 @@ pkgbase = mingw-w64-python36-bin
source = https://www.python.org/ftp/python/3.6.5/python-3.6.5-embed-amd64.zip
source = https://www.python.org/ftp/python/3.6.5/Python-3.6.5.tgz
source = wine-python.sh
+ source = bpo-11566.patch
sha256sums = f654c055817b5a2c5b050d744833d95d621aeaa507b5c28b4840712821a70891
sha256sums = dfb476fabd20f617c8a5be58ca3e55844c8310710c6ff0dd25486d1d03c95a28
sha256sums = 53a3e17d77cd15c5230192b6a8c1e031c07cd9f34a2f089a731c6f6bd343d5c6
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = mingw-w64-python36-bin
diff --git a/PKGBUILD b/PKGBUILD
index 75778cefab63..77340f6131ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=mingw-w64-python36-bin
pkgver=3.6.5
_pybasever=36
-pkgrel=2
+pkgrel=3
pkgdesc="Next generation of the python high-level scripting language (native MSVC version) (mingw-w64)"
arch=('any')
license=('PSF')
@@ -13,16 +13,22 @@ options=('staticlibs' '!buildflags' '!strip')
source=("https://www.python.org/ftp/python/${pkgver}/python-${pkgver}-embed-win32.zip"
"https://www.python.org/ftp/python/${pkgver}/python-${pkgver}-embed-amd64.zip"
"https://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tgz"
- wine-python.sh)
+ wine-python.sh bpo-11566.patch)
noextract=("python-${pkgver}-embed-win32.zip"
"python-${pkgver}-embed-amd64.zip")
sha256sums=('f654c055817b5a2c5b050d744833d95d621aeaa507b5c28b4840712821a70891'
'dfb476fabd20f617c8a5be58ca3e55844c8310710c6ff0dd25486d1d03c95a28'
'53a3e17d77cd15c5230192b6a8c1e031c07cd9f34a2f089a731c6f6bd343d5c6'
- SKIP)
+ SKIP SKIP)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare () {
+ cd "${srcdir}/Python-${pkgver}"
+ # https://bugs.python.org/issue11566
+ patch -p1 -i "${srcdir}"/bpo-11566.patch
+}
+
build() {
cd "${srcdir}/Python-${pkgver}"
for _arch in ${_architectures}; do
diff --git a/bpo-11566.patch b/bpo-11566.patch
new file mode 100644
index 000000000000..056f87ccd9c2
--- /dev/null
+++ b/bpo-11566.patch
@@ -0,0 +1,10 @@
+--- a/PC/pyconfig.h.orig 2018-10-31 18:10:31.305748749 +0100
++++ b/PC/pyconfig.h 2018-10-31 18:10:48.242416545 +0100
+@@ -282,7 +282,6 @@
+ #endif
+
+ #define COMPILER "[gcc]"
+-#define hypot _hypot
+ #define PY_LONG_LONG long long
+ #define PY_LLONG_MIN LLONG_MIN
+ #define PY_LLONG_MAX LLONG_MAX