summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-01-13 20:07:42 +0100
committerMichel Zou2020-01-13 20:07:42 +0100
commit01e0a09cfed0e43deb48d4095e3885abeb6de3a8 (patch)
tree45d9e90f9f638ef5fa73a1645fe93d73c1bd980f
parent085e461b65882c5ea77b95b80dc1dfecc465e12b (diff)
downloadaur-01e0a09cfed0e43deb48d4095e3885abeb6de3a8.tar.gz
3.7.6, bpo36020
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD12
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b81a1206cf98..a6f74882998e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-python37-bin
pkgdesc = Next generation of the python high-level scripting language (native MSVC version) (mingw-w64)
- pkgver = 3.7.5
- pkgrel = 2
+ pkgver = 3.7.6
+ pkgrel = 1
url = http://www.python.org/
arch = any
license = PSF
@@ -9,18 +9,18 @@ pkgbase = mingw-w64-python37-bin
makedepends = mingw-w64-binutils
depends = mingw-w64-openssl
optdepends = mingw-w64-wine: runtime support
- noextract = python-3.7.5-embed-win32.zip
- noextract = python-3.7.5-embed-amd64.zip
+ noextract = python-3.7.6-embed-win32.zip
+ noextract = python-3.7.6-embed-amd64.zip
options = staticlibs
options = !buildflags
options = !strip
- source = https://www.python.org/ftp/python/3.7.5/python-3.7.5-embed-win32.zip
- source = https://www.python.org/ftp/python/3.7.5/python-3.7.5-embed-amd64.zip
- source = https://www.python.org/ftp/python/3.7.5/Python-3.7.5.tgz
+ source = https://www.python.org/ftp/python/3.7.6/python-3.7.6-embed-win32.zip
+ source = https://www.python.org/ftp/python/3.7.6/python-3.7.6-embed-amd64.zip
+ source = https://www.python.org/ftp/python/3.7.6/Python-3.7.6.tgz
source = wine-python.sh
- sha256sums = b8337c080bf9dbab81dbb67fe38d84a7f1cec746c428a9ef164df249f4e8467b
- sha256sums = 30d8fb3525e0edeb77b29f799c6248755f58da2f46d351c7f091c33adccea059
- sha256sums = 8ecc681ea0600bbfb366f2b173f727b205bb825d93d2f0b286bc4e58d37693da
+ sha256sums = e2257b87e2e1a131e5d2adf843887fdab5021f8d4d6d68d49691aa965650c3ab
+ sha256sums = 114638061d636285600cbc3d4def64b45c43da9b225cb9eeead30fe7fe7d60d4
+ sha256sums = aeee681c235ad336af116f08ab6563361a0c81c537072c1b309d6e4050aa2114
sha256sums = SKIP
pkgname = mingw-w64-python37-bin
diff --git a/PKGBUILD b/PKGBUILD
index a6919943509c..d6c22e4fd689 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=mingw-w64-python37-bin
-pkgver=3.7.5
+pkgver=3.7.6
_pybasever=37
-pkgrel=2
+pkgrel=1
pkgdesc="Next generation of the python high-level scripting language (native MSVC version) (mingw-w64)"
arch=('any')
license=('PSF')
@@ -16,15 +16,17 @@ source=("https://www.python.org/ftp/python/${pkgver}/python-${pkgver}-embed-win3
wine-python.sh)
noextract=("python-${pkgver}-embed-win32.zip"
"python-${pkgver}-embed-amd64.zip")
-sha256sums=('b8337c080bf9dbab81dbb67fe38d84a7f1cec746c428a9ef164df249f4e8467b'
- '30d8fb3525e0edeb77b29f799c6248755f58da2f46d351c7f091c33adccea059'
- '8ecc681ea0600bbfb366f2b173f727b205bb825d93d2f0b286bc4e58d37693da'
+sha256sums=('e2257b87e2e1a131e5d2adf843887fdab5021f8d4d6d68d49691aa965650c3ab'
+ '114638061d636285600cbc3d4def64b45c43da9b225cb9eeead30fe7fe7d60d4'
+ 'aeee681c235ad336af116f08ab6563361a0c81c537072c1b309d6e4050aa2114'
'SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare () {
cd "${srcdir}/Python-${pkgver}"
+ # https://bugs.python.org/issue36020
+ sed -i 's|#if defined(MS_WIN32) \&\& !defined(HAVE_SNPRINTF)|#if defined(_MSC_VER) \&\& !defined(HAVE_SNPRINTF)|g' Include/pyerrors.h
}
build() {