summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip A Reimer2015-06-12 21:50:57 -0600
committerPhilip A Reimer2015-06-12 21:50:57 -0600
commit4f9e5a253ff5fa90704306ea13566f09535c70e1 (patch)
tree7e2854edd02871667def3b9892158c2089a6a006
downloadaur-4f9e5a253ff5fa90704306ea13566f09535c70e1.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD46
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aeada83c331f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.1
+# Sat Jun 6 20:41:53 UTC 2015
+pkgbase = mingw-w64-qcustomplot-qt5
+ pkgdesc = Plotting library for Qt5 (mingw-w64)
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://www.qcustomplot.com
+ arch = any
+ license = GPL
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-crt
+ depends = mingw-w64-qt5-base
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://www.qcustomplot.com/release/1.3.1/QCustomPlot-sharedlib.tar.gz
+ source = http://www.qcustomplot.com/release/1.3.1/QCustomPlot-source.tar.gz
+ md5sums = 05c3c32a28116b63e09213c8ed2b7055
+ md5sums = 4448e2e3efbe92ea226fc21a5a1bde55
+
+pkgname = mingw-w64-qcustomplot-qt5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d31830f6a2f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: ant32 <antreimer@gmail.com>
+
+pkgname=mingw-w64-qcustomplot-qt5
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Plotting library for Qt5 (mingw-w64)"
+arch=('any')
+url="http://www.qcustomplot.com"
+license=('GPL')
+makedepends=('mingw-w64-gcc')
+depends=('mingw-w64-crt' 'mingw-w64-qt5-base')
+options=('!strip' '!buildflags' 'staticlibs')
+source=("http://www.qcustomplot.com/release/${pkgver}/QCustomPlot-sharedlib.tar.gz"
+ "http://www.qcustomplot.com/release/${pkgver}/QCustomPlot-source.tar.gz")
+md5sums=('05c3c32a28116b63e09213c8ed2b7055'
+ '4448e2e3efbe92ea226fc21a5a1bde55')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ unset LDFLAGS
+
+ # fix path to source files
+ sed -i 's|../../qcustomplot|../../qcustomplot-source/qcustomplot|g' \
+ "${srcdir}/qcustomplot-sharedlib/sharedlib-compilation/sharedlib-compilation.pro"
+
+ for _arch in ${_architectures}; do
+ mkdir -p "${srcdir}/build-${_arch}"
+ cd "${srcdir}/build-${_arch}"
+
+ ${_arch}-qmake-qt5 "${srcdir}/qcustomplot-sharedlib/sharedlib-compilation/sharedlib-compilation.pro"
+ make release
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/build-${_arch}/release"
+ mkdir -p "${pkgdir}/usr/${_arch}/"{bin,lib,include}
+ cp qcustomplot1.dll "$pkgdir/usr/${_arch}/bin"
+ cp libqcustomplot1.dll.a "${pkgdir}/usr/${_arch}/lib/"
+ cp "${srcdir}/qcustomplot-source/qcustomplot.h" "${pkgdir}/usr/${_arch}/include"
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/"*.a
+ done
+}