summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-04-07 18:38:05 +0200
committerMichel Zou2016-04-07 18:38:05 +0200
commitd9e3509a284f9dfe56f08b63a76a786c6724758d (patch)
tree02100d61ce0359062f511c0e74e96ef94727b3e9
parentafac55d20f427c120e957a0b7f13380a76f1c928 (diff)
downloadaur-d9e3509a284f9dfe56f08b63a76a786c6724758d.tar.gz
2015.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b176f4448974..c6a351fad9e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu Apr 7 16:38:05 UTC 2016
pkgbase = mingw-w64-qhull
pkgdesc = A general dimension code for computing convex hulls and related structures (mingw-w64)
- pkgver = 2012.1
+ pkgver = 2015.2
pkgrel = 1
url = http://www.qhull.org/
arch = any
@@ -10,8 +12,8 @@ pkgbase = mingw-w64-qhull
options = !buildflags
options = !strip
options = staticlibs
- source = http://www.qhull.org/download/qhull-2012.1-src.tgz
- md5sums = d0f978c0d8dfb2e919caefa56ea2953c
+ source = http://www.qhull.org/download/qhull-2015-src-7.2.0.tgz
+ md5sums = e6270733a826a6a7c32b796e005ec3dc
pkgname = mingw-w64-qhull
diff --git a/PKGBUILD b/PKGBUILD
index 06161ab169ec..d025ab825a9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-qhull
-pkgver=2012.1
+pkgver=2015.2
pkgrel=1
pkgdesc="A general dimension code for computing convex hulls and related structures (mingw-w64)"
arch=('any')
@@ -9,19 +9,17 @@ license=('custom')
depends=('mingw-w64-crt')
makedepends=('mingw-w64-cmake')
options=('!buildflags' '!strip' 'staticlibs')
-source=("http://www.qhull.org/download/qhull-$pkgver-src.tgz")
-md5sums=('d0f978c0d8dfb2e919caefa56ea2953c')
+source=("http://www.qhull.org/download/qhull-2015-src-7.2.0.tgz")
+md5sums=('e6270733a826a6a7c32b796e005ec3dc')
+
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "qhull-$pkgver"
for _arch in ${_architectures}; do
- unset LDFLAGS
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \
-DCMAKE_BUILD_TYPE=Release \
- -DBUILD_SHARED_LIBS=OFF \
- -DBUILD_TESTING=OFF \
..
make
popd
@@ -30,8 +28,6 @@ build() {
package() {
for _arch in ${_architectures}; do
- #cd "$srcdir/qhull-${pkgver}/build-${_arch}-static"
- #make install DESTDIR="$pkgdir"
cd "$srcdir/qhull-${pkgver}/build-${_arch}"
make install DESTDIR="$pkgdir"
rm -r "$pkgdir"/usr/${_arch}/man "$pkgdir"/usr/${_arch}/doc
@@ -39,7 +35,4 @@ package() {
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
-
- #make DESTDIR="$pkgdir" install
-
}