summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-06-03 23:53:09 +0200
committerMichel Zou2016-06-03 23:53:09 +0200
commit62b7aa168874123a27271ad1e4e28736dcbacd1e (patch)
treebf218c27b15b3db6a61b7a4d6921269383b42551
parent533ce3f49fcd513eaeabae1d55795f21c9b8f01d (diff)
downloadaur-62b7aa168874123a27271ad1e4e28736dcbacd1e.tar.gz
use c++98
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 4 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9bc322acdc2..58ae466d8621 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon May 30 20:09:51 UTC 2016
+# Fri Jun 3 21:53:09 UTC 2016
pkgbase = mingw-w64-qt4
pkgdesc = A cross-platform application and UI framework (mingw-w64)
pkgver = 4.8.7
diff --git a/PKGBUILD b/PKGBUILD
index 0e9bf0affdaf..cbe92778eb60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -142,6 +142,9 @@ build() {
export CPLUS_INCLUDE_PATH="/usr/i686-w64-mingw32/include/mysql"
unset LDFLAGS PKG_CONFIG_PATH
+ # workaround for class std::auto_ptr' is deprecated with gcc-6
+ export CXXFLAGS="$CXXFLAGS -std=gnu++98 -Wno-deprecated"
+
for _arch in ${_architectures}; do
if [ ${_arch} = 'i686-w64-mingw32' ]; then