summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-05-30 22:08:40 +0200
committerMichel Zou2016-05-30 22:08:40 +0200
commit76bf95c4970a152a83e3bd8db8f9d42adfcf58c1 (patch)
treeec51b08f630d996ec5a3fc298e5cfbd5128ca950
parent90d23535e12dc8da1e42af4392abc87f1a579c9c (diff)
downloadaur-76bf95c4970a152a83e3bd8db8f9d42adfcf58c1.tar.gz
gcc6 patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--qt-everywhere-opensource-src-4.8.7-gcc6.patch35
3 files changed, 46 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c78552fb7b5f..bf2dda8a5137 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Mon May 30 20:08:40 UTC 2016
pkgbase = mingw-w64-qt4
pkgdesc = A cross-platform application and UI framework (mingw-w64)
pkgver = 4.8.7
@@ -41,6 +43,7 @@ pkgbase = mingw-w64-qt4
source = qt-4.8.1-fix-activeqt-compilation.patch
source = qt-dont-set-qt-dll-define-for-static-builds.patch
source = qt4-fix-linking-against-static-dbus.patch
+ source = qt-everywhere-opensource-src-4.8.7-gcc6.patch
md5sums = d990ee66bf7ab0c785589776f35ba6ad
md5sums = 3759f73b9c872ce692b7067daef134a9
md5sums = db6257762e051f2b7b18745dca2df43d
@@ -54,6 +57,7 @@ pkgbase = mingw-w64-qt4
md5sums = 22fc6f20aa6af060c640fc3b9af888a9
md5sums = b6d9bcdd1df5115e7063d08bf75c2fd1
md5sums = 84a802e6619be4f43b2a9be0ec1a11ef
+ md5sums = 8ba77cd8f325c38daca8eadc982395a4
pkgname = mingw-w64-qt4
diff --git a/PKGBUILD b/PKGBUILD
index 6bf8b7c142ba..0e9bf0affdaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,7 +38,8 @@ source=("http://download.qt-project.org/official_releases/qt/4.8/${pkgver}/${_pk
'qt-fix-javascript-jit-on-mingw-x86_64.patch'
'qt-4.8.1-fix-activeqt-compilation.patch'
'qt-dont-set-qt-dll-define-for-static-builds.patch'
- 'qt4-fix-linking-against-static-dbus.patch')
+ 'qt4-fix-linking-against-static-dbus.patch'
+ 'qt-everywhere-opensource-src-4.8.7-gcc6.patch')
md5sums=('d990ee66bf7ab0c785589776f35ba6ad'
'3759f73b9c872ce692b7067daef134a9'
'db6257762e051f2b7b18745dca2df43d'
@@ -51,7 +52,8 @@ md5sums=('d990ee66bf7ab0c785589776f35ba6ad'
'3fe6e419c1f21c59062db1f562c1f9bf'
'22fc6f20aa6af060c640fc3b9af888a9'
'b6d9bcdd1df5115e7063d08bf75c2fd1'
- '84a802e6619be4f43b2a9be0ec1a11ef')
+ '84a802e6619be4f43b2a9be0ec1a11ef'
+ '8ba77cd8f325c38daca8eadc982395a4')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -113,6 +115,9 @@ prepare() {
# When building static binaries, make sure the gcc argument -DQT_DLL isn't used
patch -Np1 -i "${srcdir}"/qt-dont-set-qt-dll-define-for-static-builds.patch
+ # GCC 6
+ patch -Np1 -i "${srcdir}"/qt-everywhere-opensource-src-4.8.7-gcc6.patch
+
# Cross-compilation qmake target.
mkdir -p mkspecs/win32-g++-cross
mkdir -p mkspecs/win32-g++-cross-x64
diff --git a/qt-everywhere-opensource-src-4.8.7-gcc6.patch b/qt-everywhere-opensource-src-4.8.7-gcc6.patch
new file mode 100644
index 000000000000..aaf1c497f2f6
--- /dev/null
+++ b/qt-everywhere-opensource-src-4.8.7-gcc6.patch
@@ -0,0 +1,35 @@
+diff -up qt-everywhere-opensource-src-4.8.7/configure.gcc6 qt-everywhere-opensource-src-4.8.7/configure
+--- qt-everywhere-opensource-src-4.8.7/configure.gcc6 2016-04-15 07:04:19.430268222 -0500
++++ qt-everywhere-opensource-src-4.8.7/configure 2016-04-15 07:05:22.157568689 -0500
+@@ -7744,7 +7744,7 @@ case "$XPLATFORM" in
+ *-g++*)
+ # Check gcc's version
+ case "$(${QMAKE_CONF_COMPILER} -dumpversion)" in
+- 5*|4*|3.4*)
++ 8*|7*|6*|5*|4*|3.4*)
+ ;;
+ 3.3*)
+ canBuildWebKit="no"
+@@ -8060,7 +8060,7 @@ g++*)
+ 3.*)
+ COMPILER_VERSION="3.*"
+ ;;
+- 5*|4.*)
++ 8*|7*|6*|5*|4.*)
+ COMPILER_VERSION="4"
+ ;;
+ *)
+diff -up qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h.gcc6 qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h
+--- qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h.gcc6 2015-05-07 09:14:48.000000000 -0500
++++ qt-everywhere-opensource-src-4.8.7/src/xmlpatterns/api/qcoloroutput_p.h 2016-04-15 07:04:19.431268227 -0500
+@@ -70,8 +70,8 @@ namespace QPatternist
+ ForegroundShift = 10,
+ BackgroundShift = 20,
+ SpecialShift = 20,
+- ForegroundMask = ((1 << ForegroundShift) - 1) << ForegroundShift,
+- BackgroundMask = ((1 << BackgroundShift) - 1) << BackgroundShift
++ ForegroundMask = 0x1f << ForegroundShift,
++ BackgroundMask = 0x7 << BackgroundShift
+ };
+
+ public: