summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:10 +0100
committerMartchus2022-03-08 23:35:10 +0100
commit55231eba4c5c3afe81b279651de6bf8d90971aca (patch)
tree8ae5df70b5df3d741e427e682d60cb4243811c66
parentfe202457ae37685c7d4189c77728860f3ea5ed24 (diff)
downloadaur-55231eba4c5c3afe81b279651de6bf8d90971aca.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
-rw-r--r--PKGBUILD.sh.ep12
3 files changed, 32 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10bd8d867626..506d3038c01a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-3d
pkgdesc = C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r18
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -13,12 +13,14 @@ pkgbase = mingw-w64-qt5-3d
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
makedepends = mingw-w64-vulkan-headers
+ makedepends = assimp
+ makedepends = git
depends = mingw-w64-qt5-declarative
+ depends = mingw-w64-assimp
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qt3d-everywhere-src-5.15.2.tar.xz
- sha256sums = 03ed6a48c813c75296c19f5d721184ab168280b69d2656cf16f877d3d4c55c1d
+ source = git+https://invent.kde.org/qt/qt/qt3d#commit=6d926ec2739f2289c6b0bbfbc325700046e1ceee
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-3d
-
diff --git a/PKGBUILD b/PKGBUILD
index ffa600fc84a3..5e8ff1c8ea06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,29 +10,40 @@
_qt_module=qt3d
pkgname=mingw-w64-qt5-3d
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)"
-depends=('mingw-w64-qt5-declarative')
-makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-vulkan-headers')
+depends=('mingw-w64-qt5-declarative' 'mingw-w64-assimp')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-vulkan-headers' 'assimp')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
+_commit=6d926ec2739f2289c6b0bbfbc325700046e1ceee
+_basever=$pkgver
+pkgver+=+kde+r18
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('03ed6a48c813c75296c19f5d721184ab168280b69d2656cf16f877d3d4c55c1d')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
prepare() {
cd "${srcdir}/${_pkgfqn}"
- # ensure qgltf is linked against zlib
- echo 'LIBS += -L/usr/lib -lz' >> tools/qgltf/qgltf.pro
+ # ensure qgltf is linked against assimp and zlib
+ echo 'LIBS += -L/usr/lib -lassimp -lz' >> tools/qgltf/qgltf.pro
+ # avoid linker errors related to an attempt to use Qt's bundled zlib by enforcing use of system assimp
+ sed -i 's|include.*||g' tools/qgltf/qgltf.pro
}
build() {
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 6af63ac0393e..8d44eebf041d 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -4,18 +4,20 @@
# Contributor: ant32 <antreimer@gmail.com>
% end
\
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=(<%== include 'fragments/mingw-w64-qt5-non_any_archs' %>)
pkgdesc="C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)"
-depends=(<%== qt5deps qw(declarative) %>)
-makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-vulkan-headers')
+depends=(<%== qt5deps qw(declarative) %> 'mingw-w64-assimp')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-vulkan-headers' 'assimp')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
\
% content_for prepare => begin
- # ensure qgltf is linked against zlib
- echo 'LIBS += -L/usr/lib -lz' >> tools/qgltf/qgltf.pro
+ # ensure qgltf is linked against assimp and zlib
+ echo 'LIBS += -L/usr/lib -lassimp -lz' >> tools/qgltf/qgltf.pro
+ # avoid linker errors related to an attempt to use Qt's bundled zlib by enforcing use of system assimp
+ sed -i 's|include.*||g' tools/qgltf/qgltf.pro
% end
\
% content_for build_config_before_make => begin