summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip A Reimer2015-08-26 21:23:38 -0600
committerPhilip A Reimer2015-08-26 21:23:38 -0600
commit5c64e79f4d156e95fc9f574d98fd005908bb66c7 (patch)
tree878d19a7f62103592af3496ad8551f81b42169a4
downloadaur-5c64e79f4d156e95fc9f574d98fd005908bb66c7.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD53
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7caa6da8247a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mingw-w64-qt5-3d
+ pkgdesc = Qt5 for Windows -- Qt3d module (mingw-w64)
+ pkgver = 5.5.0
+ pkgrel = 1
+ url = http://qt-project.org/
+ arch = any
+ license = GPL3
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-qt5-base
+ depends = mingw-w64-qt5-declarative
+ depends = mingw-w64-qt5-quick1
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://download.qt-project.org/official_releases/qt/5.5/5.5.0/submodules/qt3d-opensource-src-5.5.0.tar.xz
+ md5sums = 508c90c3a2a5f37f0f7c2dd696ab10f5
+
+pkgname = mingw-w64-qt5-3d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c038310d097
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: ant32 <antreimer@gmail.com>
+
+_qt_module=qt3d
+pkgname="mingw-w64-qt5-3d"
+pkgver=5.5.0
+pkgrel=1
+arch=('any')
+pkgdesc="Qt5 for Windows -- Qt3d module (mingw-w64)"
+depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative' 'mingw-w64-qt5-quick1')
+makedepends=('mingw-w64-gcc')
+options=('!strip' '!buildflags' 'staticlibs')
+license=('GPL3' 'LGPL')
+url="http://qt-project.org/"
+_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
+source=("http://download.qt-project.org/official_releases/qt/5.5/${pkgver}/submodules/${_pkgfqn}.tar.xz")
+md5sums=('508c90c3a2a5f37f0f7c2dd696ab10f5')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro
+ make
+
+ popd
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # The .dll's are installed in both bindir and libdir
+ # One copy of the .dll's is sufficient
+ rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
+
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/"*.dll.a
+
+ popd
+ done
+
+ # .prl files aren't interesting for us
+ find "${pkgdir}" -name "*.prl" -delete
+}