summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-06-22 20:35:55 +0200
committerMartchus2016-06-22 20:35:55 +0200
commit6f6bf67d22cbc058c4ba8f2fe66a99e167224b70 (patch)
tree469f42e48ee60e7cb0e402d73eb15f4098f6ecbd
parentad67973af59ca7ed719d411b46446b0325115da4 (diff)
downloadaur-6f6bf67d22cbc058c4ba8f2fe66a99e167224b70.tar.gz
Update to 5.7.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dea9b5be4453..dd5bd3919ea7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
# Generated by mksrcinfo v8
-# Thu Jun 16 08:00:10 UTC 2016
+# Wed Jun 22 18:35:50 UTC 2016
pkgbase = mingw-w64-qt5-3d
pkgdesc = C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)
- pkgver = 5.6.1
+ pkgver = 5.7.0
pkgrel = 1
url = https://www.qt.io/
- arch = any
+ arch = i686
+ arch = x86_64
license = GPL3
license = LGPL
makedepends = mingw-w64-gcc
@@ -13,8 +14,8 @@ pkgbase = mingw-w64-qt5-3d
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.6/5.6.1/submodules/qt3d-opensource-src-5.6.1.tar.xz
- md5sums = 8227248e5800be8d684a2700fca143e6
+ source = https://download.qt.io/official_releases/qt/5.7/5.7.0/submodules/qt3d-opensource-src-5.7.0.tar.xz
+ md5sums = 3219ec1a97c155915b1f0f036f13854e
pkgname = mingw-w64-qt5-3d
diff --git a/PKGBUILD b/PKGBUILD
index d6fdfc988c29..d903ebe450b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,9 @@
_qt_module=qt3d
pkgname="mingw-w64-qt5-3d"
-pkgver=5.6.1
+pkgver=5.7.0
pkgrel=1
-arch=('any')
+arch=('i686' 'x86_64')
pkgdesc="C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)"
depends=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc')
@@ -17,7 +17,7 @@ license=('GPL3' 'LGPL')
url="https://www.qt.io/"
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-md5sums=('8227248e5800be8d684a2700fca143e6')
+md5sums=('3219ec1a97c155915b1f0f036f13854e')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -34,11 +34,11 @@ build() {
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- # out Qt 5 build uses the system zlib for host builds
- # seems like we need to remember Qt about that here again
${_arch}-qmake-qt5 ../${_qt_module}.pro
- make
+ make qmake_all
+ find ./tools -type f -iname 'Makefile' -exec sed -i "s|-lQt5Bootstrap|-L/usr/$_arch/lib -lQt5Bootstrap|g" {} \;
+ make
popd
done
}
@@ -55,9 +55,9 @@ package() {
# One copy of the .dll's is sufficient
rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
- strip --strip-all "${pkgdir}/usr/${_arch}/lib/qt/bin/"*
find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
find "${pkgdir}/usr/${_arch}" -name "*.a" -o -name "*.dll" | xargs -rtl1 ${_arch}-strip -g
+ strip --strip-all "${pkgdir}/usr/${_arch}/lib/qt/bin/"*
popd
done