summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-29 19:09:33 +0100
committerMartchus2020-01-29 19:09:33 +0100
commit8498b972cdbb0c44336a443dedffcf2f5f8846fe (patch)
tree449c9cc65c425fbc0d7daa7f49120e3901fa2d84
parent65e2c6cb2f2f53ac89fae269af3d60d1b4fc3cea (diff)
downloadaur-8498b972cdbb0c44336a443dedffcf2f5f8846fe.tar.gz
Update to 5.14.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--PKGBUILD.sh.ep28
-rw-r--r--qt3d-sha256.txt1
4 files changed, 42 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b11c26aa98e..48208d7416dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-3d
pkgdesc = C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)
- pkgver = 5.14.0
+ pkgver = 5.14.1
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -18,8 +18,8 @@ pkgbase = mingw-w64-qt5-3d
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.14/5.14.0/submodules/qt3d-everywhere-src-5.14.0.tar.xz
- sha256sums = 515b57d0f99be48f70817cf73bc8a0c0e63f7c9c41dbf35fc8baf065fc752515
+ source = https://download.qt.io/official_releases/qt/5.14/5.14.1/submodules/qt3d-everywhere-src-5.14.1.tar.xz
+ sha256sums = 86f425e8bdf55b7b3f6a8384c2b9cffee30407fcf87ece0db060fdfb797a0774
pkgname = mingw-w64-qt5-3d
diff --git a/PKGBUILD b/PKGBUILD
index c0fca52f448b..24bba2ad19b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,31 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
_qt_module=qt3d
-pkgname="mingw-w64-qt5-3d"
-pkgver=5.14.0
+pkgname=mingw-w64-qt5-3d
+pkgver=5.14.1
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)"
depends=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
-license=('GPL3' 'LGPL3' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('515b57d0f99be48f70817cf73bc8a0c0e63f7c9c41dbf35fc8baf065fc752515')
+sha256sums=('86f425e8bdf55b7b3f6a8384c2b9cffee30407fcf87ece0db060fdfb797a0774')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
@@ -45,7 +50,7 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
# Search paths for host standard library (/usr/lib) and for Qt5Bootstrap (/usr/$_arch/lib) are not set correctly by qmake
# hence we need insert those paths manually
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..3369c4da70e2
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,28 @@
+% layout 'mingw-w64-qt5-module';
+\
+% content_for additional_contributors => begin
+# Contributor: ant32 <antreimer@gmail.com>
+% end
+\
+pkgver=5.14.1
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)"
+depends=('mingw-w64-qt5-declarative')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+\
+% content_for prepare => begin
+
+ # ensure qgltf is linked against zlib
+ echo 'LIBS += -L/usr/lib -lz' >> tools/qgltf/qgltf.pro
+% end
+\
+% content_for build_config_before_make => begin
+
+ # Search paths for host standard library (/usr/lib) and for Qt5Bootstrap (/usr/$_arch/lib) are not set correctly by qmake
+ # hence we need insert those paths manually
+ make qmake_all
+ find ./tools -type f -iname 'Makefile' -exec sed -i "s|-lQt5Bootstrap|-L/usr/$_arch/lib -lQt5Bootstrap|g" {} \;
+
+% end
diff --git a/qt3d-sha256.txt b/qt3d-sha256.txt
new file mode 100644
index 000000000000..4809049b091a
--- /dev/null
+++ b/qt3d-sha256.txt
@@ -0,0 +1 @@
+86f425e8bdf55b7b3f6a8384c2b9cffee30407fcf87ece0db060fdfb797a0774