summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-05-28 21:54:43 +0200
committerMartchus2018-05-28 21:54:43 +0200
commitd2deb30e00bcccc7a54b16a4eaa80f7d9db42f3f (patch)
tree9574547d3a6ff4ee230216e9a3186d633ac8c1c3
parent77a4affdde97c03bafa01568754a6f1f2337c75d (diff)
downloadaur-d2deb30e00bcccc7a54b16a4eaa80f7d9db42f3f.tar.gz
Update to 5.11.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD32
2 files changed, 24 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24466e0b1f81..dbec8a4d0fde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Feb 19 19:15:14 UTC 2018
pkgbase = mingw-w64-qt5-3d
pkgdesc = C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)
- pkgver = 5.10.1
+ pkgver = 5.11.0
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -20,8 +18,8 @@ pkgbase = mingw-w64-qt5-3d
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.10/5.10.1/submodules/qt3d-everywhere-src-5.10.1.tar.xz
- sha256sums = 041fb42536a72bbf9be17a6f52d4b73ce93fb98b456fd63503cc47d80d196b3b
+ source = https://download.qt.io/official_releases/qt/5.11/5.11.0/submodules/qt3d-everywhere-src-5.11.0.tar.xz
+ sha256sums = 4d541516abb31a831a668d2be984e3af7cc6bffaa3af6223a76bdd5dd25870c0
pkgname = mingw-w64-qt5-3d
diff --git a/PKGBUILD b/PKGBUILD
index 8975962cee41..e9fd7ce32542 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_qt_module=qt3d
pkgname="mingw-w64-qt5-3d"
-pkgver=5.10.1
+pkgver=5.11.0
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)"
@@ -21,7 +21,7 @@ license=('GPL3' 'LGPL3' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('041fb42536a72bbf9be17a6f52d4b73ce93fb98b456fd63503cc47d80d196b3b')
+sha256sums=('4d541516abb31a831a668d2be984e3af7cc6bffaa3af6223a76bdd5dd25870c0')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -67,7 +67,7 @@ package() {
make INSTALL_ROOT="$pkgdir" install
- # Use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ # use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
if [[ -d 'lib' ]]; then
pushd 'lib'
find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
@@ -79,19 +79,29 @@ package() {
popd
fi
- # The .dll's are installed in both bindir and libdir, one copy of the .dll's is sufficient
- find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
+ # replace library path in *.prl files so it points to the installed location and not the build directory
+ find "${pkgdir}/usr/${_arch}/lib" \( -type f -name '*.prl' -o -name '*.pc' \) -exec sed -i -e "s:$PWD/lib:/usr/$_arch/lib:g" {} \;
+
+ # remove prl files for debug version
+ if ! [[ $MINGW_W64_QT_DEBUG_BUILD ]]; then
+ for file in $(find "${pkgdir}/usr/${_arch}" -name '*d.prl' -o -name '*d.static.prl'); do
+ [ -f "${file%d*}${file##*d}" ] && rm "${file}";
+ done
+ fi
+
+ find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name '*.dll' -delete
[ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
- find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \
- find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec ${_arch}-strip --strip-all {} \;
- find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
- find "${pkgdir}/usr/${_arch}" -name "*.a" -exec ${_arch}-strip -g {} \;
- find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -delete || \
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" \( -name '*.a' -not -name 'libQt5QmlDevTools.a' -not -name 'libQt5Bootstrap.a' \) -exec ${_arch}-strip -g {} \;
+ [[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \
+ find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
popd
done
- # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ # drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
done
}