summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-03-28 19:40:38 +0200
committerMartchus2016-03-28 19:40:38 +0200
commitf36597c7216a592c02a667b8675e8668b2331364 (patch)
tree8650ba8a8970aef519d6e4377e3c0b638b3c6642
parent04a8301938af436cd488260748edbb55747886ae (diff)
downloadaur-f36597c7216a592c02a667b8675e8668b2331364.tar.gz
updated to 5.6.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
2 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index affb00cbb7af..d4fc0653cf7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,20 @@
# Generated by mksrcinfo v8
-# Wed Feb 3 22:50:54 UTC 2016
+# Mon Mar 28 17:31:58 UTC 2016
pkgbase = mingw-w64-qt5-3d
pkgdesc = C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)
- pkgver = 5.5.1
+ pkgver = 5.6.0
pkgrel = 1
url = https://www.qt.io/
arch = any
license = GPL3
license = LGPL
makedepends = mingw-w64-gcc
- depends = mingw-w64-qt5-base
depends = mingw-w64-qt5-declarative
- depends = mingw-w64-qt5-quick1
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.5/5.5.1/submodules/qt3d-opensource-src-5.5.1.tar.xz
- md5sums = 872dfbe166154c2e0e89317ab23d2cd6
+ source = https://download.qt.io/official_releases/qt/5.6/5.6.0/submodules/qt3d-opensource-src-5.6.0.tar.xz
+ md5sums = fba04c921d53fc3ec6794e2a2a75ca60
pkgname = mingw-w64-qt5-3d
diff --git a/PKGBUILD b/PKGBUILD
index 1d96b7749314..dce731ee86fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,41 @@
# Maintainer: Martchus <martchus@gmx.net>
# Contributor: ant32 <antreimer@gmail.com>
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
_qt_module=qt3d
pkgname="mingw-w64-qt5-3d"
-pkgver=5.5.1
+pkgver=5.6.0
pkgrel=1
arch=('any')
pkgdesc="C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)"
-depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative' 'mingw-w64-qt5-quick1')
+depends=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc')
options=('!strip' '!buildflags' 'staticlibs')
license=('GPL3' 'LGPL')
url="https://www.qt.io/"
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-md5sums=('872dfbe166154c2e0e89317ab23d2cd6')
+md5sums=('fba04c921d53fc3ec6794e2a2a75ca60')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ # ensure qgltf is linked against zlib
+ echo 'LIBS += -L/usr/lib -lz' >> tools/qgltf/qgltf.pro
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
+ # out Qt 5 build uses the system zlib for host builds
+ # seems like we need to remember Qt about that here again
${_arch}-qmake-qt5 ../${_qt_module}.pro
make
@@ -43,8 +55,9 @@ package() {
# One copy of the .dll's is sufficient
rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
- ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
- ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/"*.dll.a
+ strip --strip-all "${pkgdir}/usr/${_arch}/lib/qt/bin/"*
+ find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.a" -o -name "*.dll" | xargs -rtl1 ${_arch}-strip -g
popd
done