summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:11 +0100
committerMartchus2022-03-08 23:35:11 +0100
commit962d3d08920c906cf73dbd4e47f2c779ab093c6b (patch)
tree33ba7ef47b4b668deec5cefb48d58930601b8962
parent72c0f9762c6af9681b366233d8fc4d025bab6293 (diff)
downloadaur-962d3d08920c906cf73dbd4e47f2c779ab093c6b.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 25 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1fdc74f2386..d58c65b49514 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-3d-static
pkgdesc = C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r18
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -12,13 +12,15 @@ pkgbase = mingw-w64-qt5-3d-static
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
makedepends = mingw-w64-vulkan-headers
+ makedepends = assimp
+ makedepends = git
depends = mingw-w64-qt5-declarative-static
+ depends = mingw-w64-assimp
depends = mingw-w64-qt5-3d
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qt3d-everywhere-src-5.15.2.tar.xz
- sha256sums = 03ed6a48c813c75296c19f5d721184ab168280b69d2656cf16f877d3d4c55c1d
+ source = git+https://invent.kde.org/qt/qt/qt3d#commit=6d926ec2739f2289c6b0bbfbc325700046e1ceee
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-3d-static
-
diff --git a/PKGBUILD b/PKGBUILD
index eec7ddcf6a66..3f617caff112 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,30 +10,41 @@
_qt_module=qt3d
pkgname=mingw-w64-qt5-3d-static
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)"
-depends=('mingw-w64-qt5-declarative-static')
-makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-vulkan-headers')
+depends=('mingw-w64-qt5-declarative-static' 'mingw-w64-assimp')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-vulkan-headers' 'assimp')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
+_commit=6d926ec2739f2289c6b0bbfbc325700046e1ceee
+_basever=$pkgver
+pkgver+=+kde+r18
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('03ed6a48c813c75296c19f5d721184ab168280b69d2656cf16f877d3d4c55c1d')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
prepare() {
cd "${srcdir}/${_pkgfqn}"
- # ensure qgltf is linked against zlib
- echo 'LIBS += -L/usr/lib -lz' >> tools/qgltf/qgltf.pro
+ # ensure qgltf is linked against assimp and zlib
+ echo 'LIBS += -L/usr/lib -lassimp -lz' >> tools/qgltf/qgltf.pro
+ # avoid linker errors related to an attempt to use Qt's bundled zlib by enforcing use of system assimp
+ sed -i 's|include.*||g' tools/qgltf/qgltf.pro
}
build() {