summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-12-11 18:59:18 +0000
committerMartchus2018-12-11 18:59:18 +0000
commit1dd0c75436890e2c89ce12b36acd66c7b436bfb3 (patch)
tree518c23fcd757283518452a462c3c2c9e4a1187e5
parentc90d5470e28517de948f8e2c4c2410a09043a887 (diff)
downloadaur-1dd0c75436890e2c89ce12b36acd66c7b436bfb3.tar.gz
Update to 5.12.0
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch4
-rw-r--r--0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch10
-rw-r--r--PKGBUILD8
4 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29188faf2898..7e62eb108af8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-activeqt
pkgdesc = ActiveX integration framework (mingw-w64)
- pkgver = 5.11.2
+ pkgver = 5.12.0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -19,12 +19,12 @@ pkgbase = mingw-w64-qt5-activeqt
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.11/5.11.2/submodules/qtactiveqt-everywhere-src-5.11.2.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.12/5.12.0/submodules/qtactiveqt-everywhere-src-5.12.0.tar.xz
source = 0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
source = 0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
- sha256sums = b06c634059e2069584dccf331a45074e6a2c63ca6ea5576769c47a985173a041
- sha256sums = 608d6905d407c3c6939c00fc2962a906f76086272bbeca811b9f1529b30ed50a
- sha256sums = a04aededab0eb220be9000dafc06ffb9f9541d158e639b58a54eeef922a3c60a
+ sha256sums = a22876b4243cb433042e7f4812974eac05935872f39cc880a3587bc3eae86d3e
+ sha256sums = 2c6278acc994f57afd4cd93bd183b73bf744e504d7ee007d73e8fe1568d760f5
+ sha256sums = a14b931d373cce075318702ec513d829750f3ab2db73d6ed5433db4bd1f577ae
pkgname = mingw-w64-qt5-activeqt
diff --git a/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch b/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
index 914c99c26b0e..d7a4cee836c3 100644
--- a/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
+++ b/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
@@ -1,4 +1,4 @@
-From f383e94a641c227fdafbc95f5b20fc85784f7d5e Mon Sep 17 00:00:00 2001
+From 0cff734180ff88a27b16aee3f5974577a39d0cb7 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 2 Jun 2017 17:17:46 +0200
Subject: [PATCH 1/2] Don't require windows.h when using native Linux gcc
@@ -17,5 +17,5 @@ index 7f9a8d4..6f3548a 100644
SOURCES = main.cpp
--
-2.19.0
+2.19.2
diff --git a/0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch b/0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
index a87ef7c3ab99..e0a3cfe3fa31 100644
--- a/0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
+++ b/0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
@@ -1,4 +1,4 @@
-From 4a0b20d46895bbcc4bc85a11640c9c54364c508a Mon Sep 17 00:00:00 2001
+From 92e5888ab26ec60efeb1fe28ce3edbba35fec960 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 2 Jun 2017 17:21:08 +0200
Subject: [PATCH 2/2] Handle win64 in dumpcpp and
@@ -11,10 +11,10 @@ See https://bugreports.qt.io/browse/QTBUG-46827
2 files changed, 12 insertions(+)
diff --git a/src/activeqt/container/qaxbase.cpp b/src/activeqt/container/qaxbase.cpp
-index 883f1e9..2680baf 100644
+index 722a389..66499cb 100644
--- a/src/activeqt/container/qaxbase.cpp
+++ b/src/activeqt/container/qaxbase.cpp
-@@ -2180,6 +2180,10 @@ void MetaObjectGenerator::readClassInfo()
+@@ -2176,6 +2176,10 @@ void MetaObjectGenerator::readClassInfo()
const QStringList versions = controls.childGroups();
for (const QString &version : versions) {
tlfile = controls.value(QLatin1Char('/') + version + QLatin1String("/0/win32/.")).toString();
@@ -26,7 +26,7 @@ index 883f1e9..2680baf 100644
break;
}
diff --git a/tools/dumpcpp/main.cpp b/tools/dumpcpp/main.cpp
-index 2baad0e..e918e34 100644
+index 4601aef..65eee94 100644
--- a/tools/dumpcpp/main.cpp
+++ b/tools/dumpcpp/main.cpp
@@ -1539,6 +1539,10 @@ int main(int argc, char **argv)
@@ -52,5 +52,5 @@ index 2baad0e..e918e34 100644
}
--
-2.19.0
+2.19.2
diff --git a/PKGBUILD b/PKGBUILD
index 8e42bca7cc50..4937bc980693 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_qt_module=qtactiveqt
pkgname=mingw-w64-qt5-activeqt
-pkgver=5.11.2
+pkgver=5.12.0
pkgrel=1
arch=('any')
pkgdesc="ActiveX integration framework (mingw-w64)"
@@ -23,9 +23,9 @@ _pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch'
'0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch')
-sha256sums=('b06c634059e2069584dccf331a45074e6a2c63ca6ea5576769c47a985173a041'
- '608d6905d407c3c6939c00fc2962a906f76086272bbeca811b9f1529b30ed50a'
- 'a04aededab0eb220be9000dafc06ffb9f9541d158e639b58a54eeef922a3c60a')
+sha256sums=('a22876b4243cb433042e7f4812974eac05935872f39cc880a3587bc3eae86d3e'
+ '2c6278acc994f57afd4cd93bd183b73bf744e504d7ee007d73e8fe1568d760f5'
+ 'a14b931d373cce075318702ec513d829750f3ab2db73d6ed5433db4bd1f577ae')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \