summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2017-12-14 01:06:31 +0100
committerMartchus2017-12-14 01:06:31 +0100
commit4c143d65d598e69dba64195e3f46c0315e4c3dcb (patch)
treea1b7502ac5e35ca8dc795a93379ffb7073168c5e
parent28cec14ef64919139617b1785eeb8194cda14a3f (diff)
downloadaur-4c143d65d598e69dba64195e3f46c0315e4c3dcb.tar.gz
Update to 5.10.0
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch6
-rw-r--r--0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch8
-rw-r--r--PKGBUILD12
4 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ddfd2e63b14..7bfd36fad4c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Oct 16 17:36:32 UTC 2017
+# Thu Dec 14 00:06:31 UTC 2017
pkgbase = mingw-w64-qt5-activeqt
pkgdesc = ActiveX integration framework (mingw-w64)
- pkgver = 5.9.2
+ pkgver = 5.10.0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -21,12 +21,12 @@ pkgbase = mingw-w64-qt5-activeqt
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.9/5.9.2/submodules/qtactiveqt-opensource-src-5.9.2.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.10/5.10.0/submodules/qtactiveqt-everywhere-src-5.10.0.tar.xz
source = 0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
source = 0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
- sha256sums = 60458d1972075b7196122b01d0ef7929cef49cc3f0683f8e46cd3a65b44de5cf
- sha256sums = 7e2f0bd1803d8c6d4ba3618a7ee02d3887f192ef9d3f6ab31d7f5468b515e3c0
- sha256sums = b781aa5f1bccc9be056ba15f1ff3e557cd19b48ad212a37a529dc414844f3af1
+ sha256sums = f9d74034ffe6e54278f1720d4c8c678f80882b9fffa3b698bd212f0a4b5cd674
+ sha256sums = 7e099a0aaa459d25eea88105179237653571ac0a2498c987ab9bdccaf118722b
+ sha256sums = e65bdeeaf11f2e905145ff3aac81a735f5d2f3c68cf5ba69f1ee36ef4b25e50f
pkgname = mingw-w64-qt5-activeqt
diff --git a/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch b/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
index 8606e140dbbd..64d686efaa5f 100644
--- a/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
+++ b/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
@@ -1,4 +1,4 @@
-From 82a268b89f2c68be1ce2d10eb89634bd3bff9715 Mon Sep 17 00:00:00 2001
+From 5e50bfc8c4dbc276ee4ec189794584f7b8bdf2a2 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 2 Jun 2017 17:17:46 +0200
Subject: [PATCH 1/2] Don't require windows.h when using native Linux gcc
@@ -8,7 +8,7 @@ Subject: [PATCH 1/2] Don't require windows.h when using native Linux gcc
1 file changed, 1 deletion(-)
diff --git a/src/tools/idc/idc.pro b/src/tools/idc/idc.pro
-index 1898ed5..524ee2e 100644
+index 7f9a8d4..6f3548a 100644
--- a/src/tools/idc/idc.pro
+++ b/src/tools/idc/idc.pro
@@ -1,4 +1,3 @@
@@ -17,5 +17,5 @@ index 1898ed5..524ee2e 100644
SOURCES = main.cpp
--
-2.14.2
+2.15.1
diff --git a/0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch b/0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
index e82bc22f6f0b..0d76c7a0084a 100644
--- a/0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
+++ b/0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
@@ -1,4 +1,4 @@
-From ba803e4196000080e8e5b5abce811e54318eb08e Mon Sep 17 00:00:00 2001
+From 986644a25ba7d02fb0044b1cb163329e2b8f4e89 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 2 Jun 2017 17:21:08 +0200
Subject: [PATCH 2/2] Handle win64 in dumpcpp and
@@ -11,10 +11,10 @@ See https://bugreports.qt.io/browse/QTBUG-46827
2 files changed, 12 insertions(+)
diff --git a/src/activeqt/container/qaxbase.cpp b/src/activeqt/container/qaxbase.cpp
-index cd564d3..f3c55b1 100644
+index aa66398..087b83c 100644
--- a/src/activeqt/container/qaxbase.cpp
+++ b/src/activeqt/container/qaxbase.cpp
-@@ -2170,6 +2170,10 @@ void MetaObjectGenerator::readClassInfo()
+@@ -2180,6 +2180,10 @@ void MetaObjectGenerator::readClassInfo()
const QStringList versions = controls.childGroups();
for (const QString &version : versions) {
tlfile = controls.value(QLatin1Char('/') + version + QLatin1String("/0/win32/.")).toString();
@@ -52,5 +52,5 @@ index 1f0cca8..d26bd78 100644
}
--
-2.14.2
+2.15.1
diff --git a/PKGBUILD b/PKGBUILD
index 8e98c5b4db7b..7d31fc24f344 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_qt_module=qtactiveqt
pkgname=mingw-w64-qt5-activeqt
-pkgver=5.9.2
+pkgver=5.10.0
pkgrel=1
arch=('any')
pkgdesc="ActiveX integration framework (mingw-w64)"
@@ -19,13 +19,13 @@ options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
license=('GPL3' 'LGPL3' 'LGPL2.1' 'FDL' 'custom')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch'
'0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch')
-sha256sums=('60458d1972075b7196122b01d0ef7929cef49cc3f0683f8e46cd3a65b44de5cf'
- '7e2f0bd1803d8c6d4ba3618a7ee02d3887f192ef9d3f6ab31d7f5468b515e3c0'
- 'b781aa5f1bccc9be056ba15f1ff3e557cd19b48ad212a37a529dc414844f3af1')
+sha256sums=('f9d74034ffe6e54278f1720d4c8c678f80882b9fffa3b698bd212f0a4b5cd674'
+ '7e099a0aaa459d25eea88105179237653571ac0a2498c987ab9bdccaf118722b'
+ 'e65bdeeaf11f2e905145ff3aac81a735f5d2f3c68cf5ba69f1ee36ef4b25e50f')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \