summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2017-06-08 21:42:48 +0200
committerMartchus2017-06-08 21:42:48 +0200
commit5b36484a2d3f2d2e78fc85598479cae0cc5dc3e9 (patch)
tree6147a39f75604b03d4d2a398f85f34c42f1389ae
parenta9211fb33b7f43ad9590f1a92751b6d2e3b185b2 (diff)
downloadaur-5b36484a2d3f2d2e78fc85598479cae0cc5dc3e9.tar.gz
Update to 5.9.0
-rw-r--r--.SRCINFO16
-rw-r--r--0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch21
-rw-r--r--0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch (renamed from qtactiveqt-win64.patch)39
-rw-r--r--PKGBUILD21
-rw-r--r--qt5-activeqt-fix-compilation.patch15
-rw-r--r--qtactiveqt-fix-build.patch7
6 files changed, 67 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f7a6757e445..24d1881fb536 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Feb 9 20:01:02 UTC 2017
+# Thu Jun 8 19:42:48 UTC 2017
pkgbase = mingw-w64-qt5-activeqt
pkgdesc = ActiveX integration framework (mingw-w64)
- pkgver = 5.8.0
+ pkgver = 5.9.0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -21,12 +21,12 @@ pkgbase = mingw-w64-qt5-activeqt
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.8/5.8.0/submodules/qtactiveqt-opensource-src-5.8.0.tar.xz
- source = qtactiveqt-fix-build.patch
- source = qtactiveqt-win64.patch
- md5sums = d1c8ae9489b737957ba100bb27323eb5
- md5sums = 7a7ba436452aa56613b3fbb15684e094
- md5sums = 1264d0274586aec14f96a978b416b048
+ source = https://download.qt.io/official_releases/qt/5.9/5.9.0/submodules/qtactiveqt-opensource-src-5.9.0.tar.xz
+ source = 0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
+ source = 0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
+ sha256sums = d7c7babf1510e0728e80a786fe9d83f6cb931813005d05c85873929207261635
+ sha256sums = 32977d8a1e6cb8b6c4f4c44ac4c801ae7bc2c5ec70563f28e2cb3d01cd379b1f
+ sha256sums = 0efddd784b939e0b78006dd7739b6889664dea0721289d56bc3c5dd7b39fd240
pkgname = mingw-w64-qt5-activeqt
diff --git a/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch b/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
new file mode 100644
index 000000000000..5090095cbb42
--- /dev/null
+++ b/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
@@ -0,0 +1,21 @@
+From b3ea4c8e4cba65883b7c8f66bdc968ce14ba58a6 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Fri, 2 Jun 2017 17:17:46 +0200
+Subject: [PATCH 1/2] Don't require windows.h when using native Linux gcc
+
+---
+ src/tools/idc/idc.pro | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/tools/idc/idc.pro b/src/tools/idc/idc.pro
+index 1898ed5..524ee2e 100644
+--- a/src/tools/idc/idc.pro
++++ b/src/tools/idc/idc.pro
+@@ -1,4 +1,3 @@
+-option(host_build)
+ CONFIG += force_bootstrap
+ SOURCES = main.cpp
+
+--
+2.13.0
+
diff --git a/qtactiveqt-win64.patch b/0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
index f2ca3d690b5e..208968473a07 100644
--- a/qtactiveqt-win64.patch
+++ b/0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
@@ -1,9 +1,22 @@
-diff -rupN qtactiveqt-opensource-src-5.4.1/src/activeqt/container/qaxbase.cpp qtactiveqt-opensource-src-5.4.1-new/src/activeqt/container/qaxbase.cpp
---- qtactiveqt-opensource-src-5.4.1/src/activeqt/container/qaxbase.cpp 2015-02-17 05:56:13.000000000 +0100
-+++ qtactiveqt-opensource-src-5.4.1-new/src/activeqt/container/qaxbase.cpp 2015-06-23 16:41:44.483979750 +0200
-@@ -2164,6 +2164,10 @@
- QStringList versions = controls.childGroups();
- foreach (const QString &version, versions) {
+From c8c5802c04b4fbd7fc34ba70af93851a35294741 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Fri, 2 Jun 2017 17:21:08 +0200
+Subject: [PATCH 2/2] Handle win64 in dumpcpp and
+ MetaObjectGenerator::readClassInfo
+
+See https://bugreports.qt.io/browse/QTBUG-46827
+---
+ src/activeqt/container/qaxbase.cpp | 4 ++++
+ tools/dumpcpp/main.cpp | 8 ++++++++
+ 2 files changed, 12 insertions(+)
+
+diff --git a/src/activeqt/container/qaxbase.cpp b/src/activeqt/container/qaxbase.cpp
+index 22aec57..64b2f47 100644
+--- a/src/activeqt/container/qaxbase.cpp
++++ b/src/activeqt/container/qaxbase.cpp
+@@ -2170,6 +2170,10 @@ void MetaObjectGenerator::readClassInfo()
+ const QStringList versions = controls.childGroups();
+ for (const QString &version : versions) {
tlfile = controls.value(QLatin1Char('/') + version + QLatin1String("/0/win32/.")).toString();
+ if(tlfile.isEmpty())
+ {
@@ -12,10 +25,11 @@ diff -rupN qtactiveqt-opensource-src-5.4.1/src/activeqt/container/qaxbase.cpp qt
if (!tlfile.isEmpty())
break;
}
-diff -rupN qtactiveqt-opensource-src-5.4.1/tools/dumpcpp/main.cpp qtactiveqt-opensource-src-5.4.1-new/tools/dumpcpp/main.cpp
---- qtactiveqt-opensource-src-5.4.1/tools/dumpcpp/main.cpp 2015-02-17 05:56:13.000000000 +0100
-+++ qtactiveqt-opensource-src-5.4.1-new/tools/dumpcpp/main.cpp 2015-06-23 16:35:53.157273425 +0200
-@@ -1515,6 +1515,10 @@
+diff --git a/tools/dumpcpp/main.cpp b/tools/dumpcpp/main.cpp
+index 97915c1..ae41289 100644
+--- a/tools/dumpcpp/main.cpp
++++ b/tools/dumpcpp/main.cpp
+@@ -1539,6 +1539,10 @@ int main(int argc, char **argv)
typeLib = settings.value(QLatin1Char('/') + codes.at(c) + QLatin1String("/0/win32/.")).toString();
if (QFile::exists(typeLib))
break;
@@ -26,7 +40,7 @@ diff -rupN qtactiveqt-opensource-src-5.4.1/tools/dumpcpp/main.cpp qtactiveqt-ope
}
if (!typeLib.isEmpty())
-@@ -1577,6 +1581,10 @@
+@@ -1598,6 +1602,10 @@ int main(int argc, char **argv)
+ QLatin1String("/win32/.")).toString();
if (QFile::exists(typeLib))
break;
@@ -37,3 +51,6 @@ diff -rupN qtactiveqt-opensource-src-5.4.1/tools/dumpcpp/main.cpp qtactiveqt-ope
}
}
+--
+2.13.0
+
diff --git a/PKGBUILD b/PKGBUILD
index aeca6efcf406..d7af8acfadc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_qt_module=qtactiveqt
pkgname=mingw-w64-qt5-activeqt
-pkgver=5.8.0
+pkgver=5.9.0
pkgrel=1
arch=('any')
pkgdesc="ActiveX integration framework (mingw-w64)"
@@ -21,11 +21,11 @@ license=('GPL3' 'LGPL3' 'LGPL2.1' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
- "qtactiveqt-fix-build.patch"
- "qtactiveqt-win64.patch")
-md5sums=('d1c8ae9489b737957ba100bb27323eb5'
- '7a7ba436452aa56613b3fbb15684e094'
- '1264d0274586aec14f96a978b416b048')
+ '0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch'
+ '0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch')
+sha256sums=('d7c7babf1510e0728e80a786fe9d83f6cb931813005d05c85873929207261635'
+ '32977d8a1e6cb8b6c4f4c44ac4c801ae7bc2c5ec70563f28e2cb3d01cd379b1f'
+ '0efddd784b939e0b78006dd7739b6889664dea0721289d56bc3c5dd7b39fd240')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -35,12 +35,11 @@ _architectures='i686-w64-mingw32 x86_64-w64-mingw32'
prepare() {
cd "${srcdir}/${_pkgfqn}"
- # Don't try to build stuff which requires windows.h with the native Linux gcc
- patch -p1 -i ../qtactiveqt-fix-build.patch
- # dumpcpp and MetaObjectGenerator::readClassInfo do not handle win64
- # https://bugreports.qt.io/browse/QTBUG-46827
- patch -p1 -i ../qtactiveqt-win64.patch
+ # Apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ patch -p1 -i "$patch"
+ done
}
build() {
diff --git a/qt5-activeqt-fix-compilation.patch b/qt5-activeqt-fix-compilation.patch
deleted file mode 100644
index ff2b8359115b..000000000000
--- a/qt5-activeqt-fix-compilation.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/activeqt/control/qaxserverbase.cpp.orig 2012-09-10 22:01:40.963557678 +0200
-+++ src/activeqt/control/qaxserverbase.cpp 2012-09-10 22:05:37.913161773 +0200
-@@ -4033,12 +4033,10 @@
- }
-
-
--#ifndef QT_STATIC // avoid conflict with symbol in static lib
- bool qt_sendSpontaneousEvent(QObject *o, QEvent *e)
- {
- return QCoreApplication::sendSpontaneousEvent(o, e);
- }
--#endif
-
- /*
- Tries to set the size of the control.
diff --git a/qtactiveqt-fix-build.patch b/qtactiveqt-fix-build.patch
deleted file mode 100644
index 7c10be469cd7..000000000000
--- a/qtactiveqt-fix-build.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- qtactiveqt-opensource-src-5.3.0/src/tools/idc/idc.pro.orig 2014-05-26 00:05:53.258370322 +0200
-+++ qtactiveqt-opensource-src-5.3.0/src/tools/idc/idc.pro 2014-05-26 00:06:18.131627963 +0200
-@@ -1,4 +1,3 @@
--option(host_build)
- CONFIG += force_bootstrap
- SOURCES = main.cpp
-