summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-11-21 16:58:14 +0100
committerMartchus2020-11-21 16:58:14 +0100
commit7443dbac95f4f92f2d054fdc8d2859f96d618881 (patch)
treef44b44000149d51235dd0cead00c1e1ef0ae6968
parent604a6dd6fef49bc1efbe6a90c0d6238feadd8744 (diff)
downloadaur-7443dbac95f4f92f2d054fdc8d2859f96d618881.tar.gz
Update to 5.15.2
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch4
-rw-r--r--0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch16
-rw-r--r--PKGBUILD8
-rw-r--r--PKGBUILD.sh.ep2
-rw-r--r--qtactiveqt-sha256.txt2
6 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54830cad910b..0018648518fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-activeqt
pkgdesc = ActiveX integration framework (mingw-w64)
- pkgver = 5.15.1
+ pkgver = 5.15.2
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -19,12 +19,12 @@ pkgbase = mingw-w64-qt5-activeqt
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.1/submodules/qtactiveqt-everywhere-src-5.15.1.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtactiveqt-everywhere-src-5.15.2.tar.xz
source = 0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
source = 0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
- sha256sums = 4f8bbd320349d89ae7867de4bc752cf984f96c6def2b951564dcd5e4f53529c1
- sha256sums = b76fbe967e7f8af79fd2e4a1d64144edbfcd3ab5e7b70a19410215f93ccc16c1
- sha256sums = 486e1b7856e8b516abe93828edf83ede4f7e557e23ba1f2071034e984569c343
+ sha256sums = 868161fee0876d17079cd5bed58d1667bf19ffd0018cbe515129f11510ad2a5c
+ sha256sums = 05443c9a67b30160a7d4264da9c57b1a2fdbc3c74bab8e9f69c51ac8feeac2cb
+ sha256sums = 06aa9413f31edd4f8c51d65cf6a8e1add8d5a6af2588f18bdc2e67164ebdaea7
pkgname = mingw-w64-qt5-activeqt
diff --git a/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch b/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
index 5c9beffbe131..bda43b2f5722 100644
--- a/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
+++ b/0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch
@@ -1,4 +1,4 @@
-From ab2f571f3c72bea8ab6478db089592c301259394 Mon Sep 17 00:00:00 2001
+From f3eb4a339ad53d96f59cf172e6e5f356b0d43bbd Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 2 Jun 2017 17:17:46 +0200
Subject: [PATCH 1/2] Don't require windows.h when using native Linux gcc
@@ -17,5 +17,5 @@ index 7f9a8d4..6f3548a 100644
SOURCES = main.cpp
--
-2.28.0
+2.29.2
diff --git a/0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch b/0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
index aa12cac1cd3d..639455959817 100644
--- a/0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
+++ b/0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
@@ -1,4 +1,4 @@
-From 5652ce8e4225793cb4041be6aadee82d4ac84c27 Mon Sep 17 00:00:00 2001
+From 7b74ca5cb9fb9077eb26e73a84822850e8608c50 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 2 Jun 2017 17:21:08 +0200
Subject: [PATCH 2/2] Handle win64 in dumpcpp and
@@ -11,7 +11,7 @@ See https://bugreports.qt.io/browse/QTBUG-46827
2 files changed, 12 insertions(+)
diff --git a/src/activeqt/container/qaxbase.cpp b/src/activeqt/container/qaxbase.cpp
-index 3203096..6adf9eb 100644
+index 2903cdf..12e3801 100644
--- a/src/activeqt/container/qaxbase.cpp
+++ b/src/activeqt/container/qaxbase.cpp
@@ -2202,6 +2202,10 @@ void MetaObjectGenerator::readClassInfo()
@@ -26,11 +26,11 @@ index 3203096..6adf9eb 100644
break;
}
diff --git a/tools/dumpcpp/main.cpp b/tools/dumpcpp/main.cpp
-index 780d41b..029e10b 100644
+index 55aa80b..a1282f2 100644
--- a/tools/dumpcpp/main.cpp
+++ b/tools/dumpcpp/main.cpp
-@@ -1580,6 +1580,10 @@ int main(int argc, char **argv)
- typeLib = settings.value(QLatin1Char('/') + codes.at(c) + QLatin1String("/0/win32/.")).toString();
+@@ -1586,6 +1586,10 @@ int main(int argc, char **argv)
+ typeLib = settings.value(keyPrefix + QLatin1String("win32/.")).toString();
if (QFile::exists(typeLib))
break;
+ typeLib = settings.value(QLatin1String("/") + codes.at(c) + QLatin1String("/0/win64/.")).toByteArray();
@@ -40,8 +40,8 @@ index 780d41b..029e10b 100644
}
if (!typeLib.isEmpty())
-@@ -1639,6 +1643,10 @@ int main(int argc, char **argv)
- + QLatin1String("/win32/.")).toString();
+@@ -1650,6 +1654,10 @@ int main(int argc, char **argv)
+ typeLib = settings.value(keyPrefix + QLatin1String("win32/.")).toString();
if (QFile::exists(typeLib))
break;
+ typeLib = settings.value(key + QLatin1String("/") + codes.at(c) + QLatin1String("/win64/.")).toByteArray();
@@ -52,5 +52,5 @@ index 780d41b..029e10b 100644
}
--
-2.28.0
+2.29.2
diff --git a/PKGBUILD b/PKGBUILD
index bf562af01c62..817252f4ad54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@
_qt_module=qtactiveqt
pkgname=mingw-w64-qt5-activeqt
-pkgver=5.15.1
+pkgver=5.15.2
pkgrel=1
arch=('any')
pkgdesc="ActiveX integration framework (mingw-w64)"
@@ -29,9 +29,9 @@ _pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch'
'0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch')
-sha256sums=('4f8bbd320349d89ae7867de4bc752cf984f96c6def2b951564dcd5e4f53529c1'
- 'b76fbe967e7f8af79fd2e4a1d64144edbfcd3ab5e7b70a19410215f93ccc16c1'
- '486e1b7856e8b516abe93828edf83ede4f7e557e23ba1f2071034e984569c343')
+sha256sums=('868161fee0876d17079cd5bed58d1667bf19ffd0018cbe515129f11510ad2a5c'
+ '05443c9a67b30160a7d4264da9c57b1a2fdbc3c74bab8e9f69c51ac8feeac2cb'
+ '06aa9413f31edd4f8c51d65cf6a8e1add8d5a6af2588f18bdc2e67164ebdaea7')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index fc340891a74a..c1ea7068b90e 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -10,7 +10,7 @@
% end
\
-pkgver=5.15.1
+pkgver=5.15.2
pkgrel=1
arch=('any')
pkgdesc="ActiveX integration framework (mingw-w64)"
diff --git a/qtactiveqt-sha256.txt b/qtactiveqt-sha256.txt
index aa4e9c513b90..25f9d7e18b3d 100644
--- a/qtactiveqt-sha256.txt
+++ b/qtactiveqt-sha256.txt
@@ -1 +1 @@
-4f8bbd320349d89ae7867de4bc752cf984f96c6def2b951564dcd5e4f53529c1
+868161fee0876d17079cd5bed58d1667bf19ffd0018cbe515129f11510ad2a5c