aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip A Reimer2015-09-25 12:58:43 -0600
committerPhilip A Reimer2015-09-25 12:58:43 -0600
commit05d619b31c5b91a4a2274655c57106e9cadb2d50 (patch)
tree23beb133f58a482074843e7acfee774931abd0ad
parent126d8edf333f59cf1734030ae2acdab87fbf83b6 (diff)
downloadaur-05d619b31c5b91a4a2274655c57106e9cadb2d50.tar.gz
fix harfbuzz
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--qt5-fix-static-harfbuzz-detection.patch2
3 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e38249c53f25..705c1d5577f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-qt5-base
pkgdesc = A cross-platform application and UI framework (mingw-w64)
pkgver = 5.5.0
- pkgrel = 1
+ pkgrel = 2
url = http://qt-project.org
arch = i686
arch = x86_64
@@ -62,7 +62,7 @@ pkgbase = mingw-w64-qt5-base
md5sums = 6a6bc88f35ac8080869de39bc128ce5b
md5sums = e793479e0b86b39ddafd328140f1a24c
md5sums = 40de3aaf7d713034e06f4eece665b1ba
- md5sums = 1a7921cadeb5c3db383dea068519e8d3
+ md5sums = 4149c27286f110e37893d1764d4c8a68
md5sums = 6aea7182982098de045721f51bf20fc2
md5sums = a265dea62755caf38187114143999224
md5sums = 612a4dfb9f1a3898a1920c28bb999159
diff --git a/PKGBUILD b/PKGBUILD
index d42fcc581d9a..9a1f26232510 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: jellysheep <max.mail@dameweb.de>
pkgname=mingw-w64-qt5-base
pkgver=5.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
arch=(i686 x86_64)
url="http://qt-project.org"
@@ -65,7 +65,7 @@ md5sums=('252613b5a180c94d7196d10467a4f08b'
'6a6bc88f35ac8080869de39bc128ce5b'
'e793479e0b86b39ddafd328140f1a24c'
'40de3aaf7d713034e06f4eece665b1ba'
- '1a7921cadeb5c3db383dea068519e8d3'
+ '4149c27286f110e37893d1764d4c8a68'
'6aea7182982098de045721f51bf20fc2'
'a265dea62755caf38187114143999224'
'612a4dfb9f1a3898a1920c28bb999159'
@@ -211,6 +211,7 @@ build() {
-system-libpng \
-system-libjpeg \
-system-sqlite \
+ -system-harfbuzz \
-no-fontconfig \
-iconv \
-openssl \
diff --git a/qt5-fix-static-harfbuzz-detection.patch b/qt5-fix-static-harfbuzz-detection.patch
index 80dc3b29b20c..fa04b3362f9c 100644
--- a/qt5-fix-static-harfbuzz-detection.patch
+++ b/qt5-fix-static-harfbuzz-detection.patch
@@ -4,4 +4,4 @@
SOURCES = harfbuzz.cpp
CONFIG -= qt dylib
-LIBS += -lharfbuzz
-+LIBS += -lharfbuzz -lglib-2.0 -lws2_32 -lole32 -lwinmm -lshlwapi -lintl
++LIBS += -lharfbuzz -lglib-2.0 -lws2_32 -lole32 -lwinmm -lshlwapi -lintl -liconv