aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-06-22 20:35:58 +0200
committerMartchus2016-06-22 20:35:58 +0200
commit5b0001b591181a3cf834e5e579e12f67552dda36 (patch)
treebab6e82d07dfac229e139a085149350e2a06218d
parente7da1b8812868eb45afda60b2c231f0eb3c45f08 (diff)
downloadaur-5b0001b591181a3cf834e5e579e12f67552dda36.tar.gz
Update to 5.7.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--qtbase-1-fixes.patch60
3 files changed, 10 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a18e8d33a936..49134819e4a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jun 16 08:00:16 UTC 2016
+# Wed Jun 22 18:35:55 UTC 2016
pkgbase = mingw-w64-qt5-base
pkgdesc = A cross-platform application and UI framework (mingw-w64)
- pkgver = 5.6.1
+ pkgver = 5.7.0
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -31,7 +31,7 @@ pkgbase = mingw-w64-qt5-base
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.6/5.6.1/submodules/qtbase-opensource-src-5.6.1.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.7/5.7.0/submodules/qtbase-opensource-src-5.7.0.tar.xz
source = add-angle-support.patch
source = use-external-angle-library.patch
source = qt5-workaround-pkgconfig-install-issue.patch
@@ -48,7 +48,7 @@ pkgbase = mingw-w64-qt5-base
source = fix-static-psql-mysql.patch
source = qtbase-1-fixes.patch
source = qt5-fix-implib-ext.patch
- md5sums = b23232190a3df61fe1ba81636987b036
+ md5sums = 184f9460b40752d71b15b827260580c2
md5sums = bab00ccc19d888997f323c80354a7c3f
md5sums = f7e1487de6e85116d9c6bde2eac4fb73
md5sums = bc99c4cc6998295d76f37ed681c20d47
@@ -63,7 +63,7 @@ pkgbase = mingw-w64-qt5-base
md5sums = c15d9f480d0248648fa52aeacb46e3c7
md5sums = 612a4dfb9f1a3898a1920c28bb999159
md5sums = d0eb81aef1a21c65813fe4ddabbc4206
- md5sums = 62d2977e57fccf1f16d7ea6bf06d3279
+ md5sums = 42c4968a0bd29856b683ad1b5d2b2a75
md5sums = 83139869355c2d46921adb25e47cf0fa
pkgname = mingw-w64-qt5-base
diff --git a/PKGBUILD b/PKGBUILD
index 71f7c445d43e..b68b114c6234 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ isOpenGL() {
}
pkgname=mingw-w64-qt5-base
-pkgver=5.6.1
+pkgver=5.7.0
pkgrel=1
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
! isStatic && arch=('i686' 'x86_64')
@@ -64,7 +64,7 @@ source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/sub
"fix-static-psql-mysql.patch"
"qtbase-1-fixes.patch"
"qt5-fix-implib-ext.patch")
-md5sums=('b23232190a3df61fe1ba81636987b036'
+md5sums=('184f9460b40752d71b15b827260580c2'
'bab00ccc19d888997f323c80354a7c3f'
'f7e1487de6e85116d9c6bde2eac4fb73'
'bc99c4cc6998295d76f37ed681c20d47'
@@ -79,7 +79,7 @@ md5sums=('b23232190a3df61fe1ba81636987b036'
'c15d9f480d0248648fa52aeacb46e3c7'
'612a4dfb9f1a3898a1920c28bb999159'
'd0eb81aef1a21c65813fe4ddabbc4206'
- '62d2977e57fccf1f16d7ea6bf06d3279'
+ '42c4968a0bd29856b683ad1b5d2b2a75'
'83139869355c2d46921adb25e47cf0fa')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -204,7 +204,6 @@ build() {
-openssl \
-dbus-linked \
-no-glib \
- -no-gtkstyle \
-no-icu \
-release \
-nomake examples \
@@ -253,7 +252,7 @@ build() {
#sed -e "s|^QT_LFLAGS_MYSQL_R=.*$|QT_LFLAGS_MYSQL_R=\"${QT_LFLAGS_MYSQL_R}\"|g" -i "${srcdir}/${_pkgfqn}/configure"
qt_configure_args_mysql="-mysql_config /this/file/should/not/exist"
- mkdir ../build-${_arch} && pushd ../build-${_arch}
+ mkdir -p ../build-${_arch} && pushd ../build-${_arch}
if isStatic; then
../${_pkgfqn}/configure -static $qt_configure_args $qt_configure_args_mysql
@@ -263,7 +262,7 @@ build() {
# libraries which various compiled tools (like moc) use. As the libQt5Bootstrap*
# libraries aren't installed at this point yet, we have to workaround this
../${_pkgfqn}/configure -shared $qt_configure_args $qt_configure_args_mysql
- LD_LIBRARY_PATH="$PWD/lib" make
+ LD_LIBRARY_PATH="$PWD/lib" LDFLAGS="-L$PWD/lib" make
fi
popd
diff --git a/qtbase-1-fixes.patch b/qtbase-1-fixes.patch
index 561bad3dcc7e..37b9523b2442 100644
--- a/qtbase-1-fixes.patch
+++ b/qtbase-1-fixes.patch
@@ -126,66 +126,6 @@ index 3cfb614..8b7063f 100644
2.5.0
-From a6f45e15cf19e29afc5f42d1e87feb2b4f7e9532 Mon Sep 17 00:00:00 2001
-From: Boris Nagaev <bnagaev@gmail.com>
-Date: Sun, 18 Oct 2015 23:11:28 +0300
-Subject: [PATCH 6/8] configure: fix log corruption with option -v
-
-This bug occurs if ./configure is called with -v on systems on
-which fd proc entries point to the files/devices they are open
-on instead of being magic nodes which would basically dup() the
-actual fds (e.g., Linux).
-
-In this case, the command "tee $tty" appends to /dev/stderr, which
-may be already opened by the parent process. This breaks the log file.
-
-Normally, the log file starts with
-
- This is the Qt Open Source Edition.
- ...
-
-but with `-v` flag it would start with output of awkprog and maybe
-some zero bytes. Zero bytes are observed on Debian Wheezy.
-
- DEFAULT_INCDIRS=...
- ...
- ^@^@^@^@^@^@^@^@^@^@^@^@...
- Done running configuration tests.
- ...
-
-To fix this problem, the output of `...` is saved to a variable, and
-then eval'd and echo'd (if -v).
-
-This solution was found by Tony Theodore.
-https://github.com/mxe/mxe/issues/938#issuecomment-149770348
-
-Change-Id: Id0c28598890e813774cc92f38ee46a0697b34e77
-Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@theqtcompany.com>
-Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
-(cherry picked from commit 45fe3f1cde1e516d1ddccddb5e33ea4316497c36)
-
-diff --git a/configure b/configure
-index 4a4b478..a5c0fd5 100755
---- a/configure
-+++ b/configure
-@@ -3639,10 +3639,9 @@ END {
- print "DEFAULT_LIBDIRS=\"/lib\n/usr/lib\"\n";
- }'
-
--unset tty
--[ "$OPT_VERBOSE" = "yes" ] && tty=/dev/stderr
--eval "`LC_ALL=C $TEST_COMPILER $SYSROOT_FLAG $TEST_COMPILER_CXXFLAGS -xc++ -E -v - < /dev/null 2>&1 > /dev/null | $AWK "$awkprog" | tee $tty`"
--unset tty
-+awkprog_result=`LC_ALL=C $TEST_COMPILER $SYSROOT_FLAG $TEST_COMPILER_CXXFLAGS -xc++ -E -v - < /dev/null 2>&1 > /dev/null | $AWK "$awkprog"`
-+eval "$awkprog_result"
-+[ "$OPT_VERBOSE" = "yes" ] && echo "$awkprog_result"
-
- echo "Done running configuration tests."
-
---
-2.5.0
-
-
From 6064564099df17f7cddded8ec0c68d9e57d29ae9 Mon Sep 17 00:00:00 2001
From: Ray Donnelly <mingw.android@gmail.com>
Date: Wed, 26 Aug 2015 12:45:43 +0100