summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-03-09 00:31:00 +0100
committerMartchus2016-03-09 00:31:00 +0100
commitc584e340e884ea55eacee9bec24554e78bd03b70 (patch)
treeaaab7bea65ef57a5828ced49509cf1f2ee11e92e
parent6d87f25b9fd0357cfe3f702ab69e9218d8d8720c (diff)
downloadaur-c584e340e884ea55eacee9bec24554e78bd03b70.tar.gz
fixed bug caused by new ANGLE version
- enables required declarations from ANGLE headers to prevent build failure - rebuild ANGLE first since it needed a fix, too - updated this package just for consistency with ANGLE version, actually there is no rebuild required
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85d8e35ad12f..9c117e0dd48d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Feb 7 20:45:14 UTC 2016
+# Tue Mar 8 23:30:44 UTC 2016
pkgbase = mingw-w64-qt5-base-opengl
pkgdesc = A cross-platform application and UI framework (mingw-w64)
pkgver = 5.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.qt.io/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 57dd835c164c..fa5c45637d3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=mingw-w64-qt5-base-opengl
pkgver=5.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
arch=(i686 x86_64)
url="https://www.qt.io/"
@@ -252,8 +252,15 @@ build() {
# fix include directory of dbus
qt_configure_args+=" $(${_arch}-pkg-config --cflags-only-I dbus-1 --cflags)"
- isOpenGL && qt_configure_args+=' -opengl desktop'
- isStatic && qt_configure_args+=' -opengl no'
+ if isStatic; then
+ qt_configure_args+=' -opengl no'
+ elif isOpenGL; then
+ qt_configure_args+=' -opengl desktop'
+ else
+ # GL_GLEXT_PROTOTYPES must be defined to enable declarations GLES functions
+ qt_configure_args+=' -DGL_GLEXT_PROTOTYPES'
+ fi
+ # TODO: allow dynamic OpenGL configuration
unset PKG_CONFIG_PATH