aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-03-09 00:35:23 +0100
committerMartchus2016-03-09 00:35:23 +0100
commit6838c5d9f631a953d1da408128d7cdfa73a747a1 (patch)
treeba1267d7c59342bdb4a8f9bb295ccac1b5f611c3
parent426694d8c96eb48c42512ac4cbf65b8ee09aee1e (diff)
downloadaur-6838c5d9f631a953d1da408128d7cdfa73a747a1.tar.gz
fixed bug caused by new ANGLE version
- enables required declarations from ANGLE headers to prevent build failure - rebuild ANGLE first since it needed a fix, too - updated this package just for consistency with ANGLE version, actually there is no rebuild required
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46bcae6123b7..c589c8aa5034 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Mon Jan 4 04:57:19 UTC 2016
+# Tue Mar 8 23:33:05 UTC 2016
pkgbase = mingw-w64-qt5-base-static
pkgdesc = A cross-platform application and UI framework (mingw-w64)
pkgver = 5.5.1
- pkgrel = 1
- url = http://qt-project.org
+ pkgrel = 2
+ url = https://www.qt.io/
arch = i686
arch = x86_64
groups = mingw-w64-qt
@@ -33,7 +33,7 @@ pkgbase = mingw-w64-qt5-base-static
options = !strip
options = !buildflags
options = staticlibs
- source = http://download.qt-project.org/official_releases/qt/5.5/5.5.1/submodules/qtbase-opensource-src-5.5.1.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.5/5.5.1/submodules/qtbase-opensource-src-5.5.1.tar.xz
source = qt5-merge-static-and-shared-library-trees.patch
source = add-angle-support.patch
source = use-external-angle-library.patch
diff --git a/PKGBUILD b/PKGBUILD
index b1e19c467faa..ab84c7ddcd1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,14 @@
-# Maintainer: ant32 <antreimer@gmail.com>
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor: ant32 <antreimer@gmail.com>
# Contributor: Filip Brcic <brcha@gna.org>
# Contributor: jellysheep <max.mail@dameweb.de>
+
pkgname=mingw-w64-qt5-base-static
pkgver=5.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
arch=(i686 x86_64)
-url="http://qt-project.org"
+url="https://www.qt.io/"
license=("custom, FDL, GPL3, LGPL")
depends=(
mingw-w64-crt
@@ -33,7 +35,7 @@ makedepends=(mingw-w64-gcc
mingw-w64-pkg-config)
options=(!strip !buildflags staticlibs)
_pkgfqn="qtbase-opensource-src-${pkgver}"
-source=("http://download.qt-project.org/official_releases/qt/5.5/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
"qt5-merge-static-and-shared-library-trees.patch"
"add-angle-support.patch"
"use-external-angle-library.patch"
@@ -250,8 +252,15 @@ build() {
# fix include directory of dbus
qt_configure_args+=" $(${_arch}-pkg-config --cflags-only-I dbus-1 --cflags)"
- isOpenGL && qt_configure_args+=' -opengl desktop'
- isStatic && qt_configure_args+=' -opengl no'
+ if isStatic; then
+ qt_configure_args+=' -opengl no'
+ elif isOpenGL; then
+ qt_configure_args+=' -opengl desktop'
+ else
+ # GL_GLEXT_PROTOTYPES must be defined to enable declarations GLES functions
+ qt_configure_args+=' -DGL_GLEXT_PROTOTYPES'
+ fi
+ # TODO: allow dynamic OpenGL configuration
unset PKG_CONFIG_PATH