summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-02-19 20:15:17 +0100
committerMartchus2018-02-19 20:15:17 +0100
commit89fc27c4a3c5556994d48d0e45e52865427ef567 (patch)
tree491f3663af76118a031c53da6f0d2c097800c95c
parent0ad840a059b5ac56afb4ed2ac83e5bca2f829e6a (diff)
downloadaur-89fc27c4a3c5556994d48d0e45e52865427ef567.tar.gz
Update to 5.10.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9923c5bda62f..eaa561b2cf66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Dec 14 00:06:29 UTC 2017
+# Mon Feb 19 19:15:17 UTC 2018
pkgbase = mingw-w64-qt5-canvas3d
pkgdesc = A JavaScript 3D rendering API for Qt Quick (mingw-w64)
- pkgver = 5.10.0
+ pkgver = 5.10.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -19,8 +19,8 @@ pkgbase = mingw-w64-qt5-canvas3d
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.10/5.10.0/submodules/qtcanvas3d-everywhere-src-5.10.0.tar.xz
- sha256sums = d289626f06236f2c0e3065416fd6a8a72b8895cb5253ee2d9b6320df5b452987
+ source = https://download.qt.io/official_releases/qt/5.10/5.10.1/submodules/qtcanvas3d-everywhere-src-5.10.1.tar.xz
+ sha256sums = de829a8e6aa4b8496048e9b6f3bff306a80c35935855a94426025ddfb8bcb0c0
pkgname = mingw-w64-qt5-canvas3d
diff --git a/PKGBUILD b/PKGBUILD
index e35111c92a52..dabf06cd42f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_qt_module=qtcanvas3d
pkgname="mingw-w64-qt5-canvas3d"
-pkgver=5.10.0
+pkgver=5.10.1
pkgrel=1
arch=('any')
pkgdesc="A JavaScript 3D rendering API for Qt Quick (mingw-w64)"
@@ -20,7 +20,7 @@ license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('d289626f06236f2c0e3065416fd6a8a72b8895cb5253ee2d9b6320df5b452987')
+sha256sums=('de829a8e6aa4b8496048e9b6f3bff306a80c35935855a94426025ddfb8bcb0c0')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -52,6 +52,19 @@ package() {
pushd build-${_arch}-${_config##*=}
make INSTALL_ROOT="$pkgdir" install
+
+ # Use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ if [[ -d 'lib' ]]; then
+ pushd 'lib'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
+ popd
+ fi
+ if [[ -d 'plugins' ]]; then
+ pushd 'plugins'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib/qt/plugins" --parents {} +
+ popd
+ fi
+
# ensure to get the import lib, too
[[ "${_config##*=}" == 'shared' ]] &&
install -Dm755 qml/QtCanvas3D/*.dll -t "${pkgdir}/usr/${_arch}/bin" &&
@@ -67,5 +80,8 @@ package() {
find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
popd
done
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
done
}